Shutdown process hangs

Hello, when I wanted to shut down the laptop it got stuck on the following picture. Journalctl -p err returned the following information.

Apr 02 17:59:38 susanne-20hr002mge nmbd[1178]: [2024/04/02 17:59:38.528894,  0] ../../source3/nmbd/nmbd_nameq>
Apr 02 17:59:38 susanne-20hr002mge nmbd[1178]:   query_name_response: Multiple (2) responses received for a q>
Apr 02 17:59:38 susanne-20hr002mge nmbd[1178]:   This response was from IP 192.168.178.20, reporting an IP ad>
Apr 02 17:59:38 susanne-20hr002mge nmbd[1178]: [2024/04/02 17:59:38.528998,  0] ../../source3/nmbd/nmbd_nameq>
Apr 02 17:59:38 susanne-20hr002mge nmbd[1178]:   query_name_response: Multiple (3) responses received for a q>
Apr 02 17:59:38 susanne-20hr002mge nmbd[1178]:   This response was from IP 192.168.178.21, reporting an IP ad>
Apr 02 18:04:52 susanne-20hr002mge nmbd[1178]: [2024/04/02 18:04:52.133252,  0] ../../source3/nmbd/nmbd_nameq>
Apr 02 18:04:52 susanne-20hr002mge nmbd[1178]:   query_name_response: Multiple (2) responses received for a q>
Apr 02 18:04:52 susanne-20hr002mge nmbd[1178]:   This response was from IP 192.168.178.20, reporting an IP ad>
Apr 02 18:04:52 susanne-20hr002mge nmbd[1178]: [2024/04/02 18:04:52.133342,  0] ../../source3/nmbd/nmbd_nameq>
Apr 02 18:04:52 susanne-20hr002mge nmbd[1178]:   query_name_response: Multiple (3) responses received for a q>
Apr 02 18:04:52 susanne-20hr002mge nmbd[1178]:   This response was from IP 192.168.178.21, reporting an IP ad>
Apr 02 18:09:08 susanne-20hr002mge dbus-broker-launch[534]: Activation request for 'org.freedesktop.Avahi' fa>
Apr 02 18:09:08 susanne-20hr002mge dbus-broker-launch[534]: Activation request for 'org.bluez' failed.
Apr 02 18:09:08 susanne-20hr002mge dbus-broker-launch[534]: Activation request for 'org.freedesktop.nm_dispat>
Apr 02 18:09:08 susanne-20hr002mge dbus-broker-launch[534]: Activation request for 'org.bluez' failed.
Apr 02 18:09:08 susanne-20hr002mge dbus-broker-launch[534]: Activation request for 'org.freedesktop.nm_dispat>
Apr 02 18:09:09 susanne-20hr002mge dbus-broker-launch[534]: Activation request for 'org.freedesktop.nm_dispat>
-- Boot f569e72e17064c908950405d231a6e2d --
Apr 02 18:31:29 susanne-20hr002mge kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS failed (-95)
Apr 02 18:31:29 susanne-20hr002mge kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS failed (-95)
Apr 02 18:31:29 susanne-20hr002mge kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS failed (-95)
Apr 02 18:31:29 susanne-20hr002mge kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS failed (-95)
Apr 02 18:31:29 susanne-20hr002mge kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS failed (-95)
Apr 02 18:31:30 susanne-20hr002mge kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS failed (-95)
Apr 02 18:31:30 susanne-20hr002mge kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS failed (-95)
Apr 02 18:31:31 susanne-20hr002mge kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS failed (-95)
lines 1-27

System:
Kernel: 6.8.2-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0ed49918-7420-48a6-932a-26fef437d125 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 20HR002MGE v: ThinkPad X1 Carbon 5th
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 20HR002MGE v: SDK0J40697 WIN
serial: <superuser required> part-nu: LENOVO_MT_20HR_BU_Think_FM_ThinkPad
X1 Carbon 5th uuid: <superuser required> UEFI: LENOVO v: N1MET73W (1.58 )
date: 04/04/2023
Battery:
ID-1: BAT0 charge: 31.9 Wh (80.6%) condition: 39.6/57.0 Wh (69.4%)
power: 21.1 W volts: 12.9 min: 11.6 model: LGC 01AV429 type: Li-poly
serial: <filter> status: charging cycles: 378
CPU:
Info: model: Intel Core i7-7500U bits: 64 type: MT MCP arch: Amber/Kaby Lake
note: check gen: core 7 level: v3 note: check built: 2017
process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 9
microcode: 0xF4
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 800 min/max: 400/3500 scaling: driver: intel_pstate
governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 23199
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel HD Graphics 620 vendor: Lenovo ThinkPad X1 Carbon 5th Gen
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:5916 class-ID: 0300
Device-2: Chicony Integrated Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:3 chip-ID: 04f2:b5ce
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0x313d built: 2016 res: 1920x1080
hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.4-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 620 (KBL GT2)
device-ID: 8086:5916 memory: 15.02 GiB unified: yes
API: Vulkan v: 1.3.279 layers: 3 device: 0 type: integrated-gpu name: Intel
HD Graphics 620 (KBL GT2) driver: mesa intel v: 24.0.4-arch1.2
device-ID: 8086:5916 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.4-arch1.2 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo ThinkPad X1 Carbon
5th Gen driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
API: ALSA v: k6.8.2-zen2-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Ethernet I219-V vendor: Lenovo ThinkPad X1 Carbon 5th Gen
driver: e1000e v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15d8
class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:24fd
class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
IF-ID-1: wwp0s20f0u6i12 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Drives:
Local Storage: total: 476.94 GiB used: 74.89 GiB (15.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 51055KLA temp: 36.9 C
scheme: GPT
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 74.89 GiB (15.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 74.89 GiB (15.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 74.89 GiB (15.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 74.89 GiB (15.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.38 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 45.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 16 GiB note: est. available: 15.38 GiB used: 3.06 GiB (19.9%)
Processes: 219 Power: uptime: 13m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.14 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1533 libs: 429 tools: pamac,paru Compilers:
gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.1 running-in: konsole
inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2024-04-01
Last full system update: 2024-04-03
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

That doesn’t help, but you’re not alone:

I quickly see 3 commonalities with potential:

Kernel: 6.8.2-zen2-1-zen
Desktop: KDE Plasma v: 6.0.3
Windows dual boot: Probably (Run as root to verify)
4 Likes

And like in the other thread, my initial troubleshooting step is always: try with a different kernel, starting with linux-lts (and headers)

4 Likes

Maybe also check this (e.g. try disabling bluetooth):
https://bbs.archlinux.org/viewtopic.php?pid=2161144
And relevant links therein.

3 Likes

First of all, thank you for your feedback. I didn’t have Bluetooth turned on. I switched to the LTS kernel but when I shut down the laptop it still hangs.

The “funny” thing is that it also changes the DHCP setting in the BIOS, so WOL no longer works. Only

sudo poweroff

works for me.
It is also strange that on a multiboot computer it only happens with KDE and Hyprland and not with i3wm.
Thanks for the link filo :slight_smile:

5 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.