Shell changed but not actually changed

Hi, I wanted to change my default shell to zsh. The problem is that after I followed the steps in the Arch Wiki, my system says that my shell is changed, but I still get an error, that fish, which I don't use anymore I thought, doesn't allow something which I also don't understand.

I hope someone can help with this...

Here is the console output:

╭─[email protected] in ~ took 46ms
╰─λ echo $SHELL
/bin/zsh

╭─[email protected] in ~
╰─λ eval "$(ssh-agent -s)"
fish: $(...) is not supported. In fish, please use '(ssh-agent)'.
eval "$(ssh-agent -s)"

Your shell is probably being set in your terminal to fish. Check the terminal settings.

4 Likes
eval (ssh-agent -c)

Until you figure out your shell problem. Also please report back because my terminal does this too, how odd.

Eg for konsole

3 Likes

Thats odd. But thx with changing the path in the console profile to the right shell, it worked :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.