Set system power profile discrete to GPU issues

Hey ! Im new to this awesome distro and I run DaVinci resolve Studio on Ubuntu just fine but cant get Davinci to use discrete GPU for it?

Here is the error and I have searched Arch wiki and none of the help seems to work for me:

"Please ensure that the system power profile is set to
use the discrete GPU for DaVinci Resolve and that the
displays are not connected to the integrated GPU".

Any help will be appreciated and many thanks to the developers !

boot into to your dgpu in optimus manager then try it

1 Like

Assuming this is a nvidia dgpu
Post output of this command

lspci -nnk | grep "nvidia"

Try these in the meantime

1st.If u have optimus manager than switch to nvidia option and try and even if that doesn't work
2. try prime-run ur app name in terminal
If u can't go in nvidia mode then u probably have some problems with drivers
3. According to ur post display should be on descrete GPU Im not sure if I understand exactly what it consequences it should have but does it want whole system to be running of nvidia gpu? I mean optimus-manager leaves intel GPU connected to display and renders stuff on dgpu and then passes it on to the integrated GPU.
4. if nothing works and u have working nvidia drivers then try this on optimus laptop I don't know if it will work on muxless but anyways


This is a paid software. Does purchasing a license not provide support for such issues?


Thanks :slight_smile: Ill try these,

The output is :

lspci -nnk | grep "nvidia"

Kernel driver in use: nvidia
Kernel modules: nouveau, nvidia_drm, nvidia

Ill get back to you and many many thanks for taking the time :slight_smile:

Maybe , I have used it for years on Debian based systems so it would make more sense to ask here as they dont support Arch.

Who said they don't