Screenshot problem

i can't take a screenshot

On your printer?

A little more information would be helpful to be able to help you.
Ein paar Informationen mehr wären hilfreich um dir helfen zu können.

inxi -Fxxxza

i can't take a screenshot, on garuda screen capture don't work. not with flameshot and spactacle, screenshot is not working.

KDE? Or one of the many other DEs that Garuda offers?
Do you use lite or ultimate or Barebones version?
You see, "it do not work", is not enough for asking for help.
BTW, it work on i3wm and KDE on my PC.

⣿⣿⣿⡷⠊⡢⡹⣦⡑⢂⢕⢂⢕⢂⢕⢂⠕⠔⠌⠝⠛⠶⠶⢶⣦⣄⢂⢕⢂⢕ --------------------------
⣿⣿⠏⣠⣾⣦⡐⢌⢿⣷⣦⣅⡑⠕⠡⠐⢿⠿⣛⠟⠛⠛⠛⠛⠡⢷⡈⢂⢕⢂ OS: Garuda Linux x86_64
⠟⣡⣾⣿⣿⣿⣿⣦⣑⠝⢿⣿⣿⣿⣿⣿⡵⢁⣤⣶⣶⣿⢿⢿⢿⡟⢻⣤⢑⢂ Kernel: 5.9.1-zen2-1-zen
⣾⣿⣿⡿⢟⣛⣻⣿⣿⣿⣦⣬⣙⣻⣿⣿⣷⣿⣿⢟⢝⢕⢕⢕⢕⢽⣿⣿⣷⣔ Uptime: 6 hours, 29 mins
⣿⣿⠵⠚⠉⢀⣀⣀⣈⣿⣿⣿⣿⣿⣿⣿⣿⣿⣗⢕⢕⢕⢕⢕⢕⣽⣿⣿⣿⣿ Packages: 1962 (pacman)
⢷⣂⣠⣴⣾⡿⡿⡻⡻⣿⣿⣴⣿⣿⣿⣿⣿⣿⣷⣵⣵⣵⣷⣿⣿⣿⣿⣿⣿⡿ Shell: zsh 5.8
⢌⠻⣿⡿⡫⡪⡪⡪⡪⣺⣿⣿⣿⣿⣿⠿⠿⢿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠃ DE: Plasma 5.20.1
⠣⡁⠹⡪⡪⡪⡪⣪⣾⣿⣿⣿⣿⠋⠐⢉⢍⢄⢌⠻⣿⣿⣿⣿⣿⣿⣿⣿⠏⠈ WM: KWin
⡣⡘⢄⠙⣾⣾⣾⣿⣿⣿⣿⣿⣿⡀⢐⢕⢕⢕⢕⢕⡘⣿⣿⣿⣿⣿⣿⠏⠠⠈ WM Theme: WhiteSur-dark
⠌⢊⢂⢣⠹⣿⣿⣿⣿⣿⣿⣿⣿⣧⢐⢕⢕⢕⢕⢕⢅⣿⣿⣿⣿⡿⢋⢜⠠⠈ CPU: AMD FX-8150 (8) @ 3.800GHz
⠄⠁⠕⢝⡢⠈⠻⣿⣿⣿⣿⣿⣿⣿⣷⣕⣑⣑⣑⣵⣿⣿⣿⡿⢋⢔⢕⣿⠠⠈ GPU: AMD ATI Radeon RX 470/480/570/570X/580/580X/590
⠨⡂⡀⢑⢕⡅⠂⠄⠉⠛⠻⠿⢿⣿⣿⣿⣿⣿⣿⣿⣿⡿⢋⢔⢕⢕⣿⣿⠠⠈ Memory: 6466MiB / 11959MiB
⠄⠪⣂⠁⢕⠆⠄⠂⠄⠁⡀⠂⡀⠄⢈⠉⢍⢛⢛⢛⢋⢔⢕⢕⢕⣽⣿⣿⠠⠈ Song: Shayne Hartford - Unknown Album - Genshin Impact on LINUX!

inxi -Fxxxza is not working

What is the output in terminal/konsole from

inxi -Fxxxza

Did you reboot in KDE after updates?

If nothing help restore last working snapshot.

ultimate

System:    Kernel: 5.9.1-zen2-1-zen x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/vmlinuz-linux-zen root=UUID=62e1017a-d087-4b4a-a211-bd48c1081f1d rw 
           [email protected] quiet splash loglevel=3 
           Desktop: KDE Plasma 5.20.1 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: GA-78LMT-USB3 6.0 serial: <filter> BIOS: Award v: F2 
           date: 11/25/2014 
CPU:       Info: 8-Core model: AMD FX-8150 bits: 64 type: MCP arch: Bulldozer family: 15 (21) model-id: 1 
           stepping: 2 microcode: 600063E L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 61072 
           Speed: 1416 MHz min/max: 1400/3800 MHz boost: disabled Core speeds (MHz): 1: 1412 2: 1417 3: 1419 
           4: 1425 5: 1419 6: 1432 7: 1424 8: 1472 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: PC Partner Limited driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu FAILED: ati 
           unloaded: modesetting,radeon alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") diag: 547mm (21.5") 
           OpenGL: renderer: AMD Radeon RX 480 Graphics (POLARIS10 DRM 3.39.0 5.9.1-zen2-1-zen LLVM 10.0.1) 
           v: 4.6 Mesa 20.2.1 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel 
           v: kernel bus ID: 00:14.2 chip ID: 1002:4383 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: PC Partner Limited 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aaf0 
           Sound Server: ALSA v: k5.9.1-zen2-1-zen 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 
           v: kernel port: ce00 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Microsoft Xbox 360 Wireless Adapter type: USB driver: usbfs bus ID: 5-1:2 
           chip ID: 045e:0719 serial: <filter> 
Drives:    Local Storage: total: 763.85 GiB used: 580.75 GiB (76.0%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Samsung model: ST500LM012 HN-M500MBB size: 465.76 GiB block size: 
           physical: 4096 B logical: 512 B speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0001 
           scheme: MBR 
           ID-2: /dev/sdb vendor: Samsung model: HD322HJ size: 298.09 GiB block size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 1118 scheme: MBR 
Partition: ID-1: / raw size: 44.74 GiB size: 44.74 GiB (100.00%) used: 41.94 GiB (93.7%) fs: btrfs 
           dev: /dev/sdb2 
           ID-2: /boot raw size: 500.0 MiB size: 476.2 MiB (95.24%) used: 315.7 MiB (66.3%) fs: ext4 
           dev: /dev/sda1 
           ID-3: /home raw size: 465.27 GiB size: 456.97 GiB (98.22%) used: 374.23 GiB (81.9%) fs: ext4 
           dev: /dev/sda2 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 373.7 MiB used: 332.1 MiB (88.9%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 373.7 MiB used: 326.8 MiB (87.4%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 373.7 MiB used: 328.7 MiB (88.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 373.7 MiB used: 313.9 MiB (84.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 373.7 MiB used: 331.6 MiB (88.7%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 373.7 MiB used: 329.1 MiB (88.1%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 373.7 MiB used: 332.0 MiB (88.8%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 373.7 MiB used: 317.3 MiB (84.9%) priority: 32767 dev: /dev/zram7 
           ID-9: swap-9 type: partition size: 2.00 GiB used: 0 KiB (0.0%) priority: 1024 dev: /dev/sdb4 
Sensors:   System Temperatures: cpu: 33.0 C mobo: N/A gpu: amdgpu temp: 47.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 703 
Info:      Processes: 354 Uptime: 6h 28m Memory: 11.68 GiB used: 6.28 GiB (53.8%) Init: systemd v: 246 
           Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: pacman: 1962 lib: 565 flatpak: 0 Shell: Zsh v: 5.8 
           running in: konsole inxi: 3.1.06

Try reboot first and then

flameshot gui -d 5000

i did not it but this problem is occurring since I reinstalled garuda

"flameshot gui -d 5000" is working

Ok, I boot in KDE, there the "Print" Button on keyboard doesn't work.
I always use the icon in taskbar for screenshot in KDE, in i3wm the button work.

So it is maybe a KDE bug if it works before.

On my kde lite install printscreen using windows key /prtscr works

1 Like

https://www.joe0.com/2019/02/15/how-to-take-screenshots-using-flameshot-in-kde-plasma-desktop-ubuntu-18-10-and-associate-it-with-the-print-prt-sc-keyboard-shortcut/

done
image

1 Like