Screen not staying off with energy saving options enabled

Hello, I am very much enjoying the distro during the short time I have used it, but unfortunately I'm a noob and am trying to work a few things out that I have not found a solution for.

Under Settings > Power Management > Energy Saving

I have the "Screen energy saving" box checked, with a switch off time of 10 minutes. After this time the screen does turn off, for about 5 seconds, and then immediately turns back on.

System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=78cb144b-5cd4-4e11-ba58-cad9614c53fa rw rootf[email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3
           Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: ASUS product: N/A v: N/A serial: <filter>
           Mobo: ASUSTeK model: TUF GAMING B560M-PLUS WIFI v: Rev 1.xx serial: <filter>
           UEFI: American Megatrends v: 1017 date: 07/13/2021
CPU:       Info: 8-Core model: 11th Gen Intel Core i7-11700K bits: 64 type: MT MCP
           arch: Rocket Lake family: 6 model-id: A7 (167) stepping: 1 microcode: 40 cache:
           L2: 16 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 115200
           Speed: 4744 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 4744 2: 4721 3: 4882
           4: 4814 5: 4964 6: 4735 7: 4873 8: 4900 9: 4894 10: 4873 11: 4989 12: 4933 13: 4886
           14: 4909 15: 4900 16: 4886
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
           vendor: Sapphire Limited driver: amdgpu v: kernel bus-ID: 03:00.0 chip-ID: 1002:731f
           class-ID: 0300
           Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
           unloaded: modesetting,radeon alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
           s-diag: 582mm (22.9")
           Monitor-1: HDMI-A-1 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2")
           diag: 686mm (27")
           OpenGL:
           renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.42.0 5.15.2-zen1-1-zen LLVM 13.0.0)
           v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
           Device-2: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel bus-ID: 03:00.1
           chip-ID: 1002:ab38 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
           chip-ID: 8086:43f0 class-ID: 0280
           IF: wlo1 state: up mac: <filter>
           Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel port: 4000
           bus-ID: 06:00.0 chip-ID: 10ec:8125 class-ID: 0200
           IF: enp6s0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:7
           chip-ID: 8087:0026 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 931.51 GiB used: 20.55 GiB (2.2%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB size: 931.51 GiB
           block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
           serial: <filter> rev: 1B4QFXO7 temp: 35.9 C scheme: GPT
Partition: ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 20.55 GiB (2.2%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%)
           fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
           ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 20.55 GiB (2.2%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 20.55 GiB (2.2%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 20.55 GiB (2.2%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 31.16 GiB used: 4.2 MiB (0.0%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 27.8 C mobo: N/A gpu: amdgpu temp: 52.0 C mem: 44.0 C
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:      Processes: 390 Uptime: 22m wakeups: 0 Memory: 31.16 GiB used: 3.94 GiB (12.6%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages:
           pacman: 1850 lib: 548 Client: Unknown Client: garuda-assistant inxi: 3.3.08

To solve that problem with mine, I insert a short, one line configuration file named "snd_hda_intel.conf" in /etc/modprobe.d. That line says:

"options snd_hda_intel power_save=0"

It keeps peripheral/sound stuff from polling & re-awakening my PC.

7 Likes

Ok, I've made the file and will give this a shot. Thank you

is this a known bug in the gui?

It's an intel power-saving bug thing. And a 'known' fix (at least in Arch), which is why it is important to have information such as an inxi output, which you thankfully provided, and which showed you had intel sound and was using the snd_hda_intel.

However, please note that your inxi also says:

Which is vague to me but seems to state that an alternate driver may be/can be used. Again, that line is vague to me but probably not to more knowledgeable forum people.

Anyway, try the fix provided, reboot, and see what happens. There's nothing harmful with it.

4 Likes

Sorry to revive a thread from a couple of days ago (here) but unfortunately the fix from that thread did not work.

Under Settings > Power Management > Energy Saving

I have the "Screen energy saving" box checked, with a switch off time of 10 minutes. After this time the screen does turn off, for about 5 seconds, and then immediately turns back on.

The fix from user c00ter from the other thread: To solve that problem with mine, I insert a short, one line configuration file named "snd_hda_intel.conf" in /etc/modprobe.d. That line says:

"options snd_hda_intel power_save=0"

It keeps peripheral/sound stuff from polling & re-awakening my PC.

System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=78cb144b-5cd4-4e11-ba58-cad9614c53fa rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3
           Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: ASUS product: N/A v: N/A serial: <filter>
           Mobo: ASUSTeK model: TUF GAMING B560M-PLUS WIFI v: Rev 1.xx serial: <filter>
           UEFI: American Megatrends v: 1017 date: 07/13/2021
CPU:       Info: 8-Core model: 11th Gen Intel Core i7-11700K bits: 64 type: MT MCP
           arch: Rocket Lake family: 6 model-id: A7 (167) stepping: 1 microcode: 40 cache:
           L2: 16 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 115200
           Speed: 4881 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 4881 2: 4909 3: 4872
           4: 4698 5: 4958 6: 4996 7: 4900 8: 4822 9: 4832 10: 4856 11: 4965 12: 4911 13: 4826
           14: 4884 15: 4845 16: 4900
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
           vendor: Sapphire Limited driver: amdgpu v: kernel bus-ID: 03:00.0 chip-ID: 1002:731f
           class-ID: 0300
           Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
           unloaded: modesetting,radeon alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
           s-diag: 582mm (22.9")
           Monitor-1: HDMI-A-1 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2")
           diag: 686mm (27")
           OpenGL:
           renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.42.0 5.15.2-zen1-1-zen LLVM 13.0.0)
           v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
           Device-2: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel bus-ID: 03:00.1
           chip-ID: 1002:ab38 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
           chip-ID: 8086:43f0 class-ID: 0280
           IF: wlo1 state: up mac: <filter>
           Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel port: 4000
           bus-ID: 06:00.0 chip-ID: 10ec:8125 class-ID: 0200
           IF: enp6s0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:7
           chip-ID: 8087:0026 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 931.51 GiB used: 37.9 GiB (4.1%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB size: 931.51 GiB
           block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
           serial: <filter> rev: 1B4QFXO7 temp: 35.9 C scheme: GPT
Partition: ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 37.9 GiB (4.1%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%)
           fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
           ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 37.9 GiB (4.1%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 37.9 GiB (4.1%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 37.9 GiB (4.1%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 31.16 GiB used: 2.2 MiB (0.0%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 27.8 C mobo: N/A gpu: amdgpu temp: 51.0 C mem: 44.0 C
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:      Processes: 414 Uptime: 49m wakeups: 0 Memory: 31.16 GiB used: 6.63 GiB (21.3%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages:
           pacman: 1850 lib: 548 Client: Unknown Client: garuda-assistant inxi: 3.3.08