Screen goes black during installation Garuda Linux

I've created a bootable Garuda (Dragonized BlackArch Edition) USB stick (DD image).
during installation at GRUB when I select open source or proprietary drivers the screen goes black and nothin happens after that, the laptop is on but the screen is black pressing random keys nothin happens.
i cant go pass GRUB menu.
I've tested the USB stick with another Laptop which is AMD A8 processer and the screen doesn't goes black and installation is normal.
what problem might be? is my laptop not supported?

legacy mode is disabled and safe boot is also off.

my Specs :
Hp ProBook 450 G7
intel Core i5 @ 1.60GHz (8 CPUs)
8 GB ram
intel UHD Graphics

Hi there, welcome!
Would you please try to check in your BIOS UEFI settings if Legacy mode is not disabled, and if so, disable it and try again? Also make sure that Secure boot is off there.


@filo yes both the settings are disabled I've that way still not working

Just found this, which seems interesting/applicable.
It looks like the issue persists with recent kernels, but it seems that it should be working if connecting via HDMI with an external monitor...
In my opinion, if you manage to install using an external monitor (or with nomodeset) and then install the linux-lts kernel (5.10) you should be fine.


@filo I humbly agree. That sounds like a kernel conflict issue. Love your solution to it. I didn't think of that until you posted it. :grinning:


Also, try KDE barebones. It comes with LTS. It should boot fine, if kernel is at fault. Then, you can simply install Garuda-dr460nized-config to upgrade to dr460nized edition.


thnks a lot, downgraded the kernel and it worked.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.