Samsung Galaxy A03 driver

Hey everyone,

So I got a problem, I bought a new phone a few days ago (Samsung Galaxy A03) but I can't connect it to my computer using an USB cable, my phone just charge but I can't transfer files to my laptop, my files manager doesn't detect my phone.
I think it's a problem with a missing driver but I can't find any samsung driver for linux on the internet.
If someone know where I can find those drivers or if it's another problem it will be very helpful.

Try a different cable as some only charge not for data use

3 Likes

I used the cable of my previous phone and it was able to transfer data, I also try with the cable that was in the phone box but it doesn't work too.

So, problem solved, I mark it.

garuda-inxi?
KDE?
Use kde-connect then or X-plore (ssh,wlan, ...)

1 Like

Sorry, when I said it was able to transfer data it was with my old phone but not with the new one

Sorry my English :smiley:

garuda-inxi?
KDE?
Use kde-connect then or X-plore (ssh,wlan, ...)

1 Like

Need the phone, data tranfer in settings/popup, Developer options/adb allowed?
Can you check in terminal
adb-devices
?
Did you ask in XDA forum?

1 Like

Sorry but I don't understand what you mean, my developer options and USB debbuging are allowed.
The command adb devices says that their is no device attached

Your other phone with the good cable work fine with Garuda?
There is no special driver for different (Samsung) phones, correct?
Again, did you ask or search in XDA forum or web?

When you connect the phone there will be a notification saying "Charging via USB, Tap to change". Tap that and change the connection to "Data transfer". You can also access that via the phone Settings.

2 Likes

Yes my other phone works perfectly with Garuda and I havn't ask in XDA forum but I will do.
For the notification, I have the one that say "Charging via USB" but there is no propositions to change the connection type even if the default connection is set on "Transfer Files", moreover when I go to my Internet settings to share my connection via USB it tells me that there is no USB devices connected

Some phones default to charge only on USB. Mine also does this. Search USB in your settings and change to "USB controlled by" to "Connected device" (your computer).

Choose file transfer or tethering or whatever you want under "Use USB for".

Mine is all greyed out because I don't have a connection right now, but if your cable is good you should be able to access the settings you need.

1 Like


I already done that but it change nothing to my problem, my computer and my phone both can't detect each other.

Firewall on phone or comp?

1 Like

There is no firewall on both my computer or my phone

What about the cable? Have you tried the new phone with the old cable, or another cable?

What sort of cable are you using?

1 Like