Running a game

Hello again :sweat_smile:, i was trying to run gta san but it isnot launching. I had tried to fix it by using winetricks d3dx9 vcrun2010 but still it isnt launching.. i also updated wine. here is my Garuda-inxi : garuda-inxi

System:
Kernel: 6.4.10-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=841fed05-c7a1-4710-85fc-de712c660e4a rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=100ebd16-08c1-416a-835e-5f1db5650c37 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: INTEL model: H61 serial: <superuser required>
UEFI: American Megatrends v: 4.6.5 date: 05/29/2019
CPU:
Info: model: Intel Core i3-3220 bits: 64 type: MT MCP arch: Ivy Bridge
gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 3292 high: 3293 min/max: 1600/3300 scaling:
driver: intel_cpufreq governor: performance cores: 1: 3291 2: 3292 3: 3292
4: 3293 bogomips: 26339
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics driver: i915
v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
active: VGA-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:0152 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: VGA-1 model: EW32S3PW serial: <filter> built: 2012
res: 1366x768 hz: 60 dpi: 30 gamma: 1.2 size: 1150x650mm (45.28x25.59")
diag: 1321mm (52") ratio: 16:9 modes: max: 1366x768 min: 720x400
API: OpenGL v: 4.2 Mesa 23.1.5 renderer: Mesa Intel HD Graphics 2500 (IVB
GT1) direct-render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
class-ID: 0403
API: ALSA v: k6.4.10-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0
chip-ID: 10ec:8136 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Ralink MT7601U Wireless Adapter driver: mt7601u type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-1.6:6
chip-ID: 148f:7601 class-ID: 0000 serial: <filter>
IF: wlp0s29u1u6 state: up mac: <filter>
Drives:
Local Storage: total: 628.27 GiB used: 68.03 GiB (10.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500DM002-1BD142
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: KC48 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 model: SATA SSD 128GB size: 119.24 GiB
block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s tech: SSD
serial: <filter> fw-rev: 537 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: SanDisk model: Cruzer Blade
size: 14.59 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
fw-rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-4: /dev/sdd maj-min: 8:48 vendor: SanDisk model: USB 3.2Gen1
size: 28.67 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
fw-rev: 1.00 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 112.74 GiB size: 112.74 GiB (100.00%) used: 15 GiB (13.3%)
fs: btrfs dev: /dev/sdb3 maj-min: 8:19
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 435.76 GiB size: 435.76 GiB (100.00%)
used: 53.03 GiB (12.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/log raw-size: 112.74 GiB size: 112.74 GiB (100.00%)
used: 15 GiB (13.3%) fs: btrfs dev: /dev/sdb3 maj-min: 8:19
ID-5: /var/tmp raw-size: 112.74 GiB size: 112.74 GiB (100.00%)
used: 15 GiB (13.3%) fs: btrfs dev: /dev/sdb3 maj-min: 8:19
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 6.72 GiB used: 1.33 GiB (19.7%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sdb2 maj-min: 8:18
Sensors:
System Temperatures: cpu: 47.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 277 Uptime: 1h 0m wakeups: 0 Memory: total: 8 GiB note: est.
available: 6.72 GiB used: 2.5 GiB (37.2%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 15.0.7
Packages: pm: pacman pkgs: 2147 libs: 567 tools: octopi,pamac,paru
Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.28
Garuda (2.6.16-1):
System install date:     2023-08-12
Last full system update: 2023-08-13
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:
  1. How did you install the game? Which store?
  2. Run it from the terminal and share the log.
3 Likes

For reference, here's compatibility report of GTA San
https://www.protondb.com/app/12120

i am using wine bcz proton give me this error : Protontricks was closed due to the following error:

No Proton enabled Steam apps were found. Have you launched one of the apps at least once?

=============

Please include this entire error message when making a bug report.
Log messages:

Found Steam directory at /home/p******/.local/share/Steam
Found 1 Steam library folders
Currently logged-in Steam user: p****
Couldn't find custom shortcuts. Maybe none have been created yet?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.