Rtlwifi module loading error

Hello Garuda users.

Kernel: 5.18.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c8f869ce-554b-4598-b90a-a257e270b783 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Pavilion 15 Notebook PC v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 22A9 v: 72.48 serial: <superuser required>
UEFI: American Megatrends v: F.46 date: 04/18/2018
Battery:
ID-1: BAT0 charge: 20.4 Wh (100.0%) condition: 20.4/20.4 Wh (100.0%)
volts: 16.8 min: 14.8 model: Hewlett-Packard Primary type: Li-ion
serial: N/A status: charging cycles: 183
CPU:
Info: model: AMD A10-7300 Radeon R6 10 Compute Cores 4C+6G bits: 64
type: MT MCP arch: Steamroller built: 2014 process: GF 28nm
family: 0x15 (21) model-id: 0x30 (48) stepping: 1 microcode: 0x6003109
Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 256 KiB desc: d-4x16
KiB; i-2x96 KiB L2: 4 MiB desc: 2x2 MiB
Speed (MHz): avg: 1896 min/max: 1100/1900 boost: enabled scaling:
driver: acpi-cpufreq governor: schedutil cores: 1: 1896 2: 1896 3: 1896
4: 1896 bogomips: 15171
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Kaveri [Radeon R6 Graphics] vendor: Hewlett-Packard
driver: radeon v: kernel alternate: amdgpu arch: GCN-2 code: Sea Islands
process: GF/TSMC 16-28nm built: 2013-17 ports: active: HDMI-A-1,eDP-1
empty: none bus-ID: 00:01.0 chip-ID: 1002:130a class-ID: 0300
Device-2: Cheng Uei Precision Industry (Foxlink) Webcam type: USB
driver: uvcvideo bus-ID: 2-4:2 chip-ID: 05c8:036e class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: radeon
unloaded: fbdev,modesetting,vesa gpu: radeon display-ID: :0 screens: 1
Screen-1: 0 s-res: 3286x1080 s-dpi: 96 s-size: 869x285mm (34.21x11.22")
s-diag: 915mm (36.01")
Monitor-1: HDMI-A-1 mapped: HDMI-0 pos: primary,top-right
model: Kingston 40TV serial: <filter> built: 2019 res: 1920x1080 hz: 60
dpi: 69 gamma: 1.2 size: 708x398mm (27.87x15.67") diag: 1015mm (40")
ratio: 16:9 modes: max: 1920x1080 min: 640x480
Monitor-2: eDP-1 mapped: eDP pos: bottom-l model: AU Optronics 0x43ec
built: 2013 res: 1366x768 hz: 60 dpi: 101 gamma: 1.2
size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9 modes:
max: 1366x768 min: 640x480
OpenGL: renderer: AMD KAVERI (LLVM 14.0.6 DRM 2.50 5.18.16-zen1-1-zen)
v: 4.5 Mesa 22.1.6 direct render: Yes
Audio:
Device-1: AMD Kaveri HDMI/DP Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:1308
class-ID: 0403
Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel
v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
Sound Server-1: ALSA v: k5.18.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: N/A modules: rtl8723be pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 01:00.0 chip-ID: 10ec:b723
class-ID: 0280
Device-2: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8136
class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
IF-ID-1: br-c5322a07816b state: down mac: <filter>
IF-ID-2: docker0 state: down mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 3-3:2 chip-ID: 0bda:b001 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 1 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 465.76 GiB used: 232.15 GiB (49.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
Partition:
ID-1: / raw-size: 72.53 GiB size: 72.53 GiB (100.00%) used: 53.19 GiB
(73.3%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-2: /boot/efi raw-size: 100 MiB size: 98.4 MiB (98.42%) used: 27.5 MiB
(27.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 72.53 GiB size: 72.53 GiB (100.00%) used: 53.19 GiB
(73.3%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 72.53 GiB size: 72.53 GiB (100.00%) used: 53.19
GiB (73.3%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-5: /var/tmp raw-size: 72.53 GiB size: 72.53 GiB (100.00%) used: 53.19
GiB (73.3%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 14.59 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 68.9 C mobo: N/A gpu: radeon temp: 69.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 237 Uptime: 56m wakeups: 2 Memory: 14.59 GiB used: 2.96 GiB
(20.3%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 2304 lib: 509
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.20
Garuda (2.6.5-1):
System install date:     2021-12-24
Last full system update: 2022-08-29 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            fancontrol.service samba.service

as you can see in network section

Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: N/A modules: rtl8723be pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 01:00.0 chip-ID: 10ec:b723
class-ID: 0280

diver: N/A
and the wifi connection doesnt work!
the sudo modprobe rtl8723be response is:

modprobe: ERROR: Error running install command '/bin/false' for module rtlwifi: retcode 1
modprobe: ERROR: could not insert 'rtl8723be': Invalid argument

how can i make the wifi connection work?
and i have to mention i installed the OS on another pc and now using the hard disk in a new laptop

https://wiki.archlinux.org/title/Network_configuration/Wireless

I keep my fingers crossed that the other components/drivers of the PC are the same, starting with the UUID of the HDD/SSD/Nvme.

Did the update show you if grub was fixed or if you have to do it manually or was there no hint?
You should check this before you reboot.

Read!

Loading BIOS (Grub1) endlessly after system update ussing Garuda Assistant
Issues & Assistance
1h - ╭─[email protected] in ~ via  v8.1.9 ╰─λ pacman -Qi grub Name : grub Version : 2:2.06.r322.gd9b4638c5-1 Description : GNU GRand Unified Bootloader (2) Architecture : x86_64 URL : GNU GRUB - GNU Project - Free Software Foundation (FSF) Licenses : GPL3 Groups : None Provides : grub-common grub-bios grub-emu grub-efi-x8...
Stuck in boot loop after update
Issues & Assistance
2h - Problem is in kde-lite latest ISO maybe Now I tried with old kde-git iso and it booted fine Then I used Boot Repair utility and selected ESP mode , It quickly repaired boot but showed some overlay error Then I rebooted to old installation and it worked without causing bootloops Thanks for making ...
Grub FDE Slot 0 Opened but nothing happens
Issues & Assistance
2h - Hello everyone, I've been using garuda for about a year now and im really happy with it. I always use FDE (Full Disk Encryption) and had issues before with LUKS on Manjaro. After some update LUKS couldn't decrypt the drive for no apparent reason. It looked like it was a problem with my graphics c...

1 Like

thnks for the help.
its third time i move my hard disk from a laptop to another and until now i had no problem with grub. and so there was no hint or problem from grub or anything, just driver issues like this sometimes. buy the way is it safe? ( considering i use just UUID's in fstab file for mounting )

removing the /etc/modprobe.d foolder content and then using command:
sudo modprobe rtl8723be ant_sel=1
fixed the problem

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.