RTL8821CE - Wifi keeps disconnecting

I'm facing a problem while using wifi.
It keeps disconnecting in between.

And throw this error in notification saying. Wifi deactivated.

wireless interface wlan0
authentication application timed out

No problem while connecting. It just it gets disconnected while I have some important stuff to do.

I'm new to linux. Please bare with me.
Will share if any logs are required.

Turn off wifi power saving.

1 Like

If was disabled by default.

I would then try disabling IPv6.

Please post:

inxi -Faz
1 Like
System:    Kernel: 5.13.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=cbc1d73a-a184-4c73-a229-b806a17fcb87  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: HP product: HP Pavilion Laptop 15-cs2xxx v: Type1ProductConfigId  
serial: <filter> Chassis: type: 10 serial: <filter>  
Mobo: HP model: 84C1 v: 15.32 serial: <filter> UEFI: Insyde v: F.23 date: 12/25/2020  
Battery:   ID-1: BAT0 charge: 28.6 Wh (100.0%) condition: 28.6/28.6 Wh (100.0%) volts: 13.0 min: 11.6  
model: HP Primary type: Li-ion serial: N/A status: Full  
CPU:       Info: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Kaby Lake note: check  
family: 6 model-id: 8E (142) stepping: B (11) microcode: EA cache: L2: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800  
Speed: 3426 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 3426 2: 3728 3: 3693 4: 3779  
5: 3736 6: 3648 7: 3688 8: 3644  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf status: Not affected  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Hewlett-Packard driver: i915  
v: kernel bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300  
Device-2: NVIDIA GP108M [GeForce MX250] vendor: Hewlett-Packard driver: nvidia v: 470.57.02  
alternate: nouveau,nvidia_drm bus-ID: 02:00.0 chip-ID: 10de:1d13 class-ID: 0302  
Device-3: Quanta HP Wide Vision HD Camera type: USB driver: uvcvideo bus-ID: 1-3:2  
chip-ID: 0408:5300 class-ID: 0e02 serial: <filter>  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia  
display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")  
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.1.6 direct render: Yes  
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Hewlett-Packard  
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3  
chip-ID: 8086:9dc8 class-ID: 0403  
Sound Server-1: ALSA v: k5.13.7-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.32 running: yes  
Network:   Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard  
driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 4000 bus-ID: 03:00.0 chip-ID: 10ec:c821  
class-ID: 0280  
IF: wlo1 state: up mac: <filter>  
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard  
driver: r8169 v: kernel port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200  
IF: eno1 state: down mac: <filter>  
Bluetooth: Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8 bus-ID: 1-10:3  
chip-ID: 0bda:b00a class-ID: e001 serial: <filter>  
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>  
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 6060  
bus-ID: 00:17.0 chip-ID: 8086.282a rev: 30 class-ID: 0104  
Drives:    Local Storage: total: 1.14 TiB used: 14.29 GiB (1.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC501 HFM256GDJTNG-8310A
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD
serial: <filter> rev: 80002C00 temp: 35.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-60Z10T0 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 1A04 scheme: MBR
Partition: ID-1: / raw-size: 292.97 GiB size: 292.97 GiB (100.00%) used: 14.21 GiB (4.9%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 76.6 MiB (29.9%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 292.97 GiB size: 292.97 GiB (100.00%) used: 14.21 GiB (4.9%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 292.97 GiB size: 292.97 GiB (100.00%) used: 14.21 GiB (4.9%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
ID-5: /var/tmp raw-size: 292.97 GiB size: 292.97 GiB (100.00%) used: 14.21 GiB (4.9%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.65 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 301 Uptime: 1h 22m wakeups: 1 Memory: 7.66 GiB used: 4.8 GiB (62.6%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1250 lib: 300
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

If possible try disabling PCI-Express power management in the BIOS or via a grub kernel boot parameter.

Test at least 4 alternate kernels such as, linux, linux-lts, linux-mainline, or linux-next-git for your Wifi issue.

Also disable MAC address randomization.

3 Likes

Will try this. Thank you for replying to that quickly.
Will get back if the problem persists.

2 Likes

Can you please tell the process for disabling MAC address randomization.

Search is your friend try the forums, it helps.

Garuda Network Assistant

3 Likes

Yup just got that answer in another post.

Do the disconnects occur randomly or at regular intervals?

How frequently?

2 Likes

Just disabled the MAC address randomization, now a new pop up is coming stating network can't be found.

Randomly. Mostly while doing something important. Got disconnected 3 times while talking to you.

https://bbs.archlinux.org/viewtopic.php?id=265820

You could also try locking your wifi to a single bssid in network manager.

1 Like

removed all connections and using only the 2.4GHz band. But the issue still persists.

Maybe you could give a try to the rtl8821-dkms-git driver in the AUR.
I don't know if this will require to blacklist your current driver or it will be done automatically.
Although, before fumbling with drivers, I'd give priority to the other kernels.
Recently a user, with your card although on a different HP model was experiencing freezes with wifi and solved with maineline kernel. Of course that's different, Just to say that testing kernels is important.

1 Like

I think rtw88-dkms-git would be the preferred driver if you were to install an out of kernel driver. You would be best to test other kernels first before you go that route.

3 Likes

I missed this post. Be sure to reboot both your computer and router afterwards.

3 Likes

Tried installing rtw88-dkms-git with Linux-lts & linux-mainline. Still facing the same issue.

Are you dual booting
If answer is yes then that's the cause

1 Like