Rtl8814au stopped working

System:
Kernel: 6.1.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0474c9af-4141-4497-b162-69d967f7c54f rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: BIOSTAR model: Hi-Fi A85W serial: <superuser required>
UEFI: American Megatrends v: 4.6.5 date: 04/18/2013
CPU:
Info: model: AMD A10-5800K APU with Radeon HD Graphics bits: 64 type: MT MCP
arch: Piledriver level: v2 built: 2012-13 process: GF 32nm family: 0x15 (21)
model-id: 0x10 (16) stepping: 1 microcode: 0x6001119
Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 192 KiB
desc: d-4x16 KiB; i-2x64 KiB L2: 4 MiB desc: 2x2 MiB
Speed (MHz): avg: 3410 high: 3800 min/max: 1400/3800 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3800 2: 3800
3: 3378 4: 2664 bogomips: 30399
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected

so i have a network adapter and i been using it comfortably. A netgear nighthawk Ac 1900 model a7000 . I got these working using Aur.archlinux.org there are two packages installed rtl8814au-aircrack-dkms-git and rtl8814au-morrownr-git. Now i know it is not good to have two different drivers installed for the same device and one of these worked and the other didnt i think. But its been working this entier time but after restarting my computer i can no longer connect.

So here is what happened. I did a big update last night. This morning i tripped over my keyboard cable and one of my usb 3.0 slots had the middle plastic piece broke off and lodges inside my keyboard cable. I rebooted up my computer and everything came up live but my network adapter has stoped working. The reason my info is so split up is because i am phone posting right now.

I dont know which of the two packages to remove and if i removed one i dont have internet to reinstall. I dont know if the computer impact messed with any motherboard parts. Everything else seems to work. And my computer sounds quiet just its normal occasional hum. My other usbs work mouse and keyboard. I dont know if the large recent update broke the drivers and it only took effect upon restart. I am trying to think of what I can do to fix this situation. How do i check my system and find whats wrong.

Reboot, and on the Grub menu find the option to boot to a snapshot. Pick the snapshot from before you took the update. Test if your connectivity is restored. If it is, be sure to restore the snapshot and reboot before making any changes.

If your connection is back up, remove the driver that isn't DKMS because that's probably the one breaking when the kernel updates. Test the connection again. If it's good, try to take the update again.

1 Like

This snapshot works and i asked it to restore this one. Now the snapper tool says Restore and i click that and it asks Are you sure you want to restore snapshot 96 to @. Is this the correct thing.

So I am getting a message saying usb 7 is bad maybe the cable is messed up.

Yes, restore the snapshot and reboot. The snapshots are still read-only until you restore them.

Where is the message coming from? Copy and paste the message into the thread.

I cant copy and paste it it comes up when i shut down and is not displayed long. I will try to write it down next shutdown.

Gotcha. Take a video with your phone if you have a steady hand; maybe you can freeze the frame with the message and get a better look.

Usb usb7-port1: cannot enable maybe the usb cable is bad?

So i snapped that usb 3.0 when i tripped maybe its just detecting that.

And update broke the driver package again.

I'm not sure either of these are the right driver. Have you tried this one?

aur/rtl8814au-dkms-git 5.8.5.1.r149.g752d8ea-1 [+22 ~0.02]
    RTL8814AU and RTL8813AU chipset driver with firmware v5.8.5.1

You can install with Paru:

paru rtl8814au-dkms-git

Edit

You should remove the other drivers before installing the new one. This is from the GitHub page for the rtl8814au-morrownr-git:

Warning: Installing multiple drivers for the same hardware usually does not end well. If a previous attempt to install this driver failed or if you have previously installed another driver for chipsets supported by this driver, you MUST remove anything that the previous attempt installed BEFORE attempting to install this driver. This driver can be removed with the script called ./remove-driver.sh. Information is available in the section called Removal of the Driver. You can get a good idea as to whether you need to remove a previously installed driver by running the following command:

sudo dkms status

He also warns that breakage when updating the kernel is to be expected; you need to remove and reinstall each kernel upgrade, using some kind of temporary internet access (tethering from a mobile phone might work).

Warning: If you decide to upgrade to a new version of kernel such as 5.18 to 5.19, you need to remove the driver you have installed and install the newest available before installing the new kernel. Use the following commands in the driver directory:

$ git pull
$ sudo ./remove-driver.sh
$ sudo ./install-driver.sh

Temporary internet access is required for installation. There are numerous ways to enable temporary internet access depending on your hardware and situation. One method is to use tethering from a phone.. Another method is to keep a WiFi adapter that uses an in-kernel driver in your toolkit.

The page continues, read on if you wish: GitHub - morrownr/8814au: Linux Driver for USB WiFi Adapters that are based on the RTL8814AU Chipset

I think it will be better if you can get the rtl8814au-dkms-git package working though, so you don't have to worry about all that.

Paru is not doing anything. Its just sitting displaying the package build info.

Press q to get out of the build review, then confirm to continue with the installation.

See my edit above regarding removing the old drivers first. :eyes:

paru -Rsu rtl88xxau-aircrack-dkms-git rtl8814au-morrownr-git

That should probably be good enough, but see the note above regarding a special removal script for rtl8814au-morrownr-git.

As an edit to the post above (I can't edit it for some reason), it's a bit late for this realization but it only just now occurred to me that if you uninstall the old drivers first, you may be unable to install rtl8814au-dkms-git (because you have no internet connection).

If getting a tethered connection from a mobile phone is an option, I would go ahead and take down the old drivers first because that is least likely to cause issues.

If not, you can take a shot at installing the new driver, then removing the old ones and hope for the best. :crossed_fingers:

Thank you for the help. Comically right after i finished all the updates the cold front knocked out the power. Thank you merry christmas bro

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.