Reverting back to KDE5?

Dear Garudians,

After holding back from updating for a while because of the KDE 6 launch, I decided that today was the day to finally try the update. Sadly, I now encounter various glitches when I’m watching videos in fullscreen or sometimes just browse. The keyboard inputs are lagging behinde somtimes as well. Even more annoying, many games are constantly stuttering. I’ve tried reverting to the pre snapshot, but when I’m trying to load that one, I get a “Failed to start Switch Root.” error.

Is it possible to safely revert back to kde 5 for now, or what should I do?
Thank you for your help in advance!

System:
Kernel: 6.8.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=190e7cc2-4318-4f40-8d3a-f5f4b453777f rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=7c8380c2-84ce-492e-b61f-aa22976a6b16 loglevel=3
clearcpuid=304
Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: B650 AORUS ELITE AX v: x.x
serial: <superuser required> uuid: <superuser required> UEFI: American
Megatrends LLC. v: F4 date: 03/22/2023
CPU:
Info: model: AMD Ryzen 7 7700X bits: 64 type: MT MCP arch: Zen 4 gen: 5
level: v3 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 990 high: 3593 min/max: 400/5573 scaling:
driver: amd-pstate-epp governor: powersave cores: 1: 3593 2: 400 3: 400
4: 3509 5: 400 6: 400 7: 400 8: 400 9: 3549 10: 400 11: 400 12: 400
13: 400 14: 400 15: 400 16: 400 bogomips: 143724
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA102 [GeForce RTX 3090] driver: nvidia v: 550.67
alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of
2024-02; EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
built: 2020-2023 pcie: gen: 2 speed: 5 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s ports: active: none off: HDMI-A-2 empty: DP-4,DP-5,DP-6
bus-ID: 01:00.0 chip-ID: 10de:2204 class-ID: 0300
Device-2: AMD Raphael vendor: Gigabyte driver: amdgpu v: kernel
arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-1, DP-2,
DP-3, HDMI-A-1, Writeback-1 bus-ID: 11:00.0 chip-ID: 1002:164e
class-ID: 0300 temp: 37.0 C
Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
gpu: nvidia,amdgpu display-ID: 0
Monitor-1: HDMI-A-2 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
drv: nvidia device: 2 drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: nvidia x11: drv: zink
inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.67
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3090/PCIe/SSE2
memory: 23.44 GiB display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 8 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3090 driver: nvidia v: 550.67 device-ID: 10de:2204
surfaces: xcb,xlib,wayland device: 1 type: integrated-gpu name: AMD
Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
v: 24.0.3-arch1.2 device-ID: 1002:164e surfaces: xcb,xlib,wayland
device: 2 type: cpu name: llvmpipe (LLVM 17.0.6 256 bits)
driver: mesa llvmpipe v: 24.0.3-arch1.2 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
Device-1: NVIDIA GA102 High Definition Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:1aef
class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 11:00.1
chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 11:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-4: Yamaha AG06/AG03 driver: snd-usb-audio type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-2.1:4 chip-ID: 0499:170d
class-ID: 0103
API: ALSA v: k6.8.1-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0c:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp12s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
bus-ID: 0d:00.0 chip-ID: 14c3:0616 class-ID: 0280
IF: wlp13s0 state: down mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd
Bluetooth:
Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-9:7 chip-ID: 0e8d:0616
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Drives:
Local Storage: total: 3.64 TiB used: 839.48 GiB (22.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 990 PRO 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 3B2QJXD7 temp: 38.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung model: SSD 980 PRO 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 41.9 C
scheme: GPT
Partition:
ID-1: / raw-size: 1.79 TiB size: 1.79 TiB (100.00%) used: 549.91 GiB (30.1%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
used: 549.91 GiB (30.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
used: 549.91 GiB (30.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
used: 549.91 GiB (30.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 33.55 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 30.5 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 42.0 C mobo: 34.0 C gpu: amdgpu temp: 37.0 C
Fan Speeds (rpm): N/A
Info:
Memory: total: 32 GiB note: est. available: 30.5 GiB used: 3.08 GiB (10.1%)
Processes: 426 Power: uptime: 0m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.13 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 1593 pm: pacman pkgs: 1587 libs: 447 tools: octopi,paru
pm: flatpak pkgs: 6 Compilers: gcc: 13.2.1 Shell: garuda-inxi default: Bash
v: 5.2.26 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2023-09-25
Last full system update: 2024-03-24
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Snapshot?


OT
Vorwärts immer, rückwerts nimmer.
Alter Honecker Spruch, IIRC

Always forwards, never backwards.
Old Honecker saying, IIRC

1 Like

The later you upgrade to Plasma 6, the more limitations you will cause to yourself, unable to update any of your 1000+ packages.

The best approach is the Big Bang approach. You upgrade to Plasma 6 and then try to fix your issues, see here on the Forum if others have had similar ones, open bugs on bugs.kde.org, etc.

I also had to go through that and all important issues have been fixed, even many less important. Takes time, efforts, but that’s the price to pay to be on a rolling release.

5 Likes

I’m not that knowledgeable about the snapshot function. But I tried to load the pre snapshot and it gave me said error. I thought that maybe the update was so big that it’s not intendet that people are able to use snapshots anymore. So I asked here first. Should I try to load the fallback, the next older post snapshot or do something else?

Well, I couldn’t find any info on my problems from a quick glance. Also, while the update itself went smoothly, I got some errors when I tried to reboot my pc and had to forcefully shut down my pc after installing the update. I thought that it may have to do something with that. My plan was to wait until the “april update” someone mentioned is out, try again, and if that fails to reinstall the entire system.

It is probably not a good idea to stay with Arch if you want to revert. Arch is full steam ahead on KDE6. You might try a debian based distro, and by the time they upgrade, many more bugs will be ironed out.

Also, did you do an upgrade or a reinstall when you moved to KDE6? You might try backing up your data and doing a complete reinstall, that way there are no KDE5/QT5 left over system files, etc. that may be causing your issues. Just a thought.

4 Likes

Could it get problematic if I stay on KDE5 for another 2 weeks? Maybe I really have to try the complete reinstall a bit earlier in that case. But I’d really like to avoid it, if I can. Especially because, if that doesn’t work and I can’t find an answer, I’d have to switch distros. I really liked my stay here so far. I wanted a good KDE distro and saw this distro being recommended quite often, especially when it comes to gaming. Would Kubuntu be a good alternative?

Yes, if you stay on Arch. All the efforts moving forward will be for KDE6, so I could foresee it breaking your system, unless you didn’t upgrade for two weeks.

I am not up on which Debian-based distro’s have upgraded or not. I would ASSUME Debian stable has not upgraded, usually takes them months, or more. So, do some research.

2 Likes

This is explained in our wiki and what to do.

Yes you can do that, providing you can find a bootable and viable snapshot to bring you back to pre-Plasma 6.

Correct (Kubuntu). Plasma 6 came out in Feb and Kubuntu next upgrade is April, this gives them way too small a window to work on something that major.

2 Likes

Hi again!
I usually only ask here if I really don’t have a clue what to do anymore without risking system stability. I thought that I did the same thing this time around, but forgot that I still wanted to try out switching to x11 again, because I wasn’t sure if I really was on x11 the first time I tried it.

Turns out I almost certaintly wasn’t, because all problems vanished as soon as I tried that. Seems like nvidia cards still aren’t really compatible with wayland, sadly. Hopefully that’ll change soon! Sorry for essentially wasting everyones time here, but thank you for your answers! :slight_smile:

1 Like

Sorry but not exactly accurate. I just downloaded the latest test ISO for AcroLinux and the same sluggishness that’s currently in Garuda after the 6.0 thru 6.0.2 updates are in Arch which came with Plasma 6.

Simply WOW!!! :rofl: :rofl:

On one hand I’m jealous of Kubuntu users not having to deal with KDE 6 yet. On the other hand, I could never go back to a distro that wasn’t Arch-based/rolling release… they are agonizing.

Well try out a different kernel , eg linux-lts or linux to try fixing those stutters.

Every system is different, GPU drivers, CPU’s etc. I am running 6.02 and not experiencing sluggishness from Garuda.

I said noring about Garuda. I’m quite sure the sluggishness has to strickly with Plasma.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.