Reflector doesn't find any mirrors

Hi,

After installing Garuda I've noticed that my system updates are extremely slow or failing constantly. I took a look at the Reflector settings and for some reason they were set to countries really far away (which made updates slow and failing constantly).

I've now added /etc/reflector-simple.conf containing the following:

--save /etc/pacman.d/mirrorlist
--protocol https
--country US
--latest 10
--sort country
--age 10

But this has resulted in reflector-simple reporting that it's unable to contact any mirrors, blocking any update. How can I fix this?

System:
  Kernel: 5.16.0-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=1c8a84f5-022f-4831-83f6-121a4b480f8e
    rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 resume=UUID=690f207d-de1b-4014-be8c-f88c832ec40a loglevel=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: MEG X570 UNIFY (MS-7C35) v: 2.0
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: A.30 date: 01/16/2020
CPU:
  Info: model: AMD Ryzen 9 3950X bits: 64 type: MT MCP arch: Zen 2 family: 0x17 (23)
    model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache: L1: 1024 KiB
    desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB L3: 64 MiB desc: 4x16 MiB
  Speed (MHz): avg: 3510 high: 3891 min/max: N/A cores: 1: 3500 2: 3500 3: 3500 4: 3500 5: 3500
    6: 3500 7: 3500 8: 3500 9: 3500 10: 3500 11: 3500 12: 3500 13: 3500 14: 3500 15: 3500 16: 3500
    17: 3500 18: 3500 19: 3432 20: 3500 21: 3500 22: 3500 23: 3500 24: 3500 25: 3500 26: 3500
    27: 3500 28: 3500 29: 3891 30: 3500 31: 3500 32: 3500 bogomips: 224006
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Vega 10 XL/XT [Radeon RX Vega 56/64] driver: amdgpu v: kernel bus-ID: 2f:00.0
    chip-ID: 1002:687f class-ID: 0300
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver: loaded: amdgpu,ati
    unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3440x1440 s-dpi: 96 s-size: 910x381mm (35.8x15.0") s-diag: 987mm (38.8")
  Monitor-1: HDMI-A-0 res: 3440x1440 hz: 75 dpi: 109 size: 800x335mm (31.5x13.2")
    diag: 867mm (34.1")
  OpenGL: renderer: AMD Radeon RX Vega (VEGA10 DRM 3.44.0 5.16.0-zen1-1-zen LLVM 13.0.0)
    v: 4.6 Mesa 21.3.3 direct render: Yes
Audio:
  Device-1: AMD Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel v: kernel
    bus-ID: 2f:00.1 chip-ID: 1002:aaf8 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    bus-ID: 31:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Texas Instruments PCM2902 Audio Codec type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2.3:8 chip-ID: 08bb:2902 class-ID: 0300
  Device-4: Astro Gaming Astro MixAmp Pro type: USB driver: hid-generic,snd-usb-audio,usbhid
    bus-ID: 1-2.4:7 chip-ID: 9886:0038 class-ID: 0300
  Sound Server-1: ALSA v: k5.16.0-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169 v: kernel port: f000
    bus-ID: 27:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 28:00.0 chip-ID: 8086:2723
    class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
  IF-ID-2: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 chip-ID: 8087:0029
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: N/A
Drives:
  Local Storage: total: 1.94 TiB used: 328.09 GiB (16.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT2000MX500SSD1 size: 1.82 TiB block-size:
    physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 033 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Intel model: SSDSC2CW120A3 size: 111.79 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 400i scheme: GPT
  ID-3: /dev/sdg maj-min: 8:96 type: USB vendor: Lexar model: USB Flash Drive size: 14.91 GiB
    block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 1.75 TiB size: 1.75 TiB (100.00%) used: 313.3 GiB (17.5%) fs: btrfs
    dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 1.75 TiB size: 1.75 TiB (100.00%) used: 313.3 GiB (17.5%) fs: btrfs
    dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 1.75 TiB size: 1.75 TiB (100.00%) used: 313.3 GiB (17.5%) fs: btrfs
    dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 1.75 TiB size: 1.75 TiB (100.00%) used: 313.3 GiB (17.5%) fs: btrfs
    dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 69.03 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2
    maj-min: 8:2
  ID-2: swap-2 type: zram size: 62.81 GiB used: 49.5 MiB (0.1%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 51.0 C mem: 55.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 726
Info:
  Processes: 609 Uptime: 1d 15h 5m wakeups: 0 Memory: 62.81 GiB used: 7.65 GiB (12.2%)
  Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 2083
  lib: 577 Client: Unknown Client: garuda-assistant inxi: 3.3.11

Thanks :slight_smile:

Welcome :wink:

in terminal

garuda-update

and post your

garuda-inxi

as text, please like in template ask for.

6 Likes

Thank you - garuda-update completed, finally.

Best,
W

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.