Psautohint invalid PGP signature

Hello everyone! I just recently reinstalled as I am going to try getting a passthrough working, however when I attempt to install anything through pamac i get the following error.

Download of psautohint (3:2.4.0-1.1) started
Download of psautohint (3:2.4.0-1.1) finished
Checking keyring...
Checking integrity...
Error: psautohint: signature from "Pedro Henrique Lara Campos <[email protected]>" is invalid
Removing invalid files and retrying...
Resolving dependencies...
Checking inter-conflicts...
Download of psautohint (3:2.4.0-1.1) started
Download of psautohint (3:2.4.0-1.1) finished
Checking keyring...
Checking integrity...
Error: psautohint: signature from "Pedro Henrique Lara Campos <[email protected]>" is invalid
Failed to commit transaction:
invalid or corrupted package:

Fresh Install INXI:

garuda-inxi
System:
  Kernel: 6.0.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=78c2e7f5-5af0-4cd6-a76f-f692f5c10941 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: STRIX Z270E GAMING v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 1302
    date: 03/15/2018
CPU:
  Info: model: Intel Core i7-7700K bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 4500 high: 4604 min/max: 800/4600 scaling:
    driver: intel_pstate governor: performance cores: 1: 4604 2: 4600 3: 4600
    4: 4200 5: 4601 6: 4200 7: 4596 8: 4600 bogomips: 67200
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: NVIDIA GA106 [GeForce RTX 3060] vendor: Micro-Star MSI
    driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:2503
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
    compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4080x1920 s-dpi: 91 s-size: 1139x536mm (44.84x21.10")
    s-diag: 1259mm (49.56")
  Monitor-1: DP-0 pos: primary,bottom-c res: 1920x1080 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: DP-3 pos: top-right res: 1080x1920 dpi: 82
    size: 336x598mm (13.23x23.54") diag: 686mm (27.01") modes: N/A
  Monitor-3: DP-4 pos: top-left res: 1080x1920 hz: 60 dpi: 93
    size: 296x527mm (11.65x20.75") diag: 604mm (23.8") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce RTX
    3060/PCIe/SSE2 direct render: Yes
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
    driver: snd_hda_intel bus-ID: 1-5:4 v: kernel chip-ID: 041e:3264
    bus-ID: 00:1f.3 class-ID: 0102 chip-ID: 8086:a2f0 serial: <filter>
    class-ID: 0403
  Device-2: NVIDIA GA106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:228e
    class-ID: 0403
  Device-3: Creative Sound Blaster X3 type: USB
    driver: cdc_acm,hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.7-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: ASUSTeK driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 04:00.0 chip-ID: 168c:003e class-ID: 0280 temp: 41.0 C
  IF: wlp4s0 state: down mac: <filter>
Bluetooth:
  Device-1: ASUSTek Qualcomm Bluetooth 4.1 type: USB driver: btusb v: 0.8
    bus-ID: 1-7:5 chip-ID: 0b05:1825 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f020
    bus-ID: 00:17.0 chip-ID: 8086:2822 rev: class-ID: 0104
Drives:
  Local Storage: total: 2.05 TiB used: 1.4 TiB (68.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM001-1ER164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC26 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 24.67 GiB (10.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 24.67 GiB (10.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 24.67 GiB (10.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 24.67 GiB (10.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.28 GiB used: 1.2 MiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: nvidia temp: 51 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 288 Uptime: 1h 23m wakeups: 0 Memory: 31.28 GiB
  used: 6.4 GiB (20.5%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1857
  libs: 534 tools: octopi,pamac,paru Shell: fish v: 3.5.1 default: Bash
  v: 5.1.16 running-in: alacritty inxi: 3.3.23
Garuda (2.6.9-1):
  System install date:     2022-11-08
  Last full system update: 2022-11-08 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

I have used the Garuda Assistant to refresh all keyrings. No errors reported there. I am currently trying to install Flameshot and a few other programs but this error keeps popping up. I have searched for a fix to this online and on the forums prior to asking, but only found out how to refresh the keyrings.

Keyring Refresh Output:

local/archlinux-keyring 20220927-1 (base-devel)
Arch Linux PGP keyring
==> Appending keys from archlinux.gpg...
==> Updating trust database...
gpg: next trustdb check due at 2022-11-16
local/chaotic-keyring 20220803-1
Chaotic-AUR PGP keyring
==> Appending keys from chaotic.gpg...
==> Updating trust database...
gpg: next trustdb check due at 2022-11-16
Press enter to exit

Thank you for any help in advance!!

  1. Reboot
  2. Use garuda-update in konsole
  3. Do not use pamac.
5 Likes

Will do. Its still listed in your software center when you fresh install, so i added it since im used to it working flawlessly.

Rebooting now and updating. Did something change? The Add/Remove Software GUI was nice imo.

Also, for clarity, this also happens with Octopi. Same file, same situation. Errors as if it is the key for the file thats corrupted.

will report back after i follow your recommendation

EDIT: Fixed. Followed your instructions and that specific key updated. Octopi worked. Will remove pamac as well.

1 Like

Please, post next time all terminal actions, input, and output.
We recommend to use pamac only for searching, the feedbacks in the terminal are important, therefore, use pacman only.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.