Proton breaks when installing a game

Hello Garuda users!


╭─[email protected] in ~ took 4ms
╰─λ garuda-inxi
Kernel: 6.3.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=76af0bd2-221b-4492-a3df-d4e8a073820f rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_wayland vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: MSI model: B150A GAMING PRO (MS-7978) v: 1.0
serial: <superuser required> UEFI: American Megatrends v: 1.F0
date: 01/25/2018
Info: model: Intel Core i5-7500 bits: 64 type: MCP arch: Kaby Lake
gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 9 microcode: 0xF2
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3700 high: 3701 min/max: 800/3800 scaling:
driver: intel_pstate governor: powersave cores: 1: 3700 2: 3701 3: 3699
4: 3700 bogomips: 27199
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: XFX
driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 03:00.0 chip-ID: 1002:73ff
class-ID: 0300
Display: wayland server: v: with: Xwayland v: 23.1.1
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu display-ID: 0
Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon RX 6600 (navi23 LLVM
15.0.7 DRM 3.52 6.3.2-zen1-1-zen) direct-render: Yes
Device-1: Intel 100 Series/C230 Series Family HD Audio
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
API: ALSA v: k6.3.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter
driver: rtl8xxxu type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-6:2 chip-ID: 0bda:8179 class-ID: 0000 serial: <filter>
IF: wlp0s20f0u6 state: up mac: <filter>
Local Storage: total: 2.96 TiB used: 252.13 GiB (8.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3000NM0033-9ZM178
size: 2.73 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: SN04 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 EVO 250GB
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 2B6Q scheme: GPT
ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 47 GiB (20.2%)
fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 47 GiB (20.2%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 47 GiB (20.2%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 47 GiB (20.2%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 43.5 MiB (0.3%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 51.0 C pch: 50.0 C mobo: N/A gpu: amdgpu
temp: 46.0 C mem: 48.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Processes: 269 Uptime: 2h 31m wakeups: 8 Memory: available: 15.57 GiB
used: 5.7 GiB (36.6%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 2006
libs: 559 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-05-18
Last full system update: 2023-05-18
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

╭─[email protected] in ~ took 1s

I have a problem with Proton breaking after installing a certain game. Say, I installed Disco Elysium and Divinity Original Sin 2, they work just fine. I updated my system, installed some software, and rebooted and they still works fine. Then, I installed another game, in this case: No Man's Sky; then Proton suddenly breaks. All non-Linux are unplayable, while the Linux native ones works fine. I've installed several Arch-based distros, even the one that closest to vanilla, the problem still persist, so its not specific to Garuda. I've tried several things:

  1. Installing flatpak Steam
  2. Deleting one or two Proton games, then disabling the Shader Cache option.
  3. Manually deleting compatdata and prefix
  4. Deleting the whole .steam folder.
  5. Trying other Proton version: 7, 8, Experimental, GE.
  6. Trying different partition format: ext4, f2fs, xfs, now btrfs .
  7. Downgrading the kernel, trying other kernel variants.

This PC has a new VGA that I just bought a week ago, previously with my RX 480, this problem doesn't exist. But it was more than a year ago, since I've been holding back buying a new card because of the price. This PC has been inactive in that period of time because my RX480 breaks down, and I rarely do gaming on my laptop.

Anyway, here's some logs:


Disco Elysium PROTON LOG



All kind of help is greatly appreciated!

Application tried to create a window, but no driver could be loaded.

This is the only suspicious line I found in the proton logs. Switching to xorg or checking if all drivers incl. 32-bit one are installed could help, I don't know what else to suggest.


Thanks for the suggestion, I managed to"fix" it by searching for that "Application tried to create a window..." line. Turns out I can only play using 5.13-6 or below. They start slow and loads slow, but at least its a starting point.

The weird thing is, as I pointed out in the post, it ran fine under the latest GE when I first run it.

So, I've solved my issue. It was fonts. The files in ./local/share/fonts for some reason breaks Proton and Wine beyond version 5.13

By searching deeper and trial and error method, I found it by making two users on my PC. The main one, and the testing one, since I know its not related to mesa and vulkan driver or the kernel. I've tried using mesa-tkg and trying different kernels, including LTS, no luck. I found out that a clean state of home directory "solve" the issue, and the games that I thought were "problematic" weren't problematic at all, because they worked perfectly in the new user that I set up. Now, the question; what files caused it? After some digging, I found the same problem with similar solution. It was the fonts, but in that person's case, deleting fontconfig folder is enough, I have to take an extra step and delete the entire ./local/share/fonts folder...aand... Proton and Wine (for Lutris) works fine.

So now I have two users, one for gaming with Proton / Wine, and one with the fonts folder, mainly for doing design stuffs. So yeah, case closed.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.