Problems with ryzen controller

I installed ryzen controller from pamac, it starts it seems to work until i try to apply settings, i rtfm and it said i needed to run it as root, i couldn't run it with sudo the way.

i tried sudo ryzencontroller i tried sudo ryzen-controller only way it launches is "/opt/Ryzen Controller/ryzen-controller" %U so i tried sudo "/opt/Ryzen Controller/ryzen-controller" %U and this was the output

"[55792:1211/044747.798584:FATAL:atom_main_delegate.cc(211)] Running as root without --no-sandbox is not suppor
ted. See 638180 - chromium - An open-source project to help move the web forward. - Monorail.
fish: Job 1, 'sudo "/opt/Ryzen Controller/ryz…' terminated by signal SIGTRAP (Trace or breakpoint trap)"

my desired outcome is to overclock my gpu past 1500 mhz any help would be appreciated...thanks in advance

Info: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 type: MCP arch: Zen 2
family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600106 cache: L1: 384 KiB L2: 3 MiB
L3: 8 MiB bogomips: 28445
Speed: 1753 MHz min/max: 1400/2375 MHz boost: enabled Core speeds (MHz): 1: 1753 2: 2190
3: 1636 4: 1450 5: 3220 6: 1501
Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 bmi2 bpext cat_l3
cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy constant_tsc cpb cpuid cqm cqm_llc
cqm_mbm_local cqm_mbm_total cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic
extd_apicid f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs irperf
lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc
nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb perfctr_core
perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed
rdt_a rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3
stibp succor svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload
vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected

This is the actual issue you're trying to solve, and is an "X". Being unable to install "ryzen-controller" is a "Y".

https://xyproblem.info/

You will likely have add a kernel parameter, as per https://wiki.archlinux.org/title/AMDGPU#Overclocking

1 Like

X of the XY Problem: