Problems with microphone

My microphone records only some static. No discernible sounds or voice can be heard. I tried troubleshooting it myself but have given up (as far as for tonight) Here's' the console output:

Kernel: 5.18.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4ce2de8b-3f8d-4880-ab59-341f27b61e16 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma v: 5.25.0 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: Z170-P D3 v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 2604
date: 02/22/2018
CPU:
Info: model: Intel Core i5-6600K bits: 64 type: MCP arch: Skylake-S
gen: core 6 built: 2015 process: Intel 14nm family: 6 model-id: 0x5E (94)
stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 4251 high: 4291 min/max: 800/4300 scaling:
driver: intel_pstate governor: performance cores: 1: 4202 2: 4291 3: 4279
4: 4235 bogomips: 27999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN 4
process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: HDMI-A-2 empty: DP-1, DP-2, DVI-D-1, HDMI-A-1
bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-2 mapped: HDMI-A-1 model: Dell S2340L serial: <filter>
built: 2015 res: 1920x1080 hz: 60 dpi: 96 gamma: 1.2
size: 509x286mm (20.04x11.26") diag: 584mm (23") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 470 Graphics (polaris10 LLVM 13.0.1 DRM
3.46 5.18.1-zen1-1-zen)
v: 4.6 Mesa 22.1.1 direct render: Yes
**Audio:**
**Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK**
**driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170**
**class-ID: 0403**
**Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]**
**vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3**
**speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403**
**Sound Server-1: ALSA v: k5.18.1-zen1-1-zen running: yes**
**Sound Server-2: JACK v: 1.9.21 running: no**
**Sound Server-3: PulseAudio v: 16.0 running: no**
**Sound Server-4: PipeWire v: 0.3.52 running: yes**
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK AM1I-A driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.14 TiB used: 209.89 GiB (17.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Biostar model: M700-256GB
size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: S0614B0
temp: 48.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1ER162
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC45
scheme: GPT
Partition:
ID-1: / raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 209.89 GiB (88.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 563 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 209.89 GiB (88.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 209.89 GiB (88.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 209.89 GiB (88.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 344.5 MiB (2.2%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: amdgpu temp: 57.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1145
Info:
Processes: 260 Uptime: 6h 22m wakeups: 9 Memory: 15.57 GiB
used: 4.56 GiB (29.3%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1440
lib: 451 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.18
Garuda (2.6.3-2):
System install date:     2021-09-24
Last full system update: 2022-06-19 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Timeshift
Failed units:            bluetooth-autoconnect.service

Care to tell us what you've tried?

3 Likes

Also, please, reboot.
Your kernel and a lot of stuff are changed.

1 Like

went onto arch wiki and tried editing a bunch of .conf files, none of which i found on my system in the locations described by the wiki

this has nothing to do with that, the issue has been persisting for months, i've never been able to get a microphone working on garuda.
I did, however, follow your advice and rebooted, issue persists.

What kind of mic/headset is it? Does it have a 3.5mm jack or USB?

Rode lav mic, 3.5mm 3 band jack, i have it going thru a splitter (3 band female into 2 two band males) but it's detected either way. Microphone works perfectly when plugged into a smartphone, and works on a windows laptop. No windows on my main machine.

Update: Tried playing with alsamixer settings now all I can hear is complete silence, not even static :frowning:

Try this suggestion from the Arch Wiki:

Correctly detect microphone plugged in a 4-pin 3.5mm (TRRS) jack

On some modern laptops you may have a combined 3.5mm headset jack, instead of two separated ones, which may not be correctly detected by default. To make ALSA correctly detect plug-in status on your 3.5mm jack, you can put the following line into your /etc/modprobe.d/alsa-base.conf:

options snd_hda_intel index=0 model=*your_model_setting*

For a complete list of options to put in your_model_setting, see HD-Audio Codec-Specific Models or its source located at /usr/lib/modules/$(uname -r)/build/Documentation/sound/hd-audio/models.rst (provided by the linux-docs package). A common model is dell-headset-multi, even if the hardware is not from Dell.

More: Advanced Linux Sound Architecture - ArchWiki

2 Likes

Thanks I will try, any clue on how to find out which model setting to use? Should i just try a bunch and see if something works?

If you see one that describes the exact model you are using, I would try that. The wiki post mentions that dell-headset-multi often seems to work, even if the hardware is not actually Dell. If you aren't sure, that might be a good place to start.

Many thanks for help, dell-headset-multi didn't fix the issue, however, im going to sleep again and im gonna try the other options tomorrow evening. I checked alsamixer again, put all values to max, switched form 2 to 4 to 6 channel mode, went into pavucontrol. Everything labels the microphone as clearly plugged in. Tried plugging it both in the front and in the back, with or without the adapter... Leme know if I can provide more useful info.