Problems installing Nvidia drivers

When i try to install drivers for my Nvidia card from ''Hardware Configuration'' and click on ''Auto install Prophierary driver''.
I get this error message :

Starting

Using config 'video-nvidia-390xx-dkms' for device: 0000:01:00.0 (0300:10de:0f00) Display controller nVidia Corporation GF108 [GeForce GT 630]

Installing video-nvidia-390xx-dkms...

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-390xx-dkms/MHWDCONFIG

Processing classid: 0300

Sourcing /var/lib/mhwd/scripts/include/0300

Processing classid: 0302

:: Synchronizing package databases...

core is up to date

extra is up to date

community is up to date

multilib is up to date

chaotic-aur is up to date

:: Starting full system upgrade...

resolving dependencies...

looking for conflicting packages...

:: libxnvctrl-390xx and libxnvctrl are in conflict. Remove libxnvctrl? [y/N] error: unresolvable package conflicts detected

error: failed to prepare transaction (conflicting dependencies)

:: libxnvctrl-390xx and libxnvctrl are in conflict

Error: pacman failed!

Error: script failed!

Done ...
sudo pacman -Rnsc libxnvctrl

Then

sudo mhwd -a pci nonfree 0300
5 Likes

Hi I tried following these steps but in my case its throwing below error :

nvidia-390xx-dkms-390.144-1-x86_64 downloading...
bbswitch-dkms-0.8-437-x86_64 downloading...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
error: failed to commit transaction (conflicting files)
opencl-nvidia-390xx: /etc/OpenCL/vendors/nvidia.icd exists in filesystem
opencl-nvidia-390xx: /usr/lib/libnvidia-opencl.so.1 exists in filesystem
nvidia-390xx-utils: /usr/bin/nvidia-bug-report.sh exists in filesystem
nvidia-390xx-utils: /usr/bin/nvidia-cuda-mps-control exists in filesystem
---- shows a couple of above similar msgs And at the end throws below error ---

lib32-nvidia-390xx-utils: /usr/lib32/vdpau/libvdpau_nvidia.so.1 exists in filesystem
lib32-opencl-nvidia-390xx: /usr/lib32/libnvidia-opencl.so.1 exists in filesystem
Errors occurred, no packages were upgraded.
Error: pacman failed!
Error: script failed!

Please Help . I am unable to use NVidia which runs fine when i was using ubuntu on this laptop.