Problem with steam

Hi everybody,

I am using Garuda KDE Dr460nized gaming edition and my spec is:

OS: Garuda Linux x86_64
Host: VivoBook_ASUSLaptop X515JP_R565JP 1.0
Kernel: 6.4.3-zen1-2-zen

Packages: 1799 (pacman)[stable]
Shell: fish 3.6.1
Terminal: konsole 23.4.3

CPU: Intel(R) Core(TM) i7-1065G7 (8) @ 3.9 GHz
GPU: Intel Iris Plus Graphics G7
Memory: 2.74 GiB / 7.50 GiB (36%)

Everything works fine except steam. The steam-native crashes and opens again repetitively when I run the steam-native from the game submenu. I however can run the steam-native from the terminal without any problem. I cannot guess what could possibly cause such a problem. Thanks in advance for your assistance.

in your missing garuda-inxi they have not posted. Please follow the template.

I move it from KDE to Unsupported Software (AUR & Other) .


Try using steam runtime instead unless you are trying to use steam-native for a particular game that only works on steam native.

I'm not a gamer and so steam user, so this might not apply at all.
From an external look, it could be a launcher problem, so give a look at the solutions proposed in this bug report.

And, as already mentioned, please always include your garuda-inxi.


Please find the output of gardua-inxi in the following:

Kernel: 6.4.3-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=3852ea8d-d2e5-4042-9059-7499964ca656 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=c0e91ddc-7c34-4cbd-9a88-09820fbb8ea9 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X515JP_R565JP
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: X515JP v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: X515JP.308 date: 07/04/2022
ID-1: BAT0 charge: 36.3 Wh (100.0%) condition: 36.3/37.1 Wh (97.8%)
volts: 7.8 min: 7.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: not charging cycles: 2
Info: model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake
gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xBA
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 8 MiB
desc: 1x8 MiB
Speed (MHz): avg: 1250 high: 1500 min/max: 400/3900 scaling:
driver: intel_pstate governor: powersave cores: 1: 1222 2: 1500 3: 1037
4: 1500 5: 1200 6: 1183 7: 1260 8: 1100 bogomips: 23961
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Iris Plus Graphics G7 vendor: ASUSTeK driver: i915 v: kernel
arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:8a52 class-ID: 0300
Device-2: NVIDIA GP108M [GeForce MX330] vendor: ASUSTeK driver: nouveau
v: kernel non-free: 535.xx+ status: current (as of 2023-07) arch: Pascal
code: GP10x process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s
lanes: 4 link-max: gen: 3 speed: 8 GT/s bus-ID: 02:00.0 chip-ID: 10de:1d16
class-ID: 0302 temp: 38.0 C
Device-3: Sonix USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 322e:2103
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa dri: iris,nouveau gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0x61ed built: 2018 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.1.3 renderer: Mesa Intel Iris Plus Graphics
(ICL GT2) direct-render: Yes
Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
API: ALSA v: k6.4.3-zen1-2-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.74 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4
chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 4060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
Local Storage: total: 476.94 GiB used: 30.98 GiB (6.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU512GZ
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 002C temp: 30.9 C scheme: GPT
ID-1: / raw-size: 350 GiB size: 350 GiB (100.00%) used: 12.72 GiB (3.6%)
fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 110.43 GiB size: 110.43 GiB (100.00%)
used: 18.25 GiB (16.5%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 350 GiB size: 350 GiB (100.00%)
used: 12.72 GiB (3.6%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 350 GiB size: 350 GiB (100.00%)
used: 12.72 GiB (3.6%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.5 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p2 maj-min: 259:2
System Temperatures: cpu: 48.0 C mobo: N/A gpu: nouveau temp: 38.0 C
Fan Speeds (RPM): cpu: 2400
Processes: 289 Uptime: 4m wakeups: 1 Memory: total: 8 GiB note: est.
available: 7.5 GiB used: 2.42 GiB (32.2%) Init: systemd v: 253
default: graphical tool: systemctl Compilers: gcc: 13.1.1 Packages:
pm: pacman pkgs: 1799 libs: 518 tools: octopi,paru Shell: fish v: 3.6.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.28
Garuda (2.6.16-1):
System install date:     2023-07-15
Last full system update: 2023-07-16
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Strangely Steam-native opens when I click on Steam-runtime in the game submenu.

Ok, I will try that solution and let you know.

I copied the file attached to the solution but observed the same behavior: steam crashes and reopens repetitively.

Try to give a look at this:

which brings also to this (and others):

Quite frankly, I got lost, and all the libraries suggested to be installed seemed to me a dependency of steam-native-runtime, so should be already there...

1 Like

Thank you very much for your time and attention. I installed lib32-libudev0-shim but that does not solve my problem. lib32-libva is already installed. I could not install lib32-nm since I receive the error: target not found: lib32-nm.

After some searching, I found this which seems that address my problem. People suggest removing ~/.nv/GLCache as a part of the solution but such a directory does not exist in my home directory. Could the source of the problem be that I didn't install the Nvidia driver?

After further search, I found this which could resolve my problem. It suggests downgrading libgudev and lib32-libgudev from 238-1 to 237-2. I search the internet but I only found the latest version available for the download. Do you know how could I find the earlier version? I search /var/cache/pacman/pkg/ for the library but I could not find it there too.


sudo downgrade libgudev lib32-libgudev

It should show the available versions in the archive.

1 Like

Unfortunately, that solution didn't work either. It is a very strange bug since I can run Steam from the terminal but running Steam from the game submenu which does nothing but running a script does not work! I keep searching to see if I can find another solution. Thank you very much for your time.

How about copy pasting the desktop file contents here? You can easily lookup that file's location by right clicking it and selecting edit application which opens the properties dialog box.

Ideally the dektop file should be in /usr/share/applications (my steam runtime desktop file is there)

If the file content is too large you can use garuda's privatebin and post a link to it.

1 Like

Ok, I edited the Steam-native application and I found that it runs /usr/bin/steam-native. I expected that it runs the script in /usr/share/applications/ so-called steam-native.desktop. I don't have any steam-runtime.desktop in that directory. It would be nice of you if you could share your file here so I can have it and add it to my system.

It is also strange that steam-native runs when even I run the command steam-runtime in the terminal.

I search the internet for the garuda's provatebin and I found this. Unfortunately, the site seems to be unavailable. If it is ok I can post the content of steam-native.desktop here.

Wdym? privatebin's working here, I only have steam runtime in my system but I suspect steam native's .desktop file would be something similar.

Btw, this file is available as /usr/share/applications/steam.desktop in my system. hence why you couldn't find steam-runtime.desktop

If you are unable to use garuda's privatebin you can also quite easily use termbin right from your terminal. Such as I wanna paste the contents of /usr/share/applications/steam.desktop to termbin (You can ofc replace this path with the path of your steam native desktop file's path instead) I will do this.

cat /usr/share/applications/steam.desktop | tb

where tb is a predefined alias in garuda for nc 9999. This command pipes the output of steam.desktop to termbin and generates a URL similar to what privatebin gave above. Like this,

1 Like

Thank you very much for sharing the file. I have the same file with the same content in the directory. When I click on it and execute it I face the problem mentioned in OP (steam crashes and repones again repetitively). Here I have two couple of questions:

  1. When you edit the steam-native application in the game submenu what is the link in the filed the program in the application menu?
  2. What program would run when you execute steam-runtime in the terminal?

By the way, this is the content of my steam-native.desktop:

Your steam native desktop file looks fine. Can't really see any reason for the behavior you are mentioning.

I am confused with what you are trying to ask in this para.





which is just symlinked to steam-runtime launches steam runtime.

You completely lost me on this one.

Thank you very much for your reply. I found a solution to a part of my problems here. I simply add DRI_PRIME=0 in the environment variable.

I still cannot get steam-runtime running. When I execute the command steam-runtime in the terminal I get steam-native gets running.

1 Like