Problem with redshift-wayland-git and some other questions

Hi ,
I have just recently downloaded garuda sway and i have some question for which i have opened this thread , I tried to find it's answer on internet but there were no satisfactory answers:

!) I tried to use redshift-wayland-git in sway but doesn't worked what should i do?
2) I have a collection of wallpapers that i use to keep in slide show , I tried variety for that thing in sway but doesn't work , is there any alternative for it ?
3) The unfocused windows get too much transparent is there any way to stop it?

well the main problem here is that redshift-wayland-git is not working and i am a kind of person who uses too much laptop so it is very essential thing for me ,

kindly help me to solve these problems,
Thanks in advance!!!!

inxi -Faz

 ╭─[email protected] in ~
 ╰─λ inxi -Faz
System:    Kernel: 5.15.6-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=3d8862a3-cc90-4161-81ad-195e8064062c rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: sway 1.6.1 vt: 1 dm: N/A Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Dell product: Inspiron 7570 v: N/A serial: <superuser required> Chassis: type: 10
           serial: <superuser required>
           Mobo: Dell model: 06K08K v: A00 serial: <superuser required> UEFI: Dell v: 1.16.0 date: 02/17/2020
Battery:   ID-1: BAT0 charge: 27.0 Wh (100.0%) condition: 27.0/42.0 Wh (64.4%) volts: 12.8 min: 11.4
           model: Samsung SDI DELL CYMGM79 type: Li-ion serial: <filter> status: Full
           Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> charge: 55% (should be ignored)
           rechargeable: yes status: Discharging
CPU:       Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6
           model-id: 8E (142) stepping: A (10) microcode: EA cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31999
           Speed: 932 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 1763 2: 1223 3: 863 4: 881 5: 955 6: 908 7: 1048 8: 2160
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917
           class-ID: 0300
           Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Dell driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:134d
           class-ID: 0302
           Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:4 chip-ID: 1bcf:28c1
           class-ID: 0e02
           Display: wayland server: N/A compositor: sway v: 1.6.1 driver: loaded: nouveau note: n/a (using device driver)
           display-ID: 1 resolution: <missing: xdpyinfo>
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel alternate: snd_soc_skl
           bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.6-zen2-1-zen running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: no
           Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: d000
           bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp2s0 state: down mac: <filter>
           Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel bus-ID: 03:00.0 chip-ID: 8086:095a class-ID: 0280
           IF: wlp3s0 state: down mac: <filter>
           IF-ID-1: enp0s20f0u2 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth: Device-1: vivo 1820 type: USB driver: rndis_host v: kernel bus-ID: 1-2:3 chip-ID: 2d95:6ffb class-ID: 0a00
           serial: <filter>
           Device-2: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-7:5 chip-ID: 8087:0a2a
           class-ID: e001
           Report: ID: hci0 rfk-id: 0 state: up address: N/A
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 bus-ID: 00:17.0
           chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:    Local Storage: total: 1.14 TiB used: 23.12 GiB (2.0%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB block-size: physical: 4096 B
           logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: SDM3 scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 vendor: Micron model: 1100 SATA 256GB size: 238.47 GiB block-size: physical: 4096 B
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: L003 scheme: GPT
Partition: ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 23.12 GiB (2.5%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1
           maj-min: 8:1
           ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 23.12 GiB (2.5%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 23.12 GiB (2.5%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
           ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 23.12 GiB (2.5%) fs: btrfs dev: /dev/sda2
           maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 7.51 GiB used: 256 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 42.0 C pch: 42.0 C mobo: 42.0 C sodimm: SODIMM C
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 256 Uptime: 39m wakeups: 4 Memory: 7.51 GiB used: 1.85 GiB (24.6%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1162 lib: 298 Shell: fish v: 3.3.1 running-in: alacritty
           inxi: 3.3.09

 ╭─[email protected] in ~ took 3s
 ╰─λ

Tried these, as the one you mentioned hasn't been updated for 18 months?
https://wiki.archlinux.org/title/Backlight#Wayland

I installed wlsunset and used this command to get redshifting according to me :


 ╭─[email protected] in ~
 ╰─λ wlsunset -t 2600 -T 2700
registry: adding output 39
calculated sun trajectory: dawn 10:55, sunrise 11:28, sunset 23:12, dusk 23:45
setting temperature to 2700 K

but how can i make it to run at that specification on startup
because if i will stop it through ctrl + c
then it becomes same as how it was before , how can i make this command to run on startup