Problem running Vagrant on Virtualbox

Trying to get my local dev environment up and running on Garuda. Typically (on Manjaro), that just requires virtualbox and the virtualbox host modules.

I've tried installing every version of host modules I can find but I'm still unable to start Vagrant:

    Vagrant: v2.2.14, VirtualBox: vWARNING: The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel (5.9.14-99-tkg-bmq) or it failed to
         load. Please recompile the kernel module and install it by

           sudo /sbin/vboxconfig

         You will not be able to start VMs until this problem is fixed.

Dashboard:  http://vvv.test

The provider 'virtualbox' that was requested to back the machine
'default' is reporting that it isn't usable on this system. The
reason is shown below:

VirtualBox is complaining that the kernel module is not loaded. Please
run `VBoxManage --version` or open the VirtualBox GUI to see the error
message which should contain instructions on how to fix this error.

Running vboxconfig just returns "command not found."

Any help would be greatly appreciated. LOVING Garuda so far. This has been my only issue.


1 Like

install virtualbox using

sudo pacman -S virtualbox-meta

then reboot


Thank you, librewish. This worked perfectly. I knew it was something simple, just wasn't sure which package it needed.

It's not easy when you don't know,
because @librewish knows it is not easy either.