Printer is working but scanner is not

I have installed garuda-printer and cups and was able to configure the printer using cups web interface. However, the scanner does not work

It detects scanner as WSD <Scanner/Printer Name> and states "unable to connect to scanner" when tried to scan.

I have re-installed the garuda-printer and cups few time after rebooting, but no luck so far. I was hoping if someone has solution or ran into similar problem

Printer/Scanner: Canon MF8200C Series
Garuda KDE edition

I am not a dev, but do you have sane installed.

1 Like

For complete printing and scanning support
In kde lite edition

sudo pacman -S garuda-printer garuda-scanner print-manager skanlite

And enable

systemctl enable org.cups.cupsd
systemctl enable ipp-usb
5 Likes

Thanks for response. I have followed these steps and still unable to configure the printer properly. This is network printer and connected via Wi-Fi

I looked up some sites and it informs me to execute “sudo pacman -S system-config-printer“, but still no luck

So not sure if there is anything related to firewall that needs to be configured. I will continue to troubleshoot it

This is what happens in Garuda KDE

When I select Cannon MF8200C Series, fully driverless, cups-filters 1.28.2 (en)

Unable to add printer:

Unable to copy PPD file.

So I selected

Cannon MF8200C Series, IPP Everywhere, Printer gets added, but it mentions “Local Raw Printer”. Both printer and scanner does not work
I can attach the screenshot if required


NOTE: From ther Arch KDE distro system, this is working, It mentions ; “CNMF8200C Series, driverless, cups-filter 1.27.

1 Like

Its probably firewall

Disable firewalld

Then try again

2 Likes
2 Likes

I may have mis stated earlier, that changing firewall profile worked...It added printer but the driver mentioned "Local Raw printer" and not "Driverless cups..."

I disable the firewall and still getting unable to copy PPD files

Here is the error log


E [17/Sep/2020:07:57:35 -0700] [cups-deviced] PID 215580 (driverless-fax) stopped with status 1!
E [17/Sep/2020:07:57:57 -0700] [CGI] Unable to create PPD file: Could not poll sufficient capability info from the printer (ipp://Canon%
20MF8200C%20Series._ipp._tcp.local/, ipp://DECO_50C7BFB707AF.local:80/ipp/print) via IPP!
E [17/Sep/2020:07:57:57 -0700] copy_model: empty PPD file
E [17/Sep/2020:07:57:57 -0700] [Client 102] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/print
ers/Canon_MF8200C_Series) from localhost.
E [17/Sep/2020:07:58:09 -0700] [CGI] Unable to resolve \"dnssd://Canon%20MF8200C%20Series._ipp._tcp.local/?uuid=6d4ff0ce-6b11-11d8-8020-
2c9efc52a81b|Canon MF8200C Series\".
E [17/Sep/2020:07:58:23 -0700] [CGI] Unable to create PPD file: Could not poll sufficient capability info from the printer (ipp://Canon%
20MF8200C%20Series._ipp._tcp.local/, ipp://DECO_50C7BFB707AF.local:80/ipp/print) via IPP!
E [17/Sep/2020:07:58:23 -0700] copy_model: empty PPD file
E [17/Sep/2020:07:58:23 -0700] [Client 116] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/print
ers/Canon_MF8200C_Series) from localhost.
E [17/Sep/2020:07:59:34 -0700] [CGI] Unable to create PPD file: Could not poll sufficient capability info from the printer (ipp://Canon%
20MF8200C%20Series._ipp._tcp.local/, ipp://DECO_50C7BFB707AF.local:80/ipp/print) via IPP!
E [17/Sep/2020:07:59:34 -0700] copy_model: empty PPD file
E [17/Sep/2020:07:59:34 -0700] [Client 120] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/print
ers/Canon_MF8200C_Series) from localhost.
E [17/Sep/2020:08:00:04 -0700] [CGI] Unable to resolve \"dnssd://Canon%20MF8200C%20Series._ipp._tcp.local/?uuid=6d4ff0ce-6b11-11d8-8020-
2c9efc52a81b|Canon MF8200C Series\".
E [17/Sep/2020:08:03:10 -0700] [CGI] Unable to create PPD file: Could not poll sufficient capability info from the printer (ipp://Canon%
20MF8200C%20Series._ipp._tcp.local/, ipp://DECO_50C7BFB707AF.local:80/ipp/print) via IPP!
E [17/Sep/2020:08:03:10 -0700] copy_model: empty PPD file
E [17/Sep/2020:08:03:10 -0700] [Client 142] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/print
ers/Canon_MF8200C_Series) from localhost.
E [17/Sep/2020:08:04:12 -0700] [CGI] Unable to resolve \"dnssd://Canon%20MF8200C%20Series._ipp._tcp.local/?uuid=6d4ff0ce-6b11-11d8-8020-
2c9efc52a81b|Canon MF8200C Series\".
E [17/Sep/2020:09:38:50 -0700] [cups-deviced] PID 586632 (driverless) stopped with status 1!
E [17/Sep/2020:09:38:54 -0700] [cups-deviced] PID 586633 (driverless-fax) stopped with status 1!
E [17/Sep/2020:09:39:18 -0700] copy_model: empty PPD file
------------------

Mod fixed the look of the terminal output.

BTW thanks...for quick response...much appreciated

Maybe you did this allready.

Did you try also connect with wire or only wireless ? I read somewhere that that could be an issue.
Sorry i dont have the link anymore.

Succes.

Trying with wireless only....as the printer is in different room...and desktop is in different room

I tried exact same steps in other KDE distro and works fine with and without firewall enabled...

In Garuda, with and without firewall enabled....following the same steps...getting....

Unable to add printer:

Unable to copy PPD file.

---- so not sure if i can select the PPD file manuall during installing or configuring printer

Installed cndrvcups-lb-bin 3.70-1 and selected the UFR II driver and was able to print and scan ... now... it seems like using "Cannon MF8200C Series, fully driverless, cups-filters 1.28.2 (en)" it was unable to copy PPD file, but with other KDE Distro using "Cannon MF8200C Series, fully driverless, cups-filters 1.28.1 (en)" (one point version lower worked.

For now, it seems solved, but will continue to try to see why "Cannon MF8200C Series, fully driverless, cups-filters 1.28.2 (en)" driver is unable to copy PPD file using cups web interface

3 Likes

I mark it solved. For now :slight_smile:

Here are the steps that i followed after fresh install

sudo pacman -S garuda-printer garuda-scanner print-manager skanlite

systemctl enable org.cups.cupsd

Changed the firewall to "trusted" mode in change zone. Make sure to select "Permanent" and reload the firewall if needed

systemctl enable ipp-usb (I did not use it as i was using Wi-Fi network attached printer)

At this point, it is better to reboot your machine

Go to Cups web-interface and try to configure the printer and select " ully driverless, cups-filters 1.28.2 (en)" (Note: The version of cups-filters may be different

If you are able to configure and check the printer properties shows cups-filters as driver for your printer, then you are all set.

For me, the Cannon MF8280C printer was visible/identified in cups-web interface but was not able to configure the printer and was getting "Unable to copy PPD file"

For this I have installed cndrvcups-lb-bin 3.70-1 (your version may be different when you try to install)

I had some challenges in using skanlite, so i installed simple-scan for scanner. But you can you use your choice of application


1 Like