Ppp 2.5.0-1 breaks dependency ppp=2.4.9 II

Hey all,

Problem this morning with garuda-update, saying this…

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing ppp (2.5.0-1) breaks dependency 'ppp=2.4.9' required by networkmanager-fortisslvpn
[root@jacques-20frs08u00 jacques]#

Trying to uninstall ppp breaks too much dependencies.

Here’s my garuda-inxi :

System:
  Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    available: acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=66082618-ab1d-4528-aec7-ddaef29e9b82 rw rootflags=subvol=@ quiet
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Convertible System: LENOVO product: 20FRS08U00 v: ThinkPad X1 Carbon 4th
    serial: <superuser required> Chassis: type: 31 serial: <superuser required>
  Mobo: LENOVO model: 20FRS08U00 v: SDK0J40697 WIN serial: <superuser required> UEFI: LENOVO
    v: N1FET81W (1.55 ) date: 10/11/2022
Battery:
  ID-1: BAT0 charge: 44.6 Wh (94.1%) condition: 47.4/47.4 Wh (100.0%) power: 11.4 W volts: 16.0
    min: 14.8 model: LGC 00HW028 type: Li-ion serial: <filter> status: discharging
CPU:
  Info: model: Intel Core i7-6600U bits: 64 type: MT MCP arch: Skylake gen: core 6 level: v3
    note: check built: 2015 process: Intel 14nm family: 6 model-id: 0x4E (78) stepping: 3
    microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 3168 high: 3380 min/max: 400/3400 scaling: driver: intel_pstate
    governor: powersave cores: 1: 3000 2: 3292 3: 3000 4: 3380 bogomips: 22399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 v: kernel arch: Gen-9
    process: Intel 14n built: 2015-16 ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
  Device-2: Lite-On HD Webcam (960×540) driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-8:5 chip-ID: 04ca:705a class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x183d built: 2014 res: 1920x1080 hz: 60 dpi: 158
    gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.1.7-arch1.1 renderer: Mesa Intel HD Graphics 520 (SKL GT2)
    direct-render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
  API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.79 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:156f class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 04:00.0 chip-ID: 8086:24f3 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:7 chip-ID: 8087:0a2b class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 4 state: up address: <filter> bt-v: 4.2 lmp-v: 8 status:
    discoverable: no pairing: no class-ID: 7c0000
Drives:
  Local Storage: total: 476.94 GiB used: 88.24 GiB (18.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVKV512HAJH-000L1 size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 7L0QBXX7 temp: 24.9 C scheme: GPT
Partition:
  ID-
1: / raw-size: 194.8 GiB size: 194.8 GiB (100.00%) used: 88.24 GiB (45.3%) fs: btrfs
    dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 580 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-3: /home raw-size: 194.8 GiB size: 194.8 GiB (100.00%) used: 88.24 GiB (45.3%) fs: btrfs
    dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-4: /var/log raw-size: 194.8 GiB size: 194.8 GiB (100.00%) used: 88.24 GiB (45.3%) fs: btrfs
    dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-5: /var/tmp raw-size: 194.8 GiB size: 194.8 GiB (100.00%) used: 88.24 GiB (45.3%) fs: btrfs
    dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.48 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 37.0 C pch: 35.5 C mobo: N/A
  Fan Speeds (rpm): fan-1: 0
Info:
  Processes: 204 Uptime: 16m wakeups: 2 Memory: total: 16 GiB available: 15.48 GiB
  used: 3.19 GiB (20.6%) Init: systemd v: 254 default: graphical tool: systemctl Compilers:
  gcc: 13.2.1 clang: 16.0.6 Packages: pm: dpkg pkgs: 0 pm: pacman pkgs: 1458 libs: 402
  tools: octopi,paru,yay pm: rpm pkgs: 0 Client: shell wrapper v: 5.1.16-release inxi: 3.3.29
Garuda (2.6.16-1):
  System install date:     2023-07-23
  Last full system update: 2023-09-09
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

Hope to read ya soon :slight_smile:

2 Likes

Same. (Also, my internet is bog slow on this device only. Potentially related.)

garuda-inxi
System:
Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=fdd9180e-818d-4cd6-8f82-b52c0fbaca7e rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP EliteBook 820 G3 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 807C v: KBC Version 85.61 serial: <superuser required>
UEFI: HP v: N75 Ver. 01.05 date: 03/22/2016
Battery:
ID-1: BAT0 charge: 35.2 Wh (97.5%) condition: 36.1/36.1 Wh (100.0%)
volts: 12.8 min: 11.4 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: not charging
CPU:
Info: model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake
gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
model-id: 0x4E (78) stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1465 high: 1500 min/max: 400/2800 scaling:
driver: intel_pstate governor: powersave cores: 1: 1496 2: 1382 3: 1500
4: 1483 bogomips: 19200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard
driver: i915 v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports:
active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:1916 class-ID: 0300
Device-2: Cheng Uei Precision Industry (Foxlink) HP HD Camera
driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-9:5 chip-ID: 05c8:0383 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: LG Display 0x0498 built: 2015 res: 1366x768 hz: 60
dpi: 125 gamma: 1.2 size: 277x156mm (10.91x6.14") diag: 318mm (12.5")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 23.1.7-arch1.1 renderer: Mesa Intel HD Graphics
520 (SKL GT2) direct-render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 0.3.79 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Ethernet I219-V vendor: Hewlett-Packard driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1570 class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:3 chip-ID: 8087:0a2b
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
Drives:
Local Storage: total: 894.26 GiB used: 38.96 GiB (4.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Patriot model: M.2 P310 480GB
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: EDFM90.0 temp: 25.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 1103 scheme: MBR
Partition:
ID-1: / raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 38.96 GiB (8.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 38.96 GiB (8.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 38.96 GiB (8.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 38.96 GiB (8.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.42 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 44.0 C pch: 38.5 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Processes: 219 Uptime: 11m wakeups: 2 Memory: total: 8 GiB note: est.
available: 7.42 GiB used: 4.16 GiB (56.1%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1355 libs: 334 tools: octopi,paru Shell: fish
v: 3.6.1 default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-08-19
Last full system update: 2023-09-09
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:
1 Like

Same issue here.

--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵
:: Synchronizing package databases...
 garuda downloading...
 core downloading...
 extra downloading...
 multilib downloading...
 chaotic-aur downloading...
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing ppp (2.5.0-1) breaks dependency 'ppp=2.4.9' required by networkmanager-fortisslvpn

My internet is working normally.

1 Like

Try this one :

1 Like

That dit the trick… Thanks a lot Ankur :wave: :wave: :wave:

1 Like
3 Likes

Did that too and all works like a charm, including vpn… Thanks SGS :+1: :+1: :+1:

1 Like

thanks SGS, i removed the offending package with Octopi and updated without issue although the newly updated update script still singled out the package for removal after i had already done so ^.^
i think aspect that should be expected however.

thanks G-Team =-)

2 Likes

And please read

https://forum.garudalinux.org/t/ppp-2-5-0-1-breaks-dependency-ppp-2-4-9-iii/30824/14?u=sgs

2 Likes

i looked into this and figured that it’s more than likely for some browsers that have ‘built-in VPN’ switches and since i use proton’s own app that i don’t need the glitchy package.
we shall see! >.>

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.