Power profile switching from Brightness and battery applet does not work

I switched to 7800x3d and would like to put it not in performance mode when I’m just watching YT, this beast takes some power.

When I try to drag the widget to balanced it immediately snaps back to performance

image


garuda-inxi
System:
Kernel: 6.7.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=eb657d04-6680-40ca-a380-a5884de44a89 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
nvidia-drm.modeset=1
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: B650M Pro RS serial: <superuser required>
UEFI: American Megatrends LLC. v: 2.06.AS03 date: 01/16/2024
CPU:
Info: model: AMD Ryzen 7 7800X3D bits: 64 type: MT MCP arch: Zen 4 gen: 5
level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
model-id: 0x61 (97) stepping: 2 microcode: 0xA601206
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
L3: 96 MiB desc: 1x96 MiB
Speed (MHz): avg: 2337 high: 4391 min/max: 400/5050 scaling:
driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 3755
4: 400 5: 400 6: 4391 7: 3863 8: 4249 9: 400 10: 400 11: 3695 12: 3550
13: 400 14: 3751 15: 3836 16: 3512 bogomips: 134149
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Navi 21 [Radeon RX 6950 XT] vendor: Sapphire driver: amdgpu
v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1
empty: DP-1,DP-2,DP-3 bus-ID: 03:00.0 chip-ID: 1002:73a5 class-ID: 0300
Device-2: AMD Raphael driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
ports: active: none empty: DP-4, DP-5, DP-6, HDMI-A-2 bus-ID: 10:00.0
chip-ID: 1002:164e class-ID: 0300 temp: 41.0 C
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Acer XV272 P serial: <filter>
built: 2021 res: 1920x1080 hz: 144 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: radeonsi device: 2 drv: swrast gbm: drv: kms_swrast
surfaceless: drv: radeonsi x11: drv: radeonsi inactive: wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.5-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6950 XT (radeonsi
navi21 LLVM 16.0.6 DRM 3.57 6.7.3-zen1-1-zen) device-ID: 1002:73a5
memory: 15.62 GiB unified: no
API: Vulkan v: 1.3.276 layers: 8 device: 0 type: discrete-gpu name: AMD
Radeon RX 6950 XT (RADV NAVI21) driver: mesa radv v: 23.3.5-arch1.1
device-ID: 1002:73a5 surfaces: xcb,xlib device: 1 type: integrated-gpu
name: AMD Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
v: 23.3.5-arch1.1 device-ID: 1002:164e surfaces: xcb,xlib
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 10:00.1
chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 10:00.6
chip-ID: 1022:15e3 class-ID: 0403
Device-4: HP HyperX Cloud MIX Buds
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-10:6 chip-ID: 03f0:078a class-ID: 0300
serial: <filter>
Device-5: Trust USB microphone driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2.1:4
chip-ID: 145f:02d9 class-ID: 0300 serial: <filter>
API: ALSA v: k6.7.3-zen1-1-zen status: kernel-api
tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: ASRock driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 08:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Actions general adapter driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-2.1:3 chip-ID: 10d7:b012
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: no address: <filter> bt-v: 5.3 lmp-v: 12
status: discoverable: no pairing: no
Drives:
Local Storage: total: 942.7 GiB used: 542.88 GiB (57.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: SS0328D temp: 30.9 C
scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 2B6Q scheme: MBR
Partition:
ID-1: / raw-size: 476.45 GiB size: 476.45 GiB (100.00%)
used: 380.42 GiB (79.8%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 476.45 GiB size: 476.45 GiB (100.00%)
used: 380.42 GiB (79.8%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 476.45 GiB size: 476.45 GiB (100.00%)
used: 380.42 GiB (79.8%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 476.45 GiB size: 476.45 GiB (100.00%)
used: 380.42 GiB (79.8%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 30.47 GiB used: 13.5 MiB (0.0%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 44.2 C mobo: N/A
Fan Speeds (rpm): N/A
GPU: device: amdgpu temp: 45.0 C mem: 42.0 C fan: 0 watts: 18.00
device: amdgpu temp: 40.0 C
Info:
Processes: 392 Uptime: 21m wakeups: 0 Memory: total: 32 GiB note: est.
available: 30.47 GiB used: 6.31 GiB (20.7%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1815 libs: 500 tools: octopi,paru,yay Shell: fish
v: 3.7.0 default: Bash v: 5.2.26 running-in: konsole inxi: 3.3.31
Garuda (2.6.22-1):
System install date:     2023-07-18
Last full system update: 2024-02-04
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Looks to be a bug that is recently reopened
https://bugs.kde.org/show_bug.cgi?id=475255

5 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.