Plasma Shell freezes upon boot after updating

I finally had to make an account to post because I have not found a fix or cause of the issue I’m running into and need some help on this. I hadn’t had a chance to update in about a month and after doing so I can not get anything in the desktop to respond about 30 seconds after login.

Right click won’t bring up menus the upper pannel won’t do anything as well as quicklauch apps (this is in wayland) X11 just flat out freezes can’t even bring up a terminal. If I go back to my last snapshot everything works fine I’ve removed any orphaned packages that have remained after updating with no luck or even reading about this happening to anyone else here or on KDE’s forum so I’m stumped as to what it could be.
Any suggestions would be welcomed.

System:
Kernel: 6.9.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: hpet avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d132b74f-6050-4c33-99b1-9fb67039ea09 rw rootflags=subvol=@
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450I GAMING PLUS MAX WIFI (MS-7A40)
v: 2.0 serial: <superuser required> uuid: <superuser required>
UEFI: American Megatrends v: B.00 date: 08/20/2020
CPU:
Info: model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64
type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3 note: check
built: 2019 process: GF 12nm family: 0x17 (23) model-id: 0x18 (24)
stepping: 1 microcode: 0x8108109
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 3604 high: 3892 min/max: N/A cores: 1: 3887 2: 3693
3: 2593 4: 3693 5: 3892 6: 3693 7: 3693 8: 3693 bogomips: 59084
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: Sapphire
driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
empty: DP-1, DP-2, DP-3, HDMI-A-1, Writeback-1 bus-ID: 12:00.0
chip-ID: 1002:73ff class-ID: 0300
Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: DP-4 empty: HDMI-A-2,HDMI-A-3 bus-ID: 29:00.0
chip-ID: 1002:15d8 class-ID: 0300 temp: 50.0 C
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu,amdgpu display-ID: 0
Monitor-1: DP-4 res: 2560x1440 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: radeonsi device: 2 drv: swrast surfaceless: drv: radeonsi
wayland: drv: radeonsi x11: drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.0-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Vega 11 Graphics
(radeonsi raven LLVM 17.0.6 DRM 3.57 6.9.2-zen1-1-zen)
device-ID: 1002:15d8 memory: 1.95 GiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 15 device: 0 type: integrated-gpu name: AMD
Radeon Vega 11 Graphics (RADV RAVEN) driver: mesa radv v: 24.1.0-arch1.1
device-ID: 1002:15d8 surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: AMD Radeon RX 6600 (RADV NAVI23)
driver: mesa radv v: 24.1.0-arch1.1 device-ID: 1002:73ff
surfaces: xcb,xlib,wayland device: 2 type: cpu name: llvmpipe (LLVM
17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.0-arch1.1 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 12:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 29:00.1
chip-ID: 1002:15de class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 29:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.9.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: down mac: <filter>
Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 26:00.0
chip-ID: 8086:24fb class-ID: 0280
IF: wlp38s0 state: down mac: <filter>
Device-3: Realtek USB 10/100/1G/2.5G LAN driver: r8152 type: USB rev: 3.2
speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 4-3:2 chip-ID: 0bda:8156
class-ID: 0000 serial: <filter>
IF: enp41s0f3u3 state: up speed: 2500 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd
Bluetooth:
Device-1: Intel Wireless-AC 3168 Bluetooth driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-8:2 chip-ID: 8087:0aa7
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 4.2 lmp-v: 8
status: discoverable: no pairing: no
Drives:
Local Storage: total: 700.51 GiB used: 87.25 GiB (12.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240BX200SSD1
size: 223.57 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: .6 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: TeamGroup model: TM8PS7512G
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: .0 scheme: GPT
Partition:
ID-1: / raw-size: 223.31 GiB size: 223.31 GiB (100.00%)
used: 87.25 GiB (39.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
used: 566 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 223.31 GiB size: 223.31 GiB (100.00%)
used: 87.25 GiB (39.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 223.31 GiB size: 223.31 GiB (100.00%)
used: 87.25 GiB (39.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 223.31 GiB size: 223.31 GiB (100.00%)
used: 87.25 GiB (39.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 60.77 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 40.0 C mobo: 38.0 C
Fan Speeds (rpm): fan-1: 0 fan-2: 2303 fan-3: 0 fan-4: 0 fan-5: 0
GPU: device: amdgpu temp: 30.0 C mem: 34.0 C fan: 1359 watts: 3.00
device: amdgpu temp: 50.0 C
Power: 12v: N/A 5v: N/A 3.3v: 3.34 vbat: 3.23
Info:
Memory: total: 64 GiB note: est. available: 60.77 GiB used: 5.63 GiB (9.3%)
Processes: 288 Power: uptime: 54m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 24.27 GiB services: org_kde_powerdevil,upowerd
Init: systemd v: 255 default: graphical tool: systemctl
Packages: pm: pacman pkgs: 1993 libs: 530 tools: octopi,paru,yay
Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi default: fish
v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2021-10-08
Last full system update: 2024-05-31
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:            fancontrol.service

Try switching to the LTS kernel to test if the issue is kernel-related.

hi welcome youre long time user btw;)

Thats the problem if you remove orphaned Packages. Most people having issues with these here or other forums.

Its because some other packages need them and its deleted and the system crash. i dont know how you did but i only want remove discover and found the terminal typing like this

pacman -Rnsc discover  (Rnsc devil)

biggest misstake because Rnsc isnt right it delete more as you want and system broke with other issues.

Dont use Rnsc or Rns in that case only -R for Remove.
Then you dont have issues to reinstall it if you need it back again and dont delete to much pagackes on same time.(or take screenshots of it)

Your snapshot is working then you can try again the update if you see any terminal error because server download issue (or other red warnings)you can run this before you restart and having issues garuda-update remote fullfix that helped me out many times if i see error in the update or upgrade progress;)

Tried switch to LTS, as well as others same thing happens with all kernels. rolled back and tried the remote fullfix to update same thing after it updates. Only thing I have noticed going through this a few dozen times now the inxi isn’t showing a version for QT which is tied to the shell is it not?

This is normal, no need to panic.

Something is disturbing plasma.
Reload the last working snapshot and remove all widgets from the top panel so that only the KDE widgets “Application Launcher”, “Clock” and “System Tray” are left. Uninstall user-created widgets and themes. Then change the global theme to Breeze and try a garuda-update again.

3 Likes

It also wouldn’t hurt to create a new user account to see if a new user has the same problem.

2 Likes

Same thing happens as before after updating from the snapshot something had to corrupted in my configs somehow but I had no errors in the terminal after the update for anything. Either way the new user after the update was the same way.

But a new user in the snapshot worked I copied all the configs related to plasma updated then edited them in my main account now its working again. I have no idea what was actually dureing the update but those are now on my messed something up again usb so if it happens again after an update I can just edit it back in.

Thank you never ran into something like this before and I’m not great with linux but I can usually find a similar problem and work it out from there.

2 Likes

You really should install a backup program for your user’s home directory. You could include your home in your snapshots if you’d like a little more protection. However, snapshots are not a proper backup solution. For it to be considered a comprehensive backup solution you should be saving your user data to a different drive, (preferably an external drive and/or the cloud).

Snapshots are not the same as backups.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.