Plasma SDDM screen all grey with most colors gone

My login screen was like this after the update. What can be the problem?

After login, strange colors appear, i can't see anything.

please post your

garuda-inxi | tb


journalctl -r -n 500 | tb

these commands will paste your garuda-inxi and journalctl outputs to the termbin and provide you with a link that you can post here.

To execute these commands you can go to tty2 using ctrl+alt+F2

pressing the keys will throw you to tty2 which will ask you to enter your username and password. enter them. Your password won't be visible while typing.

to go back to tty1 or your graphical session use ctrl+alt+F1

We need some info to help you and these would be a start


I know but i cant post the outputs here. :frowning:

What prevents you from doing so?


As always, boot with last working snapshot. Post log from garuda-update, like

:: Paketdatenbanken werden synchronisiert …
 garuda                                                                                 96,9 KiB   202 KiB/s 00:00 [--------------------------------------------------------------------] 100%
 core                                                                                  132,5 KiB   559 KiB/s 00:00 [--------------------------------------------------------------------] 100%
 extra                                                                                   8,3 MiB  15,5 MiB/s 00:01 [--------------------------------------------------------------------] 100%
 community ist aktuell
 multilib                                                                              141,8 KiB   616 KiB/s 00:00 [--------------------------------------------------------------------] 100%
 chaotic-aur                                                                             2,5 MiB  4,18 MiB/s 00:01 [--------------------------------------------------------------------] 100%
:: Starting full system upgrade...
warning: reflector-simple: local (2.0-1.1) is newer than garuda (2.0-1)
resolving dependencies...
looking for conflicting packages...

Package (14)                                 Old Version  New Version  Net Change  Download Size

extra/gegl                                   0.4.44-2     0.4.44-3       0.00 MiB       3.03 MiB
extra/gimp                                   2.10.34-1    2.10.34-2     -0.76 MiB      20.01 MiB
core/iputils                                 20221126-1   20221126-2     0.00 MiB       0.11 MiB
extra/libgexiv2                                           0.14.0-4       1.13 MiB               
extra/libpgm                                 5.3.128-2    5.3.128-3     -0.02 MiB       0.17 MiB
extra/libraw                                 0.21.1-1     0.21.1-2       0.02 MiB       0.44 MiB
chaotic-aur/librewolf-extension-bitwarden    2022.9.1-1   2023.4.0-1     1.11 MiB       8.30 MiB
chaotic-aur/librewolf-extension-dark-reader  4.9.62-1     4.9.63-1       0.02 MiB       0.60 MiB
chaotic-aur/librewolf-extension-localcdn     2.6.45-1     2.6.50-1       0.74 MiB      19.41 MiB
chaotic-aur/linux-amd-znver3                 6.3.v.3-1    6.3.v.4-1      0.00 MiB      83.71 MiB
chaotic-aur/linux-amd-znver3-headers         6.3.v.3-1    6.3.v.4-1      0.00 MiB      14.60 MiB
core/pam                                     1.5.3-2      1.5.3-3        1.48 MiB       0.89 MiB
extra/python-cairo                           1.23.0-4     1.23.0-6       0.00 MiB       0.09 MiB
extra/python-gobject                         3.44.1-3     3.44.1-4       0.00 MiB       0.30 MiB

Total Download Size:   151.67 MiB
Total Installed Size:  370.81 MiB
Net Upgrade Size:        3.71 MiB

:: Proceed with installation? [Y/n]

do not update and post your garuda-inxi.

Do not post pictures without content, post just

"My login screen was broken after the update.".

Happy weekend all. :slight_smile:


There is an issue with mesa 23.1.0-1 that is impacting certain AMD GPUs. If you have an AMD GPU that may be your problem.

SGS's suggestion of restoring a snapshot is your easiest fix. If you need the update, add IgnorePkg=mesa to /etc/pacman.conf and see if that helps. If you can wait I would just hold off on updating until next week, then try again.


Because I only use garuda os. I can't see its screen or any gui. That's why I can't post outputs here.

I only use garuda os. I can't see its screen or any gui. That's why I can't post outputs here. I had no idea what your problem was so I didn't know how to open the topic of the thread. I only have the opportunity to take pictures.
I dont have any working snapshot.
I am aware of all the rules, I know how to write. But there is nothing that can be done about the situation.
Thank you for your sensitivity and help.
Thanks and have a nice weekend.

Yes, i have amd gpu. I dont have any working snaphot but I will try to do "IgnorePkg=mesa to /etc/pacman.conf". If that's the problem, removing mesa related stuff might be a solution, how can I do it?

No one asked you to change your os though. We literally baby walked you through how to change your tty to generate the required outputs store them in termbin which will generate a small url which you can easily type from your phone and we can understand what's happening in the system.

There was no need to be so aggressive.

Though I guess if you think this is too much work you can simply reinstall your os be done with it.


Sorry for not explaining myself fully. I guess I made you think that I know all the easy stuff and not doing it to be aggressive here.

I know that. When I first opened the subject, I couldn’t provide my internet connection, so it was like my hands and feet were tied. I have solved that problem now, I will put the terminal output here as soon as possible.

No, thanks.

If I had to reinstall a system that was broken by an update, I would prefer windows os instead. But windows os is disgusting enough some reasons.
So I will try to fix the problem. :slight_smile:

That’s nice to know. :smiley:

You can use


To connect to the wifi from terminal.


IgnorePkg would only work to prevent upgrading it after having restored a snapshot.
You can try downgrading it though, look in /var/cache/pacman/pkg/ and then sudo pacman -U the previous version. If that does not solve the problem, perhaps there is some other related package to downgrade too.


Thanks. I didn’t know this when the problem first occurred. I found nmtui from google last night, it’s a nice tool for terminal. I’ve never had to just use the terminal before. I’m learning slowly. I’ve been a little trouble for you too :slight_smile:

Thanks, I’ll try that.

why not use downgrade instead?
from man downgrade

DOWNGRADE(8)                                                                                   DOWNGRADE(8)

downgrade [option...]  <pkg> [pkg...]  [-- pacman_option...]

Downgrade Arch Linux packages.

Calling downgrade on a package will lead to the following output:


-  1)  terraform    0.11.11  2  remote
-  2)  terraform    0.11.12  1  /var/cache/pacman/pkg
+  3)  terraform    0.11.13  1  remote
+  4)  terraform    0.11.13  1  /var/cache/pacman/pkg
-  5)  terraform    0.12.0   1  remote
-  6)  terraform    0.12.0   1  /var/cache/pacman/pkg
7)  terraform    0.12.1   1  remote
Available packages (community):

The columns have the following meaning:

indicator Possible values: {-|+}

- indicates that the version was previously installed.

+ indicates the currently installed version.


1 Like

Finally my terminal outputs here:

garuda-inxi output

  Kernel: 6.3.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=9624ffb2-e752-4249-abf8-3e30708af045
    rw rootflags=subvol=@ quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=4a6f3745-262a-4d27-b125-2ce2cb1d7c24 loglevel=3 ibt=off
  Console: tty 3 DM: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: CROSSBLADE RANGER v: Rev X.0x serial: <superuser required>
    UEFI: American Megatrends v: 1803 date: 08/02/2017
  Info: model: AMD A10-7850K Radeon R7 12 Compute Cores 4C+8G bits: 64 type: MT MCP
    arch: Steamroller level: v2 built: 2014 process: GF 28nm family: 0x15 (21) model-id: 0x30 (48)
    stepping: 1 microcode: 0x6003106
  Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 256 KiB desc: d-4x16 KiB; i-2x96 KiB
    L2: 4 MiB desc: 2x2 MiB
  Speed (MHz): avg: 4032 high: 4300 min/max: 1700/4300 boost: enabled scaling:
    driver: acpi-cpufreq governor: performance cores: 1: 4300 2: 4300 3: 4300 4: 3229
    bogomips: 34399
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Pitcairn PRO [Radeon HD 7850 / R7 265 R9 270 1024SP] vendor: Hightech Information
    System driver: radeon v: kernel alternate: amdgpu arch: GCN-1 code: Southern Islands
    process: TSMC 28nm built: 2011-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports: active: DVI-I-1
    empty: DP-1,DVI-D-1,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 1002:6819 class-ID: 0300 temp: 37.0 C
  Device-2: Z-Star Micro A4 TECH HD PC Camera driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-5:3 chip-ID: 0ac8:3500 class-ID: 0102
    serial: <filter>
  Display: server: v: with: Xwayland v: 23.1.1 driver: X: loaded: radeon
    unloaded: modesetting alternate: fbdev,vesa dri: radeonsi gpu: radeon tty: 160x45
  Monitor-1: DVI-I-1 model: Asus VT207 serial: <filter> built: 2014 res: 1600x900 dpi: 89
    gamma: 1.2 size: 458x256mm (18.03x10.08") diag: 525mm (20.7") ratio: 16:9 modes: max: 1600x900
    min: 720x400
  API: OpenGL Message: GL data unavailable in console. Try -G --display
  Device-1: AMD FCH Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:14.2
    chip-ID: 1022:780d class-ID: 0403
  Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000 Series]
    vendor: Hightech Information System driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aab0 class-ID: 0403
  Device-3: Z-Star Micro A4 TECH HD PC Camera driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-5:3 chip-ID: 0ac8:3500 class-ID: 0102
    serial: <filter>
  API: ALSA v: k6.3.4-zen1-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.71 status: off with: 1: pipewire-pulse status: off 2: wireplumber
    status: off 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: c000 bus-ID: 05:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  IF-ID-1: wlp0s16f0u1 state: up mac: <filter>
  Local Storage: total: 4.89 TiB used: 74.34 GiB (1.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD30EZRX-00D8PB0 size: 2.73 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 0A80 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SDSSDX240GG25 size: 223.57 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: R211
    scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD5000AAJS-00A8B0 size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s tech: N/A serial: <filter>
    fw-rev: 3B01 scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST31500341AS size: 1.36 TiB block-size:
    physical: 512 B logical: 512 B speed: 3.0 Gb/s tech: HDD rpm: 7200 serial: <filter> fw-rev: CC1H
    scheme: GPT
  ID-5: /dev/sde maj-min: 8:64 vendor: SanDisk model: SDSSDA120G size: 111.79 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 00RL
    scheme: GPT
  ID-6: /dev/sdf maj-min: 8:80 model: Multi Flash Reader size: 14.91 GiB block-size:
    physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD
    serial: <filter> fw-rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 94.37 GiB size: 94.37 GiB (100.00%) used: 74.34 GiB (78.8%) fs: btrfs
    dev: /dev/sde2 maj-min: 8:66
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
    dev: /dev/sde1 maj-min: 8:65
  ID-3: /home raw-size: 94.37 GiB size: 94.37 GiB (100.00%) used: 74.34 GiB (78.8%) fs: btrfs
    dev: /dev/sde2 maj-min: 8:66
  ID-4: /var/log raw-size: 94.37 GiB size: 94.37 GiB (100.00%) used: 74.34 GiB (78.8%) fs: btrfs
    dev: /dev/sde2 maj-min: 8:66
  ID-5: /var/tmp raw-size: 94.37 GiB size: 94.37 GiB (100.00%) used: 74.34 GiB (78.8%) fs: btrfs
    dev: /dev/sde2 maj-min: 8:66
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.12 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sde3
    maj-min: 8:67
  System Temperatures: cpu: 44.9 C mobo: N/A gpu: radeon temp: 37.0 C
  Fan Speeds (RPM): N/A
  Processes: 194 Uptime: 1m wakeups: 0 Memory: available: 15.56 GiB used: 1.17 GiB (7.5%)
  Init: systemd v: 253 default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 2498 libs: 594 tools: octopi,paru Shell: fish v: 3.6.1
  running-in: tty 3 inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2023-05-23
  Last full system update: 2023-05-28
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

journalctl -r -n 500 output

Finally! My problem is solved. Actually, the problem was with the mesa package.
I downgraded version 23.1.0 to 23.0.3.

  1. I use

sudo downgrade mesa

and choose 23.0.3 version

Thats ok!

  1. Edited the pacman.conf

sudo nano /etc/pacman.conf


IgnorePkg = mesa

and saved it!

  1. I restarted the computer.


Yeah! Everything is working!

New Outputs:

  1. garuda-inxi
  2. journalctl -r -n 500

Thanks Solution for:





Working screenshot:


The issue is reported to be resolved with mesa-23.1.1-1. Go ahead and comment out the IgnorePkg= line in /etc/pacman.conf (or delete "mesa") and pull down the update if you want to give it a shot. :crossed_fingers: