Pipewire not detecting any audio device

After upgrading pipewire, I am not getting any audio from any of the sound devices. It isn't even detecting any soundcard or speaker. Kindly help.

pipewire
Compiled with libpipewire 0.3.24
Linked with libpipewire 0.3.24

Output of some related commands :

pactl info
Connection failure: Connection refused
ls -la /etc/pipewire  
total 24
drwxr-xr-x 1 root root  144 Apr 14 10:13 .
drwxr-xr-x 1 root root 4666 Apr 14 10:13 ..
-rw-r--r-- 1 root root 2018 Mar 18 22:09 client.conf
-rw-r--r-- 1 root root 2322 Mar 18 22:09 client-rt.conf
drwxr-xr-x 1 root root  188 Apr 14 10:09 media-session.d
-rw-r--r-- 1 root root 8224 Mar 18 22:09 pipewire.conf
-rw-r--r-- 1 root root 1584 Mar 18 22:09 pipewire-pulse.conf

systemctl --user enable --now pipewire pipewire-pulse  
Failed to enable unit: Unit file /home/linuxlover/.config/systemd/user/pipewire.service is masked.
systemctl unmask pipewire.service 
Unit pipewire.service does not exist, proceeding anyway.
pw-metadata   
can't connect: Host is down

Actually what you're showing is that pipewire isn't running.
In some distros, I've seen that one must manually create and/or enable the services. I can't remember details on which are which. I wanted to think that Garuda had the services created, but am not certain on that.
Also did you do the minimal (ie reboot)?

2 Likes

Firstly, Pipewire is now 0.3.25, so make sure you're actually up-to-date.

Secondly, merge your pacnew. https://wiki.archlinux.org/index.php/Pacman/Pacnew_and_Pacsave

Thirdly,

stop running random commands. :wink:

4 Likes
$ sudo pacman -S pipewire    
warning: pipewire-1:0.3.24-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) pipewire-1:0.3.24-1

Total Installed Size:  5.79 MiB
Net Upgrade Size:      0.00 MiB

It is saying that it's already up to date.

And how to merge pacnew?

$ find /etc -regextype posix-extended -regex ".+\.pac(new|save)" 2> /dev/null
/etc/timeshift-autosnap.conf.pacsave

And for

systemctl --user enable --now pipewire pipewire-pulse

I get

Failed to enable unit: Unit file /home/linuxlover/.config/systemd/user/pipewire.service is masked.

Is there any way to replace pipewire with pulseaudio?

yea.......I tried everything but still, I am unable to enable the service.

Use forum search function, please.

1 Like

That didn't help :worried:
See what happened,

$sudo pacman -Rns pipewire-alsa pipewire-pulse 
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire-pulse breaks dependency 'pulseaudio-bluetooth' required by gnome-bluetooth
:: removing pipewire-pulse breaks dependency 'pulseaudio' required by gnome-settings-daemon
:: removing pipewire-alsa breaks dependency 'pulseaudio-alsa' required by gnome-settings-daemon
:: removing pipewire-alsa breaks dependency 'pipewire-alsa' required by pipewire-support
:: removing pipewire-pulse breaks dependency 'pipewire-pulse' required by pipewire-support
:: removing pipewire-pulse breaks dependency 'pipewire-pulse' required by pulseeffects
:: removing pipewire-alsa breaks dependency 'pulseaudio-alsa' required by zoom

And when I try to remove the dependencies one by one , it breaks the system. :neutral_face:

$sudo pacman -S pulseaudio                                                                                                                                                                
resolving dependencies...
looking for conflicting packages...
:: pulseaudio and pipewire-pulse are in conflict. Remove pipewire-pulse? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire-pulse breaks dependency 'pulseaudio-bluetooth' required by gnome-bluetooth
:: removing pipewire-pulse breaks dependency 'pipewire-pulse' required by pipewire-support
:: removing pipewire-pulse breaks dependency 'pipewire-pulse' required by pulseeffects

$sudo pacman -R gnome-bluetooth                                                                                                                                                          
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing gnome-bluetooth breaks dependency 'gnome-bluetooth' required by gnome-control-center
:: removing gnome-bluetooth breaks dependency 'gnome-bluetooth' required by gnome-shell
:: removing gnome-bluetooth breaks dependency 'gnome-bluetooth' required by nautilus-bluetooth

It's in the wiki page I linked to above.

If you disabled the PipeWire service then why would you expect it to work?

We can't guess what manual changes you have made. If you make changes yourself then you really need to either write these down so you can revert them or trash everything and start over from scratch.

3 Likes

This morning (for my refreshment), I converted a current build. All it took was removing the remaining pulseaudio* components (pipewire installed by default, but still running pulseaudio daemon), then installing pipewire-pulse, rebooting. All was fine (for me).

3 Likes