Part of primary display is mirrored on secondary display on login screen

Hello.

Ever since installing Garuda, I've been experiencing the same bug where on the login screen (and the subsequent splash screen), the primary display is mirrored on the secondary display. The primary display being 1920x1080 and the secondary display being 3840x2160, it results in 1/4 of the secondary screen obstructed by the primary screen's mirror.

Here's the output of inxi -Faz:

System:    Kernel: 5.14.9-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=8a0a4f23-e4b4-468d-a55d-308b2de6b338  
rw [email protected] quiet
cryptdevice=UUID=06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc:luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
root=/dev/mapper/luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
resume=/dev/mapper/luks-a775b892-c6c9-43c9-8c98-189505509025 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Dell product: XPS 13 9370 v: N/A serial: <filter> Chassis: type: 10  
serial: <filter>  
Mobo: Dell model: 0W970W v: A06 serial: <filter> UEFI: Dell v: 1.15.0 date: 06/07/2021  
Battery:   ID-1: BAT0 charge: 48.4 Wh (100.0%) condition: 48.4/52.0 Wh (93.1%) volts: 8.6 min: 7.6  
model: LGC-LGC6.73 DELL H754V05 type: Li-ion serial: <filter> status: Full  
CPU:       Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake note: check  
family: 6 model-id: 8E (142) stepping: A (10) microcode: EA cache: L2: 8 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31999  
Speed: 2400 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 2400 2: 2398 3: 2398 4: 2400  
5: 2399 6: 2400 7: 2399 8: 2387  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0  
chip-ID: 8086:5917 class-ID: 0300  
Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:2  
chip-ID: 0bda:58f4 class-ID: 0e02 serial: <filter>  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1944 s-dpi: 96 s-size: 507x513mm (20.0x20.2") s-diag: 721mm (28.4")  
Monitor-1: eDP1 res: 1536x864 dpi: 135 size: 290x170mm (11.4x6.7") diag: 336mm (13.2")  
Monitor-2: DP1-1 res: 1920x1080 hz: 60 dpi: 81 size: 600x340mm (23.6x13.4") diag: 690mm (27.2")  
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.3 direct render: Yes
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
Device-2: Realtek USB Audio type: USB driver: snd-usb-audio bus-ID: 3-1.3.4:7
chip-ID: 0bda:402e class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.14.9-zen2-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
vendor: Rivet Networks Killer 1435 Wireless-AC driver: ath10k_pci v: kernel port: f040
bus-ID: 02:00.0 chip-ID: 168c:003e class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 4-1.4:4
chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
IF: enp57s0u1u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth: Device-1: Foxconn / Hon Hai type: USB driver: btusb v: 0.8 bus-ID: 1-7:3 chip-ID: 0489:e0a2
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 26.92 GiB (5.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC611 NVMe 512GB size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 11002111 temp: 51.9 C scheme: GPT
Partition: ID-1: / raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 26.92 GiB (5.9%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 708 KiB (0.3%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 26.92 GiB (5.9%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
ID-4: /var/log raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 26.92 GiB (5.9%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
ID-5: /var/tmp raw-size: 459.81 GiB size: 459.81 GiB (100.00%) used: 26.92 GiB (5.9%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-06b5b85e-d9c6-4b3d-8ad4-9160c300f9fc
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.33 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.86 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/dm-1
maj-min: 254:1 mapped: luks-a775b892-c6c9-43c9-8c98-189505509025
Sensors:   System Temperatures: cpu: 71.0 C mobo: 45.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 4801
Info:      Processes: 296 Uptime: 59m wakeups: 14 Memory: 15.33 GiB used: 5.17 GiB (33.7%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1408 lib: 341
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Here is a picture of what's happening as I've been unable to take a proper screenshot of the login screen: https://i.imgur.com/zhGehQV.jpg.

Is there anything I can do to avoid that?

Thanks!

Hi there, welcome!
Please check if this tutorial helps:

And in general ref.
https://wiki.archlinux.org/title/Multihead

5 Likes

Hello!

Thanks for the welcome and the tutorial. It worked and my problem is now solved.
Sorry for the useless thread!

2 Likes

No way! This shows (also to future users reading this thread) that the tutorials are great and the forum search works :wink:

8 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.