Pamac not seeing Updates while Discover and pacman do

Hi!
When I open Pamac and select the Updates tab, it says there's no updates/
But somehow and from somewhere, KDE Discover fetches updates, as well as "pacman -Syu" command:

I normally prefer Pamac gui as a way to upgrade packages and system. I just upgraded from Manjaro 2 days ago after yet another problem with updates and like it a lot so far, but would really prefer to be able to use Pamac for updates and package management instead of Discover.
Is there a way to fix Pamac?

Wrong mirror in pamac point to MJ and not to Garuda?
Since Garuda is not MJ your system will maybe break.

Thanks for replying! I did a fresh installation on my SSD that was Root folder, deleting everything and creating a btrfs.
The only thing that remained from MJ was my Home folder that is on a HDD. Could this have caused the issue?

Most of your personal configuration lies in your home directory, so absolutely.

Thanks! Makes sense since a lot of my DE settings were transfered from MJ (for what I'm very happy about).
I wouldn't want to lose my Home folder, how do I fix Pamac thinking it's on MJ?

Search for mirrorlist.

Far better to keep your data, but remove those configs (for the most part). You've just seen one very good reason why. Who knows what else you have yet to, um, discover? That being said, it is not uncommon to keep a few configs around, i.e. pulseaudio settings, etc. that won't vary between distributions or re-installations.

regards

1 Like

I'm adventurous, but I would say it's just easier and safer to start clean. I've done otherwise, and it's far more trouble to figure out what's wrong than to reconfigure something. I often preserve (off this partition) config files for like sway/i3, and such components that rely on lots of tinkering...but that's not much.

3 Likes

The easiest (and IMO smartest) thing to do is use the same partition for /home, but create a different username for your Garuda user.
This way you may have a clean Garuda user and preserve your settings, that you may slowly and carefully merge to the new user, or just keep them for a backup in case you want some consultation of "how was this working better in my previous system? worries.

4 Likes

solved by a complete clean install, just saved my docs on external hdd and moved them back to clean Garuda.

3 Likes

Reopening since the issue reproduces again - Pamac tells me there's no updates, while Pacman and KDE Discover do show updates

This is a fresh install latest updates installed, no Home folder leftovers no nothing. I had a day or two where all three were synced, and now first thing I see is Discover telling me there's updates, I launch Pamac (I prefer it to other options) which doesn't see any updates.

I guess it is obvious that this should be a bug in Pamac.
You should report this upstream to Pamac bug tracker.

2 Likes

Was thinking it wasn't configured properly, but might just be the case. Thanks!

I don't think so, but the best troubleshooting would be from the designers.
If you find it was config mistake, post here.
It should be better to let this unsolved, until you get the final reason.

1 Like

So I think I may have found one of the causes of the problem. They moved some functionality for KDE over into the tray app so you need to add pamac-tray to autostart applications. Don't know why they changed that. A good way to know if this will fix the issue is to simply run pamac-tray from your terminal and if that fixes it then you have the fix. Hope this helps

2 Likes

Hey I had the same problem, I used simple reflector, clicked the option "Refresh Databases" in Pamac and was resolved! Just it didn't show me the progress of instalation; however, I believe that it's a bug.

1 Like

Btw,

sudo pacman -Syu

is good practice for updating system.

And welcome to the forum.

That worked like a charm for me, was having the same issue, but that still doesn't solve the other one I have with pamac-tray, that is that the tray icon, even though it's an .svg, looks like a blurry mess, a problem I didn't face on my time with Manjaro, even though I'm using the same icon pack (Papirus btw)

Start a new topic to try find your problem.

4 Likes