Pacman: Failed retrieving `xapp`

Hi everyone! I have been on holidays for a week, and now that I'm back I'm trying to update/upgrade my garuda install.
However pacman fails during the update because it can't retrieve xapp from any mirror. I have refreshed my mirrors and added a couple more to be sure.
Any ideas on how to get out of this problem?

Here's the full output of sudo pacman -Syu:

Full output of sudo pacman -Syu
× sudo pacman -Syu                                                                                                                                                                    (base) 
warning: config file /etc/pacman.conf, line 34: directive 'TotalDownload' in section 'options' not recognised.
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 chaotic-aur is up to date
:: Starting full system upgrade...
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] y
resolving dependencies...
looking for conflicting packages...

Packages (227) alsa-card-profiles-1:0.3.30-2  alsa-lib-1.2.5-2  alsa-plugins-1:1.2.5-2  alsa-topology-conf-1.2.5-1  alsa-ucm-conf-1.2.5-2  aom-3.1.1-1  appstream-glib-0.7.18-2
               aqbanking-6.3.0-1  at-spi2-core-2.40.2-1  bluez-5.59-2  bluez-libs-5.59-2  boost-libs-1.76.0-1  ca-certificates-20210603-1  ca-certificates-mozilla-3.67-1
               ca-certificates-utils-20210603-1  chromium-91.0.4472.106-1  clang-12.0.0-1  colord-1.4.5-4  compiler-rt-12.0.0-1  cryptsetup-2.3.6-1  dhclient-4.4.2.P1-1  elfutils-0.185-1
               enchant-2.2.15-4  eog-40.2-1  evince-40.2-1  evolution-data-server-3.40.2-1  expac-10-3  ffmpeg-2:4.4-4  file-5.40-5  filesystem-2021.05.31-1  firefox-89.0-1
               fuse-common-3.10.4-1  fuse3-3.10.4-1  fzf-0.27.2-1  garuda-assistant-git-r44.63496ea-1  garuda-boot-options-1.0.1-1  garuda-common-settings-1.2.9-1  garuda-gamer-1.0.1-1
               garuda-gnome-settings-1.2.4-1  garuda-hooks-1.0.4-1  garuda-setup-assistant-1.0.8-1  garuda-welcome-1.0.5-1  git-2.32.0-1  github-desktop-2.8.3-1  glib2-2.68.3-1
               gnome-autoar-0.3.3-1  gnome-bluetooth-3.34.5-2  gnome-desktop-1:40.2-1  gnome-disk-utility-40.1-2  gnome-settings-daemon-40.0.1-2  gnome-shell-1:40.2-1
               gnome-shell-extensions-40.2-1  gnome-terminal-transparency-3.40.2-1  gnuplot-5.4.2-1  gnutls-3.7.2-2  go-2:1.16.5-1  gptfdisk-1.0.8-1  graphviz-2.47.2-1  grub-2:2.06-1  gsl-2.7-1
               gst-plugin-pipewire-1:0.3.30-2  gtk-update-icon-cache-1:4.2.1-2  gtk3-1:3.24.29-2  gtk4-1:4.2.1-2  gupnp-1.2.7-1  hdparm-9.62-1  hwids-20210613-1  imagemagick-7.1.0.0-1
               imath-3.0.4-2  inetutils-2.0-1  inkscape-1.1-4  intel-ucode-20210608-1  jasper-2.0.32-1  jre-openjdk-15.0.3.u3-1  jre-openjdk-headless-15.0.3.u3-1  js78-78.11.0-1  kauth-5.83.0-1
               kcoreaddons-5.83.0-1  kitemmodels-5.83.0-1  kvantum-theme-sweet-git-r191.3257037-1  kwindowsystem-5.83.0-1  lib32-alsa-lib-1.2.5-2  lib32-alsa-plugins-1.2.5-1
               lib32-clang-12.0.0-1  lib32-glib2-2.68.3-1  lib32-gnutls-3.7.2-1  lib32-libcanberra-0.30+2+gc0620e4-4  lib32-libcap-2.50-1  lib32-libelf-0.185-1  lib32-libnm-1.30.4-1
               lib32-libogg-1.3.5-1  lib32-libtasn1-4.17.0-1  lib32-libtirpc-1.3.2-1  lib32-libva-mesa-driver-21.1.2-1  lib32-libx11-1.7.2-1  lib32-libxcrypt-4.4.22-2  lib32-llvm-libs-12.0.0-1
               lib32-mesa-21.1.2-1  lib32-mesa-vdpau-21.1.2-1  lib32-mpg123-1.28.0-1  lib32-nspr-4.31-1  lib32-nss-3.67-1  lib32-ocl-icd-2.3.0-1  lib32-opencl-mesa-21.1.2-1
               lib32-p11-kit-0.24.0-1  lib32-pipewire-1:0.3.30-3  lib32-util-linux-2.37-1  lib32-vulkan-intel-21.1.2-1  lib32-vulkan-mesa-layers-21.1.2-1  lib32-vulkan-radeon-21.1.2-1
               lib32-zstd-1.5.0-2  libcanberra-0.30+2+gc0620e4-4  libcanberra-pulse-0.30+2+gc0620e4-3 [removal]  libcap-2.50-2  libcerf-1:1.15-1  libclc-12.0.0-1  libcmis-0.5.2-8
               libcolord-1.4.5-4  libedit-20210522_3.1-1  libelf-0.185-1  libgusb-0.3.7-1  libinput-1.18.0-1  libixion-0.16.1-6  liblouis-3.18.0-1  libmbim-1.24.8-1  libmm-glib-1.16.6-1
               libnautilus-extension-typeahead-40.1-1  libnftnl-1.2.0-1  libnice-0.1.18-2  libnl-3.5.0-3  libogg-1.3.5-1  liborcus-0.16.1-7  libp11-kit-0.24.0-1  libpcap-1.10.1-1
               libphonenumber-8.12.24-1  libqmi-1.28.6-1  libreoffice-fresh-7.1.4-1  librewolf-89.0-1  librsvg-2:2.50.7-1  libtorrent-rasterbar-1:1.2.14-1  libva-mesa-driver-21.1.2-1
               libwpe-1.10.1-1  libx11-1.7.2-1  libxcrypt-4.4.22-4  libxnvctrl-465.31-1  linux-5.12.10.arch1-1  linux-zen-5.12.10.zen1-1  linux-zen-headers-5.12.10.zen1-1  llvm-libs-12.0.0-2
               memtest86+-5.31b-1  mesa-21.1.2-1  mesa-vdpau-21.1.2-1  modemmanager-1.16.6-1  mpg123-1.28.0-1  mtools-1:4.0.29-1  mutter-40.2.1-1
               nautilus-pdf-tools-git-1.2.9.0extras20.04.03.r100.510257d-1  nautilus-typeahead-40.1-1  netpbm-10.73.34-1  nettle-3.7.3-1  nextcloud-client-3.2.2-1  nodejs-16.3.0-1  nspr-4.31-1
               nss-3.67-1  nvidia-465.31-8  nvidia-settings-465.31-1  ocl-icd-2.3.0-1  opencl-mesa-21.1.2-1  openexr-3.0.4-1  openmpi-4.1.1-2  p11-kit-0.24.0-1  pace-1.4.1.1-2
               pacman-contrib-1.4.0-3  pacutils-0.11.0-2  pambase-20210605-2  paru-1.7.2-1  pcre2-10.37-1  pipewire-1:0.3.30-2  pipewire-media-session-1:0.3.30-2  polkit-0.119-1
               poppler-21.06.1-1  poppler-glib-21.06.1-1  pulseaudio-alsa-1:1.2.5-2  python-idna-3.2-1  python-more-itertools-8.7.0-1  python-setuptools-1:57.0.0-2  python-urllib3-1.26.5-1
               qt5-declarative-5.15.2+kde+r28-1  qt5-tools-5.15.2+kde+r17-2  qt5-webengine-5.15.4-3  re2-1:20210601-1  recode-3.7.9-1  samba-4.14.5-1  smbclient-4.14.5-1  sqlite-3.35.5-2
               steam-native-runtime-1.0.0.70-2  strongswan-5.9.2-1  stunnel-5.59-1  sudo-1.9.7.p1-1  sushi-3.38.1-1  teams-1.4.00.13653-1  timeshift-20.11.1+4+gd437358-1  tracker3-3.1.2-1
               tracker3-miners-3.1.2-1  unrar-1:6.0.7-1  uresourced-0.4.0-1  util-linux-2.37-3  util-linux-libs-2.37-3  visual-studio-code-bin-1.57.0-1  vlc-3.0.15-2  vte-common-0.64.2-2
               vte3-0.64.2-2  vulkan-headers-1:1.2.179-1  vulkan-icd-loader-1.2.177-1  vulkan-intel-21.1.2-1  vulkan-mesa-layers-21.1.2-1  vulkan-radeon-21.1.2-1  vulkan-swrast-21.1.2-1
               webrtc-audio-processing-0.3.1-3  whois-5.5.10-1  wireless-regdb-2021.04.21-1  wpebackend-fdo-1.10.0-1  xapp-2.2.0-1  xfsprogs-5.12.0-1  xkeyboard-config-2.33-1  zbar-0.23.1-7
               zoom-5.6.7-1

Total Download Size:      0.19 MiB
Total Installed Size:  5512.59 MiB
Net Upgrade Size:        51.69 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 xapp-2.2.0-1-x86_64.pkg.tar.zst failed to download
 Total (1/8)                                                                             189.9 KiB   150 KiB/s 00:01 [----------------------------------------------------------------------] 100%
error: failed retrieving file 'xapp-2.2.0-1-x86_64.pkg.tar.zst' from archlinux.thaller.ws : The requested URL returned error: 404
error: failed retrieving file 'xapp-2.2.0-1-x86_64.pkg.tar.zst' from mirror.f4st.host : The requested URL returned error: 404
error: failed retrieving file 'xapp-2.2.0-1-x86_64.pkg.tar.zst' from mirror.chaoticum.net : The requested URL returned error: 404
error: failed retrieving file 'xapp-2.2.0-1-x86_64.pkg.tar.zst' from mirror.f4st.host : The requested URL returned error: 404
error: failed retrieving file 'xapp-2.2.0-1-x86_64.pkg.tar.zst' from mirror.pseudoform.org : The requested URL returned error: 404
error: failed retrieving file 'xapp-2.2.0-1-x86_64.pkg.tar.zst' from arch.mirror.constant.com : The requested URL returned error: 404
error: failed retrieving file 'xapp-2.2.0-1-x86_64.pkg.tar.zst' from mirror.chaoticum.net : The requested URL returned error: 404
error: failed retrieving file 'xapp-2.2.0-1-x86_64.pkg.tar.zst' from mirror.telepoint.bg : The requested URL returned error: 404
error: failed retrieving file 'xapp-2.2.0-1-x86_64.pkg.tar.zst' from archlinux.thaller.ws : Protocol "rsync" not supported or disabled in libcurl
error: failed retrieving file 'xapp-2.2.0-1-x86_64.pkg.tar.zst' from arch.mirror.constant.com : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.

Try

upd

in terminal, it refresh your mirrorlist.

And

warning: config file /etc/pacman.conf, line 34: directive 'TotalDownload' in section 'options' not recognised.

seems there are pacnew files you must carefully merge, search in forum :slight_smile:

3 Likes

it worked :slight_smile: Thank you very much!
I wasn't sure if "Newbies" was the right place to post this question, but clearly it was :smiley:

What's the difference between upd and refreshing using the garuda assistant? The latter is what I tried before posting

1 Like

It's just, for me, faster, that's all.

alias | grep upd
alias upd 'sudo reflector --country Germany --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacman.d/mirrorlist && cat /etc/pacman.d/mirrorlist && sudo pacman -Syu'
3 Likes

Then I must have done something wrong before, because I updated the mirrors from the garuda assistant before posting, but it didn't help.
upd helped instead.

Anyway thanks again, now is time to dig into those pacnew files :sunglasses:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.