Overheating problem

So, I wonder if someone can help me whit the temperature problem that i have with Garuda. A few members in the forum helpme with auto-freqcpu, but, after runnig it, it seems that doesn't make any change in terms of thermal reduction.

The CPU is always at 1600 Mhz, ( 52°C) and I just have some open tabs and the terminal.

"auto-cpufreq" refresh in: 1
Executed on: May 10 (Monday) - 17:37:12

-------------------------------------------------------------------------------

Linux distro: Garuda Linux Soaring Spotted-Eagle
Linux kernel: 5.12.2-zen1-1-zen
Processor: Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz
Cores: 4
Architecture: x86_64
Driver: intel_cpufreq

------------------------------ Current CPU stats ------------------------------

CPU max frequency: 1600 MHz
CPU min frequency: 800 MHz

Core    Usage   Temperature     Frequency
CPU0:     1.0%     52 °C     1589 MHz
CPU1:     1.0%     46 °C     1600 MHz
CPU2:     2.0%     52 °C     1600 MHz
CPU3:     1.0%     46 °C     1600 MHz

---------------------------- CPU frequency scaling ----------------------------

Battery is: charging

Setting to use: "performance" governor

Total CPU usage: 0.5 %
Total system load: 1.21
Average temp. of all cores: 49.0 °C

Load optimal
setting turbo boost: off
Warning: Changing CPU turbo is not supported. Skipping.

-------------------------------------------------------------------------------

"auto-cpufreq" refresh in: 3^C

I know this is a forum and you guys are doing the best that you can with helping us, but it's not an excuse to be rude whit the new comers of this distro. In my case I'm a newbie user for linux. If I request help in here is cause eather i don't know what exactly to ask and where to find a solution.

Anyway, thanks in advance for the help that you can provide us.

The software is setting the performance governor because you are running on AC power.

This is not a very high temperature for a CPU.

However, have you also cleaned out your laptop's fans and vents?

5 Likes

Thanks! I recently make a full cleanup of the laptop, I even change the thermal paste. I was running Windows 10 and I don't have this issue before. This problem start when I switch to garuda a week ago. So, maybe theres a way to change the CPU governor or something like that?

Not to be rude, but your thread was locked because a moderator, dev, and distro creator requested you to provide your system specs and you did not cooperate with posting the requested outputs. Generally, any thread I respond to where the user does not post outputs (as text) when requested has their thread locked until they edit their OP and provide the requested info.

This is the way the forum works. @SGS posted the link to the Garuda Wiki instructions of how to post your system specs and you refused to do so. IMO you were the one who was behaving rudely on our forum by refusing to post your specs when requested.

As the instructions were linked for you on how to do so, ignorance is not an excuse. When you are pointing the finger at the forum assistants you always have 3 pointing back at yourself. Just saying. :man_shrugging:

4 Likes

How did you get the idea that its "too hot"? As pointed out already, 49°C is not a high temperature for a CPU. Lets take mine as example

------------------------------ Current CPU stats ------------------------------

CPU max frequency: 2300 MHz
CPU min frequency: 400 MHz

Core    Usage   Temperature     Frequency
CPU0:     4.0%     41 °C     2400 MHz
CPU1:    11.1%     45 °C     2400 MHz
CPU2:     5.0%     41 °C     2400 MHz
CPU3:     3.9%     45 °C     2300 MHz

---------------------------- CPU frequency scaling ----------------------------

Battery is: charging

Setting to use: "performance" governor

Total CPU usage: 3.0 %
Total system load: 0.89
Average temp. of all cores: 43.0 °C

Load optimal
setting turbo boost: off

-------------------------------------------------------------------------------

These stats are from being mostly idle after applying thermal paste & cleaning out the inner of this laptop a few days ago, it wont get much better :stuck_out_tongue:

5 Likes

Mine idles around 50 °C on a regular basis, new laptop.

4 Likes

I recognize my mistake, in fact I did not pay attention to this request. Now I know, how the help works in this forum. Thank you for pointing it out. And if you took my claim as something offensive and personal I apologize it was not my intention.

Maybe it is a fault of my device, although I'm not sure, it feels to the touch. Garuda starts well, no apparent heat, but as I open applications or tabs in the browser starts to heat up to such an extent that it is uncomfortable to type with the keyboard. This did not happen to me in windows, so I thought it was due to some Garuda configuration.

6 Likes

Thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.