Os-prober-btrfs is not recognizing Windows partition

[email protected] in ~ took 11s
╰─λ inxi -Faz
System:    Kernel: 5.14.2-zen1-2-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=29e83f0f-f36a-4488-b48e-1b1b8e2bc928 rw  
[email protected] splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
loglevel=3 quiet
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux  
base: Arch Linux  
Machine:   Type: Laptop System: LENOVO product: 81NB v: Lenovo IdeaPad S340-14API serial: <filter> Chassis: type: 10  
v: Lenovo IdeaPad S340-14API serial: <filter>  
Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN serial: <filter> UEFI: LENOVO v: AMCN29WW(V1.12) date: 01/27/2021  
Battery:   ID-1: BAT1 charge: 15.3 Wh (28.9%) condition: 53.0/52.5 Wh (101.0%) volts: 11.0 min: 11.3  
model: 0x4C 0x47 0x43 0x00 0x32 0x30 0x 0x4C 0x31 0x38 0x4C 0x33 0x50 0x5250 type: Li-ion serial: <filter>  
status: Discharging cycles: 403  
CPU:       Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen  
family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108109 cache: L2: 2 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33537  
Speed: 1386 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1386 2: 1366 3: 1388 4: 1396 5: 1388  
6: 1395 7: 1337 8: 1397  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso vendor: Lenovo driver: amdgpu v: kernel bus-ID: 04:00.0
chip-ID: 1002:15d8 class-ID: 0300
Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus-ID: 1-4:2 chip-ID: 174f:2426 class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x174mm (12.2x6.9") diag: 355mm (14")
OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.42.0 5.14.2-zen1-2-zen LLVM 12.0.1) v: 4.6 Mesa 21.2.1
direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:15de class-ID: 0403
Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo
driver: snd_pci_acp3x v: kernel alternate: snd_rn_pci_acp3x bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.14.2-zen1-2-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.35 running: yes
Network:   Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: Lenovo ThinkPad E595 driver: rtw_8822be v: N/A
modules: rtw88_8822be port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:b822 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth: Device-1: Realtek RTL8822BE Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8 bus-ID: 3-2:2 chip-ID: 0bda:b023
class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 4 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 27.76 GiB (2.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lenovo O.E.M. model: RPFTJ256PDD2MWX size: 238.47 GiB block-size:
physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter> rev: 11.9 temp: 49.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: LFM1 scheme: GPT
Partition: ID-1: / raw-size: 38.09 GiB size: 38.09 GiB (100.00%) used: 23 GiB (60.4%) fs: btrfs dev: /dev/nvme0n1p7
maj-min: 259:7
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 580 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p5
maj-min: 259:5
ID-3: /home raw-size: 25.84 GiB size: 25.84 GiB (100.00%) used: 4.76 GiB (18.4%) fs: btrfs dev: /dev/nvme0n1p6
maj-min: 259:6
ID-4: /var/log raw-size: 38.09 GiB size: 38.09 GiB (100.00%) used: 23 GiB (60.4%) fs: btrfs dev: /dev/nvme0n1p7
maj-min: 259:7
ID-5: /var/tmp raw-size: 38.09 GiB size: 38.09 GiB (100.00%) used: 23 GiB (60.4%) fs: btrfs dev: /dev/nvme0n1p7
maj-min: 259:7
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 5.73 GiB used: 1.61 GiB (28.1%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 53.9 C mobo: N/A gpu: amdgpu temp: 53.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 339 Uptime: 1h 54m wakeups: 5 Memory: 5.73 GiB used: 3.38 GiB (58.9%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1828 pacman: 1822 lib: 459 flatpak: 6 Shell: fish
v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

I have updated the system and the os-prober-btrfs doesn't recognize windows

╭─[email protected] in ~ took 3s
╰─λ sudo os-prober
[sudo] password for asa:
/dev/nvme0n1p7:Garuda Linux:Garuda:linux:btrfs:UUID=29e83f0f-f36a-4488-b48e-1b1b8e2bc928:[email protected]

please help in fixing issue.

sudo update-grub gives,

sudo update-grub
[sudo] password for asa:
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-lts
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-lts.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-lts-fallback.img
Found linux image: /boot/vmlinuz-linux-hardened
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-hardened.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-hardened-fallback.img
Found linux image: /boot/vmlinuz-linux-cacule
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-cacule.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-cacule-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Garuda Linux on /dev/nvme0n1p7
Found Garuda Linux on /dev/nvme0n1p7
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Info: Separate boot partition not detected
Found snapshot: 2021-09-14 21:25:29 | timeshift-btrfs/snapshots/2021-09-14_21-25-29/@
Found snapshot: 2021-09-13 17:31:24 | timeshift-btrfs/snapshots/2021-09-13_17-31-24/@
Found snapshot: 2021-09-12 09:31:01 | timeshift-btrfs/snapshots/2021-09-12_09-31-01/@
Found snapshot: 2021-09-10 16:45:09 | timeshift-btrfs/snapshots/2021-09-10_16-45-09/@
Found snapshot: 2021-09-09 10:29:52 | timeshift-btrfs/snapshots/2021-09-09_10-29-52/@
Found snapshot: 2021-09-02 22:00:02 | timeshift-btrfs/snapshots/2021-09-02_22-00-02/@
Found 6 snapshot(s)
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

when was your last update?

yesterday, and i do almost daily updates, 2 days once atleast.

I don't think this is needed anymore, but try to manually configure the os-prober by adding GRUB_DISABLE_OS_PROBER=false to /etc/default/grub
And sudo update-grub


it's set to false and still same issue. os-prober-btrfs works but doesn't recognize windows, a lot of users have been facing this.

seems like it has been an issue across all distos. i came across [Solved] GRUB and os-prober do not see Windows 10 on a different drive / Newbie Corner / Arch Linux Forums maybe it can help



MS Windows

Often, partitions containing Windows will be automatically discovered by os-prober. However, NTFS partitions may not always be detected when mounted with the default Linux drivers. If GRUB is not detecting it, try installing NTFS-3G and remounting.

Encrypted Windows partitions may need to be decrypted before mounting. For BitLocker, this can be done with dislockerAUR. This should be sufficient for os-prober to add the correct entry.

and more

I have no problems (Lenovo), as I have written here before in the forum.
So it's either due to missing drivers, BIOS settings (fastboot set from M$ after updates) or maybe other changes made by the user.

The easiest thing would be to set up a custom.cfg for M$.


It works also for me, also after update with os-prober-btrfs.


It is worth checking IMO...


I'm also on a Lenovo laptop, (Ideapad S340), windows was being recognized before the os-prober-btrfs replacement.. I even tried mounting ntfs unmount & remounting. nothing works.. NTFS-3G is installed. Windows isn't encrypted. I am able to boot to windows from the bios boot menu f12 and there haven't been any updates to windows..

oops, double, same from post #4 here.

The issue has been solved with the new update to os-prober-btrfs. Forgot to mention, thanks for the update and quick support. Loving garuda, but have few issues which I'm trying to resolve.


Anyone know why this new prober doesn't show Windows installation anymore? Just curious. Maybe needs a new thread

Update your system, it's solved.


Update your system, boot into windows, restart then go into garuda and it will be recognized.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.