Os-prober-btrfs and os-prober-garuda are in conflict

Hello.

I got problem when I run sudo pacman -Syu:

os-prober-btrfs and os-prober-garuda are in conflict (os-prober). Remove os-prober-garuda?

Am I must remove os-prober-garuda? And If I replace that, what's the side effect of removing it?

os-prober-btrfs replaces os-prober-garuda so you should probably say yes to the replacement.

8 Likes

Hey @dalto

I did say yes to this but now my GRUB menu does not show my Windows installation. When I run update-grub, in the output I got an error like line /usr/share/os-prober/common.sh: line 2: /usr/lib/newns: No such file or directory and on running os-prober --help I got the same thing. So, I guess os-prober-btrfs is broken or is there any other problem?

Try,

sudo grub-mkconfig -o /boot/grub/grub.cfg

update the system again this time it will work

i removed the offending patch

9 Likes

Yes, it works now. Thanks

Hi, I have the same problem. My os-prober-btrfs is on version 1.79-2 and it doesn't find my Windows installation anymore.

1 Like

Windows is overrated but give it a try with

sudo update-grub
2 Likes

Yeah, just running os-prober (for which there appears to be no help or man page) only finds the btrfs volumes, and doesn't show Windows at all.

╭─***@Omen17 in /boot/grub🔒 took 2s
╰─λ sudo os-prober --help
/dev/sdb2:Garuda Linux:Garuda:linux:btrfs:UUID=4e82da31-89de-47a1-a764-d98b8c67f439:subvol=
/dev/sdb2:Garuda Linux:Garuda1:linux:btrfs:UUID=4e82da31-89de-47a1-a764-d98b8c67f439:subvol=@

13m

I just upgraded today as well, and my Windows 10 installation is no longer coming up after upgrading to os-prober-btrfs, either. I've tried the various update-grub suggestions, but they do not work, either. Whatever y'all did removed some very much-used functionality from GRUB, and it's going to force me to use the BIOS hotkey every time I want to reboot into Windows. Please fix this. It's going to become a major knock against this distribution, which I otherwise like very much and champion to others.

Works fine here.

Open new topic, please, this one is solved.

1 Like

No, it isn't.

xx@Omen17 in ~ took 17s
[🔴] × sudo pacman -Syu os-prober-btrfs
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
DEB_Arch_Extra                          3.1 KiB  4.10 KiB/s 00:01 [------------------------------------] 100%
warning: os-prober-btrfs-1.79-2 is up to date -- reinstalling
:: Starting full system upgrade...

I'm at the newest version, and when I run os-prober, this still happens:

╭─xx@Omen17 in ~ took 8ms
[🔴] × sudo os-prober
/dev/sdb2:Garuda Linux:Garuda:linux:btrfs:UUID=4e82da31-89de-47a1-a764-d98b8c67f439:subvol=@

Whatever y'all changed, it's no longer seeing Windows 10 on the nvme. This is NOT resolved.

What @SGS is saying is that the original issue is resolved. The original question was about doing a replacement. Your issue is about Windows not being detected by os-prober. You should open your own topic instead of using this one which is marked resolved.

6 Likes