OpenVPN - attemped connections time out following update

Hi all,

Fresh install using the garuda-dr460nized-linux-zen-221019.iso

Applied post-install updates using Garuda Setup Assistant.

Configured VPN using files imported from provider - attempts to connect to all servers time out.

Rolled back to initial snapshot post-install using Snapper Tools. Configured VPN before reapplying updates. VPN worked perfectly! As soon as updates reapplied, though... badness again ensues.

I have tried with UFW in enabled and disabled state.

I have tried most recent config files from VPN provider (Ivacy) and older ones. I have tried configuring the connections manually.

I tried re-importing VPN configs post-update as per this link: [SOLVED] VPN stopped working after update of openvpn and openssl / Networking, Server, and Protection / Arch Linux Forums

I have briefly spun up KDE Neon 20221117 and Fedora 37 but cannot reproduce the issue.

I think I have to roll back the individual openVPN packages to older versions and keep them from updating while this issue is fixed upstream. Pointers on how to do this gratefully received.

TIA.

System:
Kernel: 6.0.11-AMD arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-amd
root=UUID=39963002-dbfd-410c-86cb-4f5ec06de926 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: X570 AORUS ELITE WIFI v: -CF
serial: <superuser required>
Mobo: Gigabyte model: X570 AORUS ELITE WIFI serial: <superuser required>
UEFI: American Megatrends LLC. v: F37d date: 07/20/2022
Battery:
Device-1: hidpp_battery_0 model: Logitech G603 Wireless Gaming Mouse
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3 gen: 4
level: v3 note: check built: 2021-22 process: TSMC n7 (7nm)
family: 0x19 (25) model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 2407 high: 3700 min/max: 2200/4950 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2200 2: 2200
3: 3700 4: 2200 5: 2200 6: 2879 7: 2200 8: 2200 9: 2200 10: 2200 11: 2143
12: 2200 13: 2819 14: 2200 15: 3700 16: 2838 17: 2200 18: 2200 19: 2332
20: 2200 21: 2168 22: 2200 23: 2200 24: 2200 bogomips: 177685
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Sapphire driver: amdgpu v: kernel arch: RDNA-1 code: Navi
process: TSMC n7 (7nm) built: 2019-20 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-1 empty: DP-2,HDMI-A-1,HDMI-A-2
bus-ID: 0c:00.0 chip-ID: 1002:731f class-ID: 0300
Device-2: Logitech C670i FHD Webcam type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-2.1:4 chip-ID: 046d:085d
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 96 s-size: 910x381mm (35.83x15.00")
s-diag: 987mm (38.84")
Monitor-1: DP-1 mapped: DisplayPort-0 model: Mi Monitor built: 2020
res: 3440x1440 hz: 50 dpi: 110 gamma: 1.2 size: 797x334mm (31.38x13.15")
diag: 864mm (34") modes: max: 3440x1440 min: 720x400
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon RX 5700 XT (navi10
LLVM 14.0.6 DRM 3.48 6.0.11-AMD) direct render: Yes
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
bus-ID: 1-2.1:4 gen: 4 chip-ID: 046d:085d speed: 16 GT/s class-ID: 0e02
lanes: 16 serial: <filter> bus-ID: 0c:00.1 chip-ID: 1002:ab38
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0e:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Logitech C670i FHD Webcam type: USB
driver: snd-usb-audio,uvcvideo
Sound API: ALSA v: k6.0.11-AMD running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.61 running: yes
Network:
Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 05:00.0
chip-ID: 8086:24fb class-ID: 0280
IF: wlp5s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 06:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-5:2 chip-ID: 8087:0aa7 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 9.35 TiB used: 3.29 TiB (35.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: Force MP600
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: EGFM13.0 temp: 35.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:5 vendor: Samsung model: SSD 970 EVO 250GB
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 35.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST4000DM004-2CV104
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5425 serial: <filter> rev: 0001 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT1000BX500SSD1
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 030 scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST1000DM003-1ER162
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: CC45 scheme: GPT
ID-6: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 860 QVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
ID-7: /dev/sde maj-min: 8:64 vendor: Seagate model: ST2000DM001-1ER164
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: CC26 scheme: GPT
ID-8: /dev/sdf maj-min: 8:80 type: USB vendor: Toshiba model: TransMemory
size: 7.22 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-9: /dev/sdg maj-min: 8:96 type: USB model: USB FLASH DRIVE
size: 14.44 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 22.21 GiB (4.8%)
fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 42.4 MiB (8.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 465.5 GiB size: 465.5 GiB (100.00%)
used: 22.21 GiB (4.8%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 465.5 GiB size: 465.5 GiB (100.00%)
used: 22.21 GiB (4.8%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 465.5 GiB size: 465.5 GiB (100.00%)
used: 22.21 GiB (4.8%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.28 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 34.8 C mobo: 29.0 C gpu: amdgpu temp: 43.0 C
mem: 44.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 434 Uptime: 1h 0m wakeups: 3 Memory: 31.28 GiB
used: 3.59 GiB (11.5%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1278
libs: 347 tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.23
Garuda (2.6.10-1):
System install date:     2022-12-04
Last full system update: 2022-12-04
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

I just tried spinning up an instance of EndeavourOS in VirtualBox, and configured my VPN - worked fine. This workaround does not help me, but it is another part of the puzzle.

Did you reboot, after updating but before setting up the VPN configuration? Certain things can be kind of broken after taking a big update, until you reboot.

Check in /var/cache/pacman/pkg for the old version you want to try rolling back to.

ls /var/cache/pacman/pkg | grep openvpn

Rolling back is as simple as working the package into this command:

sudo pacman -U file:///var/cache/pacman/pkg/old_package-version.pkg.tar.zst

Then crack open your pacman.conf and add the package to the IgnorePkg line so it will not be updated along with the rest of your packages.

sudo micro /etc/pacman.conf
...
IgnorePkg     = name_of_package
...

More here: Downgrading packages - ArchWiki

3 Likes

Thanks.

I followed this process, and ended up with the following in my /etc/pacman.conf:

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg   = networkmanager-openvpn-1.10.2-1-x86_64.pkg.tar.zst openvpn-2.5.8-2-x86_64.pkg.tar.zst
#IgnoreGroup =

After the update, the problem persisted. Rolled back to the original snapshot, VPN connected just fine. Perhaps there is another package involved? :-/

Maybe you could try the linux-lts kernel with the new packages.
Just an idea, because I assume you didn't install the linux-amd in the Enos VM.
For the rest, once updated, they should be similar for that matters.

1 Like

When updating, did you see a warning about those packages being ignored? Like (in my case)

warning: plymouth-git: ignoring package upgrade (22.02.122.r113.g1812e55a-1 => 22.02.122.r154.g96d050ce-1)

I think there shouldn't be .pkg.tar.zst there, only the package names.

2 Likes

Thanks for the suggestion.

I was able to reproduce the issue with linux-lts, linux-hardened, linux-zen, and linux-amd, all post-update.

No, no warning. I tried modifying the pacman.conf file to remove the .pkg.tar.zst suffix but it didn't make a difference.

No warning, so I guess they have been updated again.
Check if this is the case, if so, repeat the pacman -U thing in the cache folder to downgrade again.

I rolled back the packages using this method, and the problem persisted. I can only get the VPN to work if I roll back to the original snapshot using snapper tools, or reinstall.

Would it be reasonable to suspect another package has been pulled in with the update to cause this?

Sounds reasonable, yes.
Try also downgrading networkmanager-support to the same version as in the working snapshot.

This should be just the package name--no version number or extension or anything else. In this case, just networkmanager-openvpn.

What leads you to believe that networkmanager-openvpn is the rotton apple, as opposed to openvpn or something else in the stack?

Can you paste the full package upgrade list, from after installing/before the update?

Just a quick sanity check:

Can you confirm the reboot was taken after the update?

3 Likes

I have this issue also, it started about a month ago. All my pre-set OpenVPN connections would no longer connect. I even retried importing all my connections using network managers import and still would not connect. I then used the CLI commands to do it, still no go.

I have seen network manger update a few times and even OpenVPN once during the past four weeks and it still doesn't work. There have plenty of OpenVPN issues open in the bug reports, so it is a waiting game. I had to switch to using L2TP connections for my VPN which I think is not as secure as OpenVPN, which worries me, although it seems to work.

Edit to add: When importing the OpenVPN file with network manager vs importing via terminal using 'sudo nmcli connection import type openvpn file XXXXXX.opvn', the latter imports more settings when viewed in network manager. It still won't connect, but it tells me there is definitely some issues with network manager (importing.)

2 Likes

Yes, I tried a full reinstall, and rebooted after the first update. No difference in outcome.

I successfully changed the pacman.conf file to hold back the openvpn and networkmanager-openvpn packages and got the warnings y'all indicated I would see. So far, so good. I also identified another package openfortivpn which I decided to hold back. After applying updates, the problem has changed from the VPN connection timing out, to an instant 'failed to activate' error message.

I will experiment with holding back each package individually to see what triggers the failure.

The full package upgrade list is as follows:

adwaita-cursors-43-2  adwaita-icon-theme-43-2  alpm_octopi_utils-1.0.2-3.2
alsa-card-profiles-1:0.3.61-1  alsa-lib-1.2.8-1  alsa-ucm-conf-1.2.8-1
amd-ucode-20221109.60310c2-2  android-udev-20220903-2  apr-util-1.6.1-10  ark-22.08.3-1
attica-5.100.0-1  baloo-5.100.0-1  baloo-widgets-22.08.3-1  beautyline-1:20221127-1
bind-9.18.9-1  bluedevil-1:5.26.4-1  bluez-5.66-1  bluez-hid2hci-5.66-1  bluez-libs-5.66-1
bluez-plugins-5.66-1  bluez-qt-5.100.0-1  bluez-utils-5.66-1  bolt-0.9.4-1
boost-libs-1.80.0-3  breeze-5.26.4-1  breeze-icons-5.100.0-1  brotli-1.0.9-9
btrfs-assistant-1.6.3-1.1  btrfs-progs-6.0.2-1  bubblewrap-0.7.0-1  bzip2-1.0.8-5
ca-certificates-mozilla-3.85-1  candy-icons-git-r946.1123a5a-1  chromaprint-1.5.1-5
convertlit-1.8-11  coreutils-9.1-3  cryptsetup-2.6.0-1  curl-7.86.0-4  dconf-0.40.0-2
default-cursors-1-1  device-mapper-2.03.17-1  dnsmasq-2.87-3  dolphin-22.08.3-1
dolphin-plugins-22.08.3-1  downgrade-11.2.1-1.1  ecryptfs-utils-111-7  enchant-2.3.3-2
exfatprogs-1.2.0-1  expat-2.5.0-1  faad2-2.10.1-1  fakeroot-1.30.1-1  ffmpegthumbs-22.08.3-1
filesystem-2022.10.18-1  find-the-command-git-2.0.1.r0.gfecba1a-1.1  firedragon-107.0-1
firedragon-extension-plasma-integration-1.8.1-3.1  flac-1.4.2-1  fontconfig-2:2.14.1-2
frameworkintegration-5.100.0-1  fwupd-1.8.7-2  fzf-0.35.1-1  game-devices-udev-0.18-1.1
garuda-bash-config-1.0.3-1  garuda-common-settings-2.6.10-1  garuda-dr460nized-2.0.12-3
garuda-gamer-1.1.5-1  garuda-hooks-2.8.6-1  garuda-libs-1.4.1-1  garuda-migrations-2.1.1-1
garuda-settings-manager-1.0.1-3  garuda-settings-manager-kcm-1.0.1-3
garuda-setup-assistant-3.1.5-1  garuda-video-linux-config-1:r63.2f652e8-2  gawk-5.2.1-1
gcr-3.41.1-3  gcr-4-4.0.0-1  gdk-pixbuf2-2.42.10-1  geoclue-2.6.0-3  geocode-glib-3.26.4-2
geocode-glib-common-3.26.4-2  geoip-database-20221118-1  gettext-0.21.1-2
ghostscript-10.0.0-2  git-2.38.1-2  glew-2.2.0-6  glib2-2.74.3-1  gnome-firmware-43.0-1
gnustep-base-1.28.0-5  gnutls-3.7.8-4  gptfdisk-1.0.9-2  gsettings-desktop-schemas-43.0-1
gspell-1.12.0-2  gssdp-1.6.2-1  gst-libav-1.20.4-3  gst-plugin-pipewire-1:0.3.61-1
gst-plugins-bad-1.20.4-3  gst-plugins-bad-libs-1.20.4-3  gst-plugins-base-1.20.4-3
gst-plugins-base-libs-1.20.4-3  gst-plugins-good-1.20.4-3  gst-plugins-ugly-1.20.4-3
gstreamer-1.20.4-3  gstreamer-vaapi-1.20.4-3  gtk-update-icon-cache-1:4.8.2-1
gtk3-1:3.24.35-2  gtk4-1:4.8.2-1  gtksourceview4-4.8.4-1  guile-3.0.8-3  gupnp-1:1.6.2-1
gupnp-igd-1.2.0-3  harfbuzz-5.3.1-3  harfbuzz-icu-5.3.1-3  hostapd-2.10-2  hwdata-0.364-1
hyphen-2.8.8-5  iana-etc-20221107-1  icu-72.1-2  ijs-0.35-5  imagemagick-7.1.0.52-1
imath-3.1.6-1  inxi-3.3.23.1-1  iputils-20221126-1  iso-codes-4.12.0-1
kaccounts-integration-22.08.3-1  kactivities-5.100.0-1  kactivities-stats-5.100.0-1
kactivitymanagerd-5.26.4-1  karchive-5.100.0-1  kate-22.08.3-1  kauth-5.100.0-1
kbookmarks-5.100.0-1  kcmutils-5.100.0-1  kcodecs-5.100.0-1  kcompletion-5.100.0-1
kconfig-5.100.1-1  kconfigwidgets-5.100.0-1  kcontacts-1:5.100.0-1  kcoreaddons-5.100.0-1
kcrash-5.100.0-1  kdbusaddons-5.100.0-1  kde-cli-tools-5.26.4-1  kde-gtk-config-5.26.4-1
kdeclarative-5.100.0-1  kdeconnect-22.08.3-1  kdecoration-5.26.4-1  kded-5.100.0-1
kdegraphics-mobipocket-22.08.3-1  kdegraphics-thumbnailers-22.08.3-1
kdelibs4support-5.100.0-1  kdeplasma-addons-5.26.4-1  kdesu-5.100.0-1  kdialog-22.08.3-1
kdnssd-5.100.0-1  kemoticons-5.100.0-1  kfilemetadata-5.100.0-1  kglobalaccel-5.100.0-1
kguiaddons-5.100.0-1  kholidays-1:5.100.0-1  khotkeys-5.26.4-1  ki18n-5.100.0-1
kiconthemes-5.100.0-1  kidletime-5.100.0-1  kimageformats-5.100.0-1  kinfocenter-5.26.4-1
kinit-5.100.0-1  kio-5.100.0-1  kio-extras-22.08.3-1  kirigami2-5.100.0-1
kitemmodels-5.100.0-1  kitemviews-5.100.0-1  kjobwidgets-5.100.0-1  kjs-5.100.0-1
kmenuedit-5.26.4-1  kmod-30-3  knewstuff-5.100.0-1  knotifications-5.100.0-1
knotifyconfig-5.100.0-1  konsole-22.08.3-1  kpackage-5.100.0-1  kparts-5.100.0-1
kpeople-5.100.0-1  kpipewire-5.26.4-1  kpmcore-22.08.3-1  kpty-5.100.0-1
kquickcharts-5.100.0-1  krb5-1.20-3  krunner-5.100.0-1  kscreen-5.26.4-1
kscreenlocker-5.26.4-1  kservice-5.100.0-1  ksystemstats-5.26.4-1  ktexteditor-5.100.0-1
ktextwidgets-5.100.0-1  kunitconversion-5.100.0-1  kvantum-1.0.7-1  kwallet-5.100.0-1
kwallet-pam-5.26.4-1  kwayland-5.100.0-1  kwayland-integration-5.26.4-1
kwidgetsaddons-5.100.0-1  kwin-5.26.4-1  kwin-scripts-forceblur-0.6.1-1.1
kwindowsystem-5.100.0-1  kxmlgui-5.100.0-1  layer-shell-qt-5.26.4-1  lcms2-2.14-1
ldns-1.8.3-2  lib32-alsa-lib-1.2.8-1  lib32-brotli-1.0.9-5  lib32-bzip2-1.0.8-3
lib32-curl-7.86.0-2  lib32-expat-2.5.0-2  lib32-glew-2.2.0-4  lib32-glib2-2.74.3-1
lib32-icu-72.1-2  lib32-krb5-1.20-3  lib32-libdrm-2.4.114-1  lib32-libelf-0.188-1
lib32-libffi-3.4.4-1  lib32-libgcrypt-1.10.1-2  lib32-libgpg-error-1.46-1
lib32-libidn2-2.3.4-2  lib32-libldap-2.6.3-3  lib32-libpciaccess-0.17-1  lib32-libpsl-0.21.1-3
lib32-libssh2-1.10.0-2  lib32-libunistring-1.1-1  lib32-libunwind-1.6.2-2
lib32-libva-2.16.0-1  lib32-libva-mesa-driver-22.2.3-1  lib32-libx11-1.8.2-2
lib32-libxau-1.0.10-3  lib32-libxcb-1.15-2  lib32-libxcrypt-4.4.33-1  lib32-libxdamage-1.1.5-3
lib32-libxdmcp-1.1.3-2  lib32-libxext-1.3.5-1  lib32-libxfixes-6.0.0-2  lib32-libxi-1.8-2
lib32-libxml2-2.10.3-2  lib32-libxmu-1.1.4-1  lib32-libxrandr-1.5.2-3
lib32-libxrender-0.9.11-1  lib32-libxshmfence-1.3.1-1  lib32-libxxf86vm-1.1.5-1
lib32-llvm-libs-14.0.6-3  lib32-lm_sensors-1:3.6.0.r41.g31d1f125-2  lib32-mesa-22.2.3-1
lib32-mesa-vdpau-22.2.3-1  lib32-openssl-1:3.0.7-1  lib32-pipewire-1:0.3.61-1
lib32-pipewire-jack-1:0.3.61-1  lib32-systemd-252.2-1  lib32-vulkan-icd-loader-1.3.235-1
lib32-vulkan-intel-22.2.3-1  lib32-vulkan-mesa-layers-22.2.3-1  lib32-vulkan-radeon-22.2.3-1
lib32-xz-5.2.9-1  lib32-zlib-1.2.13-2  libappindicator-gtk3-12.10.0.r298-1  libarchive-3.6.1-5
libasyncns-1:0.8+r3+g68cd5af-2  libavif-0.11.1-1  libcamera-0.0.2-1
libcanberra-1:0.30+r2+gc0620e4-2  libcloudproviders-0.3.1+r8+g3a229ee-1  libdatrie-0.2.13-2
libdrm-2.4.114-1  libedit-20210910_3.1-2  libelf-0.188-1  libevent-2.1.12-4  libffi-3.4.4-1
libfprint-1.94.5-1  libgcrypt-1.10.1-2  libgit2-1:1.5.0-2  libgpg-error-1.46-2
libgusb-0.4.2-1  libical-3.0.16-2  libidn2-2.3.4-3  libinput-1.22.0-1
libinput-gestures-2.73-1.1  libinput_gestures_qt-0.3.2+7+g0868859-1.1  libjcat-0.1.12-1
libkdcraw-22.08.3-1  libkexiv2-22.08.3-1  libkscreen-5.26.4-1  libksysguard-5.26.4-1
libldap-2.6.3-2  libmbim-1.28.2-1  libmm-glib-1.20.2-1  libnewt-0.52.23-1  libnftnl-1.2.4-1
libnghttp2-1.51.0-1  libnm-1.40.6-1  libnma-1.10.4-3  libnma-common-1.10.4-3
libpipeline-1.5.7-1  libpng-1.6.39-1  libpsl-0.21.1-3  libpulse-16.1-3  libqalculate-4.4.0-2
libqmi-1.32.2-1  libsasl-2.1.28-3  libshout-1:2.4.6-2  libsoup-2.74.3-1  libsoup3-3.2.2-1
libspectre-0.2.11-1  libssh-0.10.4-3  libssh2-1.10.0-3  libsysprof-capture-3.46.0-1
libteam-1.31-7  libthai-0.1.29-2  libtirpc-1.3.3-2  libunistring-1.1-2  libunwind-1.6.2-2
libutf8proc-2.8.0-1  libva-mesa-driver-22.2.3-1  libva-utils-2.16.0-1  libvpx-1.12.0-2
libwireplumber-0.4.12-2  libx11-1.8.2-2  libxau-1.0.10-2  libxcb-1.15-2  libxcrypt-4.4.33-1
libxcursor-1.2.1-3  libxdamage-1.1.5-5  libxdmcp-1.1.4-1  libxext-1.3.5-1  libxfixes-6.0.0-2
libxft-2.3.7-1  libxi-1.8-2  libxinerama-1.1.5-1  libxkbcommon-1.4.1-2
libxkbcommon-x11-1.4.1-2  libxml2-2.10.3-2  libxmlb-0.3.10-1  libxpm-3.5.14-1
libxpresent-1.0.1-1  libxrandr-1.5.3-1  libxrender-0.9.11-1  libyuv-r2322+3aebf69d-1
linux-firmware-20221109.60310c2-2  linux-firmware-whence-20221109.60310c2-2
linux-wifi-hotspot-4.4.0-1.1  linux-zen-6.0.11.zen1-1  linux-zen-headers-6.0.11.zen1-1
llvm-libs-14.0.6-4  lm_sensors-1:3.6.0.r41.g31d1f125-2  luajit-2.1.0.beta3.r457.g637721d0-1
lvm2-2.03.17-1  lzo-2.10-4  make-4.3-5  man-db-2.11.1-1  man-pages-6.01-1  memtest86+-6.00-2
mercurial-6.3.1-1  mesa-22.2.3-1  mesa-vdpau-22.2.3-1  mhwd-db-garuda-git-1:r63.2f652e8-2
mhwd-nvidia-525.60.11-1  milou-5.26.4-1  minizip-1:1.2.13-2  mkinitcpio-33-1
mkinitcpio-openswap-0.1.0-3.1  mobile-broadband-provider-info-20221107-1
modemmanager-1.20.2-1  modemmanager-qt-5.100.0-1  mpfr-4.1.1.p1-1  mpg123-1.31.1-1
mpv-1:0.35.0-2  mtools-1:4.0.42-1  mujs-1.3.2-1  nano-7.0-1  neon-0.32.4-2
nerd-fonts-fira-code-2.2.2-1 [removal]  networkmanager-1.40.6-1  networkmanager-l2tp-1.20.6-2
networkmanager-qt-5.100.0-1  nm-cloud-setup-1.40.6-1  nmap-7.93-1  nss-3.85-1
ntfs-3g-2022.10.3-1  octopi-0.14.0-2  okular-22.08.3-1  openfortivpn-1.19.0-2
openldap-2.6.3-2  openpmix-4.2.2-1  openssh-9.1p1-3  openssl-3.0.7-2  orc-0.4.33-1
oxygen-sounds-5.26.4-1  pace-1.4.2-1.1  pacman-6.0.2-5  pacman-contrib-1.8.0-1
pacman-mirrorlist-20221204-1  pambase-20221020-1  pango-1:1.50.12-1
partitionmanager-22.08.3-1  paru-1.11.1-1.3  pciutils-3.9.0-1  perl-clone-0.45-4
perl-html-parser-3.80-1  perl-http-message-6.44-1  perl-uri-5.17-1  pipewire-1:0.3.61-1
pipewire-alsa-1:0.3.61-1  pipewire-audio-1:0.3.61-1  pipewire-jack-1:0.3.61-1
pipewire-pulse-1:0.3.61-1  pipewire-v4l2-1:0.3.61-1  pipewire-x11-bell-1:0.3.61-1
pipewire-zeroconf-1:0.3.61-1  pixman-0.42.2-1  pkcs11-helper-1.29.0-2
plasma-browser-integration-5.26.4-1  plasma-desktop-5.26.4-1  plasma-firewall-5.26.4-1
plasma-framework-5.100.1-1  plasma-integration-5.26.4-1  plasma-nm-5.26.4-1
plasma-pa-5.26.4-1  plasma-systemmonitor-5.26.4-1  plasma-thunderbolt-5.26.4-1
plasma-workspace-5.26.4.1-1  plasma5-applets-eventcalendar-76-1.1
plasma5-applets-netspeed-1.9-1.1  plasma5-applets-window-appmenu-0.8.0-1.1
plasma5-applets-window-title-0.7.1-2.1  plymouth-git-22.02.122.r154.g96d050ce-1  polkit-122-1
polkit-kde-agent-5.26.4-1  poppler-22.12.0-1  poppler-data-0.4.11-3  poppler-qt5-22.12.0-1
popt-1.19-1  powerdevil-5.26.4-1  ppp-2.4.9-3  prison-5.100.0-1  protobuf-21.10-1
purpose-5.100.0-1  python-3.10.8-3  python-pyqt5-5.15.7-3  qca-qt5-2.3.5-2
qqc2-desktop-style-5.100.0-1  qt5-base-5.15.7+kde+r176-1  qt5-declarative-5.15.7+kde+r23-1
qt5-graphicaleffects-5.15.7-1  qt5-imageformats-5.15.7+kde+r6-1  qt5-location-5.15.7+kde+r3-1
qt5-multimedia-5.15.7+kde+r1-1  qt5-quickcontrols-5.15.7-1  qt5-quickcontrols2-5.15.7+kde+r6-1
qt5-sensors-5.15.7-1  qt5-speech-5.15.7+kde+r1-1  qt5-svg-5.15.7+kde+r9-1
qt5-tools-5.15.7+kde+r1-2  qt5-translations-5.15.7-1  qt5-wayland-5.15.7+kde+r55-1
qt5-webchannel-5.15.7+kde+r3-1  qt5-webengine-5.15.11-2  qt5-x11extras-5.15.7-1
qtermwidget-1.2.0-1  quota-tools-1:4.09-1  raptor-2.0.15-21  readline-8.2.001-1
reflector-simple-2.0-1.1  rpcbind-1.2.6-3  rsync-3.2.7-2  rubberband-3.1.2-1  sddm-0.19.0-9
sddm-kcm-5.26.4-1  sdl2-2.26.0-1  sed-4.9-1  serf-1.3.9-8  shadow-4.12.3-2
signon-kwallet-extension-22.08.3-1  smbclient-4.17.3-1  snapper-tools-1.1.1-2.1
socat-1.7.4.3-2  solid-5.100.0-1  sonnet-5.100.0-1  soundtouch-2.3.2-1  spectacle-22.08.3-1
sqlite-3.40.0-2  srt-1.5.1-3  sstp-client-1:1.0.18-1  strongswan-5.9.8-2  subversion-1.14.2-1
sudo-1.9.12.p1-1  svt-av1-1.3.0-1  sweet-theme-full-git-r293.a73fd26-1  syndication-5.100.0-1
syntax-highlighting-5.100.0-1  systemd-252.2-2  systemd-libs-252.2-2
systemd-oomd-defaults-251.5-1.1  systemd-sysvcompat-252.2-2  systemsettings-5.26.4-1
taglib-1.13-1  tcl-8.6.13-1  tealdeer-1.6.1-1  texinfo-7.0-1  threadweaver-5.100.0-1
tpm2-tss-3.2.0-3  tracker3-3.4.1-1  ttf-firacode-nerd-2.2.2-2  tzdata-2022g-1
unarchiver-1.10.7-7  unrar-1:6.2.2-1  update-grub-0.0.1-7.1  usbutils-015-2
vpnc-1:0.5.3.r506.r204-2  vulkan-icd-loader-1.3.235-1  vulkan-intel-22.2.3-1
vulkan-mesa-layers-22.2.3-1  vulkan-radeon-22.2.3-1  vulkan-swrast-22.2.3-1  wavpack-5.6.0-1
wayland-1.21.0-2  webkit2gtk-2.38.2-2  whois-5.5.14-1  wireplumber-0.4.12-2
wpa_supplicant-2:2.10-7  xcb-proto-1.15.2-2  xcb-util-image-0.4.1-2  xcb-util-keysyms-0.4.1-4
xcb-util-renderutil-0.3.10-1  xcb-util-wm-0.4.2-1  xdg-desktop-portal-kde-5.26.4-1
xdg-utils-1.1.3+25+g8ae0263-1  xf86-input-void-1.4.2-1  xfsprogs-6.0.0-1  xl2tpd-1.3.18-1
xmlsec-1.2.37-1  xorg-xsetroot-1.1.3-1  xorg-xwayland-22.1.5-1  xsel-1.2.0.20200527-2
xxhash-0.8.1-3  xz-5.2.9-1  yad-12.1-1  zlib-1:1.2.13-2  zvbi-0.2.37-1

UPDATE: I rolled back to the first snapshot, and held back ONLY networkmanager-openvpn allowing openvpn and openfortivpn to update.

Success! My VPN is up and working. By process of elimination, networkmanager-openvpn seems to be the thorn among the roses.

Edited to add: thank you to all, and especially @BluishHumility for the input and assistance.

1 Like

What version of networkmanager-openvpn works?

Working version is 1.10.0-1. Borks when upgraded to 1.10.2-1.

1 Like

I'm using the latest networkmanager-openvpn on Arch with Nordvpn ovpn files since it was released with no issues. What vpn provider are you using?

EDIT: Just tried Nordvpn ovpn files on Garuda and it worked as expected.

1 Like

Provider is Ivacy. I suppose it is too early to completely rule out the config files from the provider being the issue, although I tried manual configuring everything also.

@RodneyCK ?

I use Keepsolid VPN Unlimited. If we were using the same provider I would say yes, it may be the provider files, but two different providers, unlikely.

2 Likes