Openpgp passphrase error

I feel like I live on this forum now :sob:

a week or so ago at startup or when opening application I get an openpgp prompt to enter password, it tells me wrong password even tho I know it's correct. it then gives me a kdewallet error. I just want to stop having to type in password every time my desktop or an app opens.

steps I've taken
-pacman-key --refresh-keys
-pacman -S archlinux-keyring
-reinstalled all packages
-cleared package cache
-tried to edit my passphrase using gpg --edit-key, instead of allowing me to enter a new password it asks for my old password
-as per arch linux wiki I revoked the key by generating and importing a revocation certificate
-generated a new keypair using gpg --full-gen-key
-tried to uninstall kdewallet but due to dependencies it won't let me
-rebooted for good measure to see if the password prompt, bad passphrase, or openpgp error messages would go away

I've been digging around forums for a while, any help?

Does the password of your KDE wallet match the user password (for logging in to the session)?

why yes it does. awful of me I know. reproduced the error messages, they are below


Try the refresh keyring tool in Garuda Assistant.

Then run garuda-update in the terminal and paste output in the thread.

Post your garuda-inxi please, apple again?


:joy: Is this a German expression? What is the meaning?

Check the Macbook Air posts :wink: