Odd bootup behaviour

Hi all, I am experiencing an odd thing when booting. I know it has to do with my hardware and this Distro/kernel...but I will get to that...

So I am running a machine with multiple systems and drives and I thought I would install Garuda on some free space I had. The others are Windows, Pop OS 20.10 and Fedora 33 if interested. What happens is that when Garuda begins to load it begins and then goes to sleep, I press the power button and it boots to the logon screen. I have found in the logs where it claims to have reached the sleep target and puts the machine to sleep but I am not seeing what the cause is. It did the same exact thing with the Live USB and after fully installed and updated. It also happens with both KDE and I3WM versions I have tried.

I know it has to do with the hardware I am running because I tried the same USB on a laptop i have and it booted straight up. Was wondering if anyone else has experienced the same sort of issue before I start dissecting my peripherals to figure if it is something there or what. Details below:
OS: Garuda Linux x86_64
Kernel: 5.10.12-116-tkg-bmq
CPU: AMD Ryzen 5 3600X 6- Processor (12) @ 3.8GHz
Memory: 3042MiB / 16010MiB (19%)

MB: Aorus x470 Ultra Gaming (I think BIOS is F50, was updated to support 3600)
GPU: EVGA 1660ti

We will need your full system specs. Please read the Garuda Wiki entry regarding reporting bugs.

Also be sure your bios is up to date.

Welcome to Garuda.

2 Likes

Check your BIOS PM settings. Change something (just for fun :stuck_out_tongue_winking_eye: ).

1 Like

The only reason I can think of this would be that for some reason the OS thinks your system is a laptop running on low power and so goes to sleep to save power... but I've also never heard of this happening before. :man_shrugging:

I might try linux or linux-zen to make sure it's not a kernel issue...

1 Like

Here is my machine info: PrivateBin

I will try a newer BIOS however I am not that much out of date, I do see an SMM vulnerability.

And here is the latest boot from journalctl. PrivateBin

I have upgraded the BIOS, since there was only 2 I did each and tested ... no difference.
I also tested using the Linux-LTS kernel and it behaved the same way.

BTW: I installed using garuda-dr460nized-linux-tkg-bmq-210107.iso and the equivalent I3wm ISO.
Other than the weird bootup it seems to be functioning perfectly fine OOB, I haven't done much in the way of customizing except for the visuals.

Any help is appreciated.

OK, so.

Feb 05 08:30:25 wkd-main systemd[1]: Reached target Sleep.
Feb 05 08:30:25 wkd-main systemd[1]: Starting Suspend...
Feb 05 08:30:25 wkd-main systemd-sleep[600]: Suspending system...
Feb 05 08:30:25 wkd-main kernel: PM: suspend entry (deep)
...
Feb 05 08:30:25 wkd-main kernel: Filesystems sync: 0.043 seconds
Feb 05 08:30:42 wkd-main kernel: Freezing user space processes ... 
...
Feb 05 08:30:42 wkd-main kernel: Freezing remaining freezable tasks ... 
...
Feb 05 08:30:42 wkd-main kernel: (elapsed 1.049 seconds) done.
Feb 05 08:30:42 wkd-main kernel: printk: Suspending console(s) (use no_console_suspend to debug)
Feb 05 08:30:42 wkd-main kernel: sd 2:0:0:0: [sdb] Synchronizing SCSI cache
Feb 05 08:30:42 wkd-main kernel: sd 2:0:0:0: [sdb] Stopping disk
Feb 05 08:30:42 wkd-main kernel: sd 0:0:0:0: [sda] Synchronizing SCSI cache
Feb 05 08:30:42 wkd-main kernel: sd 0:0:0:0: [sda] Stopping disk
Feb 05 08:30:42 wkd-main kernel: ACPI: Preparing to enter system sleep state S3
Feb 05 08:30:42 wkd-main kernel: PM: Saving platform NVS memory
Feb 05 08:30:42 wkd-main kernel: Disabling non-boot CPUs ...
Feb 05 08:30:42 wkd-main kernel: smpboot: CPU 1 is now offline
Feb 05 08:30:42 wkd-main kernel: smpboot: CPU 2 is now offline
Feb 05 08:30:42 wkd-main kernel: smpboot: CPU 3 is now offline
Feb 05 08:30:42 wkd-main kernel: smpboot: CPU 4 is now offline
Feb 05 08:30:42 wkd-main kernel: smpboot: CPU 5 is now offline
Feb 05 08:30:42 wkd-main kernel: smpboot: CPU 6 is now offline
Feb 05 08:30:42 wkd-main kernel: smpboot: CPU 7 is now offline
Feb 05 08:30:42 wkd-main kernel: smpboot: CPU 8 is now offline
Feb 05 08:30:42 wkd-main kernel: smpboot: CPU 9 is now offline
Feb 05 08:30:42 wkd-main kernel: smpboot: CPU 10 is now offline
Feb 05 08:30:42 wkd-main kernel: smpboot: CPU 11 is now offline
Feb 05 08:30:42 wkd-main kernel: ACPI: Low-level resume complete
Feb 05 08:30:42 wkd-main kernel: PM: Restoring platform NVS memory
Feb 05 08:30:42 wkd-main kernel: LVT offset 0 assigned for vector 0x400
Feb 05 08:30:42 wkd-main kernel: Enabling non-boot CPUs ...
...

This implies that for some reason you are hitting the systemd Sleep target during boot, and that is suspending the system.

The next question is, why?

1 Like

Perhaps this is not the best kernel boot parameter that you are using:

intel_pstate=passive

Maybe experiment with others.

2 Likes

Maybe check who wants sleep

grep -s sleep.target /usr/lib/systemd/system/*

Probably off-topic, but it seems your systemd-swap(?) mounts fedora a swap device during boot, which I believe is not wanted.
I assume it maybe fixed using a systemd-swap param.

swapd_auto_swapon=0
2 Likes

I did notice that Swap thing, just tackling things one at a time :wink:

How do I change the intel_pstate parameter, it does not appear to be as simple as tacking it on to the kernel parameters at boot.

It's for troubleshooting, so you have to do some effort.
But IMHO, intel_pstate states it's for Intel, when you have an AMD HW. Remove it in /etc/default/grub IMO.

About topic issue, either there is a weird edit/addition from the local Administrator in system settings, or a bug in provided settings, or an incompatibility of your HW. An odd suspicion might be some interference of one of your many installed OSes.

An idea might be there might be a false alarm about HW overheating and the system goes immediately to suspend, as configured PM settings. This initialized at the very early boot stage is more than rare and strange.

Post what I have requested, when you find time.

3 Likes

Is that what you wanted me to post? It wasn't clear that you wanted to see it...anyway here is the output:

╰─λ grep -s sleep.target /usr/lib/systemd/system/*
/usr/lib/systemd/system/autorandr.service:After=sleep.target
/usr/lib/systemd/system/autorandr.service:WantedBy=sleep.target
/usr/lib/systemd/system/systemd-hibernate.service:Requires=sleep.target
/usr/lib/systemd/system/systemd-hibernate.service:After=sleep.target
/usr/lib/systemd/system/systemd-hybrid-sleep.service:Requires=sleep.target
/usr/lib/systemd/system/systemd-hybrid-sleep.service:After=sleep.target
/usr/lib/systemd/system/systemd-suspend-then-hibernate.service:Requires=sleep.target
/usr/lib/systemd/system/systemd-suspend-then-hibernate.service:After=sleep.target
/usr/lib/systemd/system/systemd-suspend.service:Requires=sleep.target
/usr/lib/systemd/system/systemd-suspend.service:After=sleep.target 

Also the /etc/default/grub doesn't mention the intel_pstate setting, The only place I have been able to find it is the logs. I have tried setting it to disabled in the grub file and I just end up with two different settings on one line in the log. I agree and I would remove it if I could.

As for the PM settings I don't have anything other than screen blanking turned on for any of my systems, our Internet sucks so badly where I live that even a 1gb download can take more than 30min so anything larger I need my machines to stay on and not go to sleep mid stream.

Thank you for your help btw.. figuring out weird issues is how I have learned Linux over the years.

I think its due to your battery
Which has N/A

I have created an udev rule which will suspend the system if battery is below 5%

Probably i should delete it

3 Likes

Post

grep -i cmdline /etc/default/grub
cat /proc/cmdline

For suspend issue

systemctl status systemd-login
systemctl status thermald

Were you doing reboot, or cold boot?
Shutdown your PC, remove from power for 15 min and boot again (do this when you have time, but it's important check).

Also, fix the issue with fedora swap. Try my suggestion. Do swapoff the fedora swap partition (check /dev/??? name). Change the systemd-swap setting.

1 Like

OMG... So i did the 15 minute reset but something else came to mind when I read

Did a little digging and found a rule for monitoring logitech wireless device batteries, I remember that I have a dongle for my 3Dconnexion Spacemouse which on some distros (Pop) is recognized in their power monitoring system. So I removed the dongle, powered on (after being unplugged ) and voila, i can successfully boot... I have rebooted a couple of times and it does seem to have remediated the issue. Then after I logged on I plugged the dongle in and the machine instantly went to sleep. I woke it up and repeated the test and yup, machine goes to sleep instantly. Bizarre...

Still would like to know where that pstate setting is coming from...

Here are the outputs for the items above:
grep -i cmdline /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 splash"
GRUB_CMDLINE_LINUX=""

cat /proc/cmdline

intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq root=UUID=9c973da9-123d-4f78-a89a-dc27f5f983fe rw [email protected] rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 splash

systemctl status systemd-logind

● systemd-logind.service - User Login Management
     Loaded: loaded (/usr/lib/systemd/system/systemd-logind.service; static)
     Active: active (running) since Fri 2021-02-05 21:46:04 EST; 19min ago
       Docs: man:sd-login(3)
             man:systemd-logind.service(8)
             man:logind.conf(5)
             man:org.freedesktop.login1(5)
   Main PID: 567 (systemd-logind)
     Status: "Processing requests..."
      Tasks: 1 (limit: 19064)
     Memory: 3.4M
        CPU: 0
     CGroup: /system.slice/systemd-logind.service
             └─567 /usr/lib/systemd/systemd-logind

Feb 05 21:46:05 wkd-main systemd-logind[567]: Watching system buttons on /dev/input/event27 (Razer Razer Viper Mini)
Feb 05 21:46:05 wkd-main systemd-logind[567]: Watching system buttons on /dev/input/event19 (ZSA Technology Labs Inc ErgoDox EZ Glo>
Feb 05 21:46:05 wkd-main systemd-logind[567]: Watching system buttons on /dev/input/event23 (Razer Razer Viper Mini Keyboard)
Feb 05 21:46:05 wkd-main systemd-logind[567]: Watching system buttons on /dev/input/event17 (ZSA Technology Labs Inc ErgoDox EZ Glo>
Feb 05 21:46:07 wkd-main systemd-logind[567]: New session c1 of user sddm.
Feb 05 21:46:15 wkd-main systemd-logind[567]: New session 2 of user wayne.
Feb 05 21:46:15 wkd-main systemd-logind[567]: Session c1 logged out. Waiting for processes to exit.
Feb 05 21:46:15 wkd-main systemd-logind[567]: Removed session c1.
Feb 05 21:48:10 wkd-main systemd-logind[567]: Operation 'sleep' finished.
Feb 05 21:48:49 wkd-main systemd-logind[567]: Operation 'sleep' finished.

systemctl status thermald

● thermald.service - Thermal Daemon Service
     Loaded: loaded (/usr/lib/systemd/system/thermald.service; enabled; vendor preset: disabled)
     Active: inactive (dead) since Fri 2021-02-05 21:46:04 EST; 22min ago
   Main PID: 570 (code=exited, status=0/SUCCESS)
        CPU: 0

Feb 05 21:46:04 wkd-main systemd[1]: Starting Thermal Daemon Service...
Feb 05 21:46:04 wkd-main thermald[570]: NO RAPL sysfs present
Feb 05 21:46:04 wkd-main thermald[570]: Unsupported cpu model or platform
Feb 05 21:46:04 wkd-main systemd[1]: Started Thermal Daemon Service.
Feb 05 21:46:04 wkd-main systemd[1]: thermald.service: Succeeded.

Now here's an interesting bit, I pulled this from the log:

upowerd[2386]: treating change event as add on /sys/devices/pci0000:00/0000:00:01.3/0000:02:00.0/usb1/1-3

This usb device is identified as the Spacemouse and it appears to be kicking off the upowerd service.

I am heading in the right direction? And could this be one of the UDEV rules kicking the suspend?

4 Likes

deleted the udev rule

you can upgrade the system and tell me if the issue is fixed

4 Likes

Journal log

Feb 05 08:30:24 wkd-main kernel: Command line: BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq root=UUID=9c973da9-123d-4f78-a89a-dc27f5f983fe rw [email protected] rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 splash quiet

Feb 05 08:30:24 wkd-main kernel: Kernel command line: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq root=UUID=9c973da9-123d-4f78-a89a-dc27f5f983fe rw [email protected] rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 splash quiet

That's another first for the same day :face_with_head_bandage:

2 Likes

:partying_face: :+1: :crossed_fingers:

I think that says it all...cold boot with dongle works, restart with dongle works and removing and replacing it also works.

You guys a awesome, thanks.

BTW: I did fix up my swap system. Looks good, now I just want to decided whether to go to I3 or stay here on KDE. Initially I wanted to move to a tiling manager but these issues pushed me back to my comfort zone so I could be a little more efficient with known shortcuts etc.

hmmm...

3 Likes

And now that you pointed that out I am seeing those two command lines at the same time signature.