Odd behavior after freezing

First off I'm not entirely sure this is a problem, everything is functioning at this point, but I ran into an issue that I don't quite understand either the cause, or the 'right' fix.

I think I ran into the freezing issue yesterday, my machine didn't lock after being left alone for some amount of time. 45+ minutes, but I thought nothing of it. I locked the machine when I noticed it wasn't locked. I typically leave it running overnight, so I didn't power it down or anything. super + l to lock the screen and walked off (the screen locked like nothing was wrong). This morning I went to unlock it, and it didn't unlock, the mouse would move, but there was no other response. Keyboard input was ignored. (hard to know if anything else was happening since it was locked)

I forced a power off, and it rebooted normally, until the login screen. I use 3 monitors and only two of them showed the login screen, where I would normally have the login screen mirrored across all 3. I logged in and most of the kde settings were set to the default. Wallpaper, panels, and the like. No latte dock running.

My conkys were up and running, as was telegram, which are the only two auto-start apps I've got configured.

I figured something had gone wrong with the forced shutdown, so I rebooted and mounted a snapshot. which rebooted into the same exact state, missing a display at login, default kde stuff.

I restored the snapshot since I was already there, and I wasn't going to miss any data.

Ran an update which executed cleanly it seems, same monitor/default kde state after reboot.

I used Garuda settings to restore Latte, and I re-configured wallpapers, log out and back in, 2 monitors on login screen, but everything restored as far as user GUI settings. Including my color schemes which are not default kde or Garuda.

Each time I rebooted and logged in, as soon as I logged in my 3rd monitor shows up like it had been there all along.

At this point everything is functional. It doesn't seem that I lost any settings, or application data/configs. The only setting that seems to have been lost is the wifi password, and I'm not sure if that was because I came across that popup before the keyring login pop up or if it was actually lost.

It's just strange, and I'm not sure why it happened, or if there's anything I can do to prevent it.

I never tried a diffferent kernel, I use zen normally, and have LTS installed, but I did not try booting into LTS.

If anyone has any ideas as to what might have caused this, or how it might be prevented in the future I'd love to hear them,

inxi output:

inxi
inxi -Faz
System:    Kernel: 5.14.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=4338b47c-edf3-4f83-9738-74170e6fd4e0 rw  
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux  
base: Arch Linux  
Machine:   Type: Laptop System: LENOVO product: 20BUS29100 v: ThinkPad T450 serial: <filter> Chassis: type: 10  
serial: <filter>  
Mobo: LENOVO model: 20BUS29100 v: SDK0E50510 WIN serial: <filter> UEFI-[Legacy]: LENOVO v: JBET51WW (1.16 )  
date: 07/08/2015  
Battery:   ID-1: BAT0 charge: 16.9 Wh (100.0%) condition: 16.9/23.2 Wh (72.6%) volts: 12.1 min: 11.1 model: SONY 45N1111  
type: Li-poly serial: <filter> status: Full  
ID-2: BAT1 charge: 13.2 Wh (100.0%) condition: 13.2/23.5 Wh (56.2%) volts: 12.6 min: 11.4 model: LGC 45N1127  
type: Li-ion serial: <filter> status: Full  
Device-1: hidpp_battery_0 model: Logitech M570 serial: <filter> charge: 60% rechargeable: yes status: Discharging  
CPU:       Info: Dual Core model: Intel Core i5-5300U bits: 64 type: MT MCP arch: Broadwell family: 6 model-id: 3D (61)  
stepping: 4 microcode: 2F cache: L2: 3 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18359  
Speed: 2678 MHz min/max: 500/2900 MHz Core speeds (MHz): 1: 2678 2: 2304 3: 2420 4: 2295  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable  
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:1616  
class-ID: 0300  
Device-2: Sunplus Innovation Full HD webcam type: USB driver: snd-usb-audio,uvcvideo bus-ID: 2-3.4.3:11  
chip-ID: 1bcf:2283 class-ID: 0102 serial: <filter>  
Device-3: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 2-8:9 chip-ID: 5986:0366 class-ID: 0e02  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 5760x1200 s-dpi: 96 s-size: 1520x316mm (59.8x12.4") s-diag: 1552mm (61.1")
Monitor-1: DP2-1 res: 1920x1080 hz: 60 dpi: 70 size: 700x390mm (27.6x15.4") diag: 801mm (31.5")
Monitor-2: DP2-2 res: 1920x1200 hz: 60 dpi: 94 size: 520x320mm (20.5x12.6") diag: 611mm (24")
Monitor-3: DP2-3 res: 1920x1200 hz: 60 dpi: 94 size: 520x320mm (20.5x12.6") diag: 611mm (24")
OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 21.2.2 direct render: Yes
Audio:     Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c
class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403
Device-3: Kingston HyperX Cloud Stinger Wireless type: USB driver: hid-generic,snd-usb-audio,usbhid
bus-ID: 2-3.1.1:8 chip-ID: 0951:16da class-ID: 0300
Device-4: Sunplus Innovation Full HD webcam type: USB driver: snd-usb-audio,uvcvideo bus-ID: 2-3.4.3:11
chip-ID: 1bcf:2283 class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.14.8-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.37 running: yes
Network:   Device-1: Intel Ethernet I218-LM vendor: Lenovo driver: e1000e v: kernel port: 3080 bus-ID: 00:19.0
chip-ID: 8086:15a2 class-ID: 0200
IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel port: efa0 bus-ID: 03:00.0 chip-ID: 8086:08b1
class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 2-7:6 chip-ID: 8087:07dc
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 953.87 GiB used: 71.8 GiB (7.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDH3 1T02 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1000 scheme: MBR
Partition: ID-1: / raw-size: 452.86 GiB size: 452.86 GiB (100.00%) used: 71.8 GiB (15.9%) fs: btrfs dev: /dev/sda3
maj-min: 8:3
ID-2: /home raw-size: 452.86 GiB size: 452.86 GiB (100.00%) used: 71.8 GiB (15.9%) fs: btrfs dev: /dev/sda3
maj-min: 8:3
ID-3: /var/log raw-size: 452.86 GiB size: 452.86 GiB (100.00%) used: 71.8 GiB (15.9%) fs: btrfs dev: /dev/sda3
maj-min: 8:3
ID-4: /var/tmp raw-size: 452.86 GiB size: 452.86 GiB (100.00%) used: 71.8 GiB (15.9%) fs: btrfs dev: /dev/sda3
maj-min: 8:3
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.33 GiB used: 4 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A
Fan Speeds (RPM): fan-1: 0
Info:      Processes: 291 Uptime: 1h 17m wakeups: 4 Memory: 15.33 GiB used: 7.19 GiB (46.9%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1510 pacman: 1504 lib: 343 flatpak: 6 Shell: Zsh
v: 5.8 running-in: tmux: inxi: 3.3.06

Pacman Log from last update before issue:

Pacman logs
[2021-09-29T00:00:48-0400] [PACMAN] Running '/usr/bin/pacman -Fy'
[2021-09-29T00:00:48-0400] [PACMAN] synchronizing package lists
[2021-09-29T07:56:06-0400] [PACKAGEKIT] synchronizing package lists
[2021-09-29T09:52:12-0400] [PACMAN] Running 'pacman -Sy --needed archlinux-keyring chaotic-keyring'
[2021-09-29T09:52:12-0400] [PACMAN] synchronizing package lists
[2021-09-29T09:52:13-0400] [PACMAN] Running 'pacman --sync -u --'
[2021-09-29T09:52:13-0400] [PACMAN] starting full system upgrade
[2021-09-29T09:56:27-0400] [ALPM] running '00-timeshift-autosnap.hook'...
[2021-09-29T09:56:27-0400] [ALPM-SCRIPTLET] First run mode (config file not found)
[2021-09-29T09:56:27-0400] [ALPM-SCRIPTLET] Selected default snapshot type: BTRFS
[2021-09-29T09:56:27-0400] [ALPM-SCRIPTLET] Using system disk as snapshot device for creating snapshots in BTRFS mode
[2021-09-29T09:56:27-0400] [ALPM-SCRIPTLET] 
[2021-09-29T09:56:27-0400] [ALPM-SCRIPTLET] /dev/sda3 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,subvolid=5,subvol=/
[2021-09-29T09:56:27-0400] [ALPM-SCRIPTLET] 
[2021-09-29T09:56:27-0400] [ALPM-SCRIPTLET] Creating new backup...(BTRFS)
[2021-09-29T09:56:27-0400] [ALPM-SCRIPTLET] Saving to device: /dev/sda3, mounted at path: /run/timeshift/backup
[2021-09-29T09:56:27-0400] [ALPM-SCRIPTLET] Created directory: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-09-29_09-56-27
[2021-09-29T09:56:28-0400] [ALPM-SCRIPTLET] Created subvolume snapshot: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-09-29_09-56-27/@
[2021-09-29T09:56:28-0400] [ALPM-SCRIPTLET] Created control file: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-09-29_09-56-27/info.json
[2021-09-29T09:56:28-0400] [ALPM-SCRIPTLET] BTRFS Snapshot saved successfully (0s)
[2021-09-29T09:56:28-0400] [ALPM-SCRIPTLET] Tagged snapshot '2021-09-29_09-56-27': ondemand
[2021-09-29T09:56:28-0400] [ALPM-SCRIPTLET] ------------------------------------------------------------------------------
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] First run mode (config file not found)
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] Selected default snapshot type: BTRFS
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] 
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] /dev/sda3 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,subvolid=5,subvol=/
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] 
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] Selected default snapshot device: /dev/sda3
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] ------------------------------------------------------------------------------
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] Removing snapshot: 2021-09-25_14-08-35
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] Deleting subvolume: @ (Id:332)
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] Deleted subvolume: @ (Id:332)
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] 
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] Destroying qgroup: 0/332
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] Destroyed qgroup: 0/332
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] 
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] Deleted directory: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-09-25_14-08-35
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] Removed snapshot: 2021-09-25_14-08-35
[2021-09-29T09:56:29-0400] [ALPM-SCRIPTLET] ------------------------------------------------------------------------------
[2021-09-29T09:56:29-0400] [ALPM] transaction started
[2021-09-29T09:56:31-0400] [ALPM] upgraded code (1.58.0-1 -> 1.60.2-1)
[2021-09-29T09:56:32-0400] [ALPM] upgraded electron12 (12.1.2-1 -> 12.2.0-1)
[2021-09-29T09:56:32-0400] [ALPM] upgraded qt5-wayland (5.15.2+kde+r31-1 -> 5.15.2+kde+r33-1)
[2021-09-29T09:56:32-0400] [ALPM] upgraded kalendar-git (r249.d0b610b-1 -> r252.0b3e512-1)
[2021-09-29T09:56:33-0400] [ALPM] upgraded libraqm (0.7.2-1 -> 0.7.2-2)
[2021-09-29T09:56:34-0400] [ALPM] upgraded vivaldi (4.2.2406.48-1 -> 4.2.2406.52-1)
[2021-09-29T09:56:35-0400] [ALPM] transaction completed
[2021-09-29T09:56:35-0400] [ALPM] running '30-systemd-update.hook'...
[2021-09-29T09:56:35-0400] [ALPM] running '90-packagekit-refresh.hook'...
[2021-09-29T09:56:35-0400] [ALPM] running 'foreign.hook'...
[2021-09-29T09:56:36-0400] [ALPM-SCRIPTLET] => No foreign/AUR packages found.
[2021-09-29T09:56:36-0400] [ALPM] running 'gtk-update-icon-cache.hook'...
[2021-09-29T09:56:36-0400] [ALPM] running 'orphans.hook'...
[2021-09-29T09:56:36-0400] [ALPM-SCRIPTLET] electron12 12.2.0-1
[2021-09-29T09:56:36-0400] [ALPM-SCRIPTLET] kinit 5.86.0-1
[2021-09-29T09:56:36-0400] [ALPM-SCRIPTLET] wayland-protocols 1.23-1
[2021-09-29T09:56:36-0400] [ALPM] running 'pacnew-check.hook'...
[2021-09-29T09:56:36-0400] [ALPM-SCRIPTLET] .pac* files found:
[2021-09-29T09:56:36-0400] [ALPM-SCRIPTLET] /etc/default/grub-btrfs/config.pacnew
[2021-09-29T09:56:36-0400] [ALPM-SCRIPTLET] Please check and merge
[2021-09-29T09:56:36-0400] [ALPM] running 'pkgfile.hook'...
[2021-09-29T09:56:36-0400] [ALPM] running 'rebuild-detector.hook'...
[2021-09-29T09:56:40-0400] [ALPM] running 'update-desktop-database.hook'...
[2021-09-29T09:56:41-0400] [ALPM] running 'zzz_pacman-sync.hook'...
[2021-09-29T09:56:44-0400] [PACMAN] Running 'pacman -Fy'
[2021-09-29T09:56:44-0400] [PACMAN] synchronizing package lists

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.