OBS & Spectavle broken after update

Hello.

I have been having some problems with obs and spectacle after an recent update.

Basically I didn't update for myb a week or two out of fear my davci would break again.
But when I did update I instantly noticed that i could no longer take screenshots with spectacle.
I didn't think to much of it at the time and i just went on with the day thinking I just needed to reboot to fix it (Not the first time it has happened so I was not worried about it).
But the next day it still didn't work so I got worried. But at the time I was busy and could go without that for a while.
Then a couple of days later I noticed that my obs didn't run as well.
I ran them both from the thermal and both gave a similar output

obs: error while loading shared libraries: libmbedtls.so.14: cannot open shared object file: No such file or directory

After a bit of Googling and asking a friend I fount that i just needed to link them.
So I used ln -s to think them and that seamed to work (and fixed Intelij).
But now obs and spectacle give this output.

obs: symbol lookup error: /usr/lib/librist.so.4: undefined symbol: mbedtls_sha512_update_ret

And when I run

ldd -r  /usr/lib/librist.so.4.2.0

It gives me this output:

linux-vdso.so.1 (0x00007ffeb11be000)
libmbedcrypto.so.7 => /usr/lib/libmbedcrypto.so.7 (0x00007f6549dd7000)
libcjson.so.1 => /usr/lib/libcjson.so.1 (0x00007f6549dcd000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007f6549be3000)
/usr/lib64/ld-linux-x86-64.so.2 (0x00007f6549ec6000)
undefined symbol: mbedtls_sha512_update_ret     (/usr/lib/librist.so.4.2.0)
undefined symbol: mbedtls_sha256_ret    (/usr/lib/librist.so.4.2.0)
undefined symbol: mbedtls_sha512_finish_ret     (/usr/lib/librist.so.4.2.0)
undefined symbol: mbedtls_sha256_update_ret     (/usr/lib/librist.so.4.2.0)
undefined symbol: mbedtls_sha512_ret    (/usr/lib/librist.so.4.2.0)
undefined symbol: mbedtls_sha1_ret      (/usr/lib/librist.so.4.2.0)
undefined symbol: mbedtls_sha1_update_ret       (/usr/lib/librist.so.4.2.0)
undefined symbol: mbedtls_sha256_finish_ret     (/usr/lib/librist.so.4.2.0)
undefined symbol: mbedtls_sha1_finish_ret       (/usr/lib/librist.so.4.2.0)

And I don't know where to go from here. I have googled for hour and I just don't know what to do.
I have reinstalled obs, spectacle and mbedtls multiple times.
I have spent all day trying to find a solution and I just want to use obs.

garuda-inxi

System:
Kernel: 6.3.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e70d2e6c-dd91-4665-af8f-016c0da9d441 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=4080c07a-6e2b-4f79-9829-6a4d106db96f loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: G7 7588 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 0FDMYT v: A00 serial: <superuser required> UEFI: Dell
v: 1.11.1 date: 07/15/2019
Battery:
ID-1: BAT0 charge: 18.4 Wh (100.0%) condition: 18.4/56.0 Wh (32.9%)
volts: 16.6 min: 15.2 model: Samsung SDI DELL W7NKD87 type: Li-ion
serial: <filter> status: full
CPU:
Info: model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF2
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 9 MiB desc: 1x9 MiB
Speed (MHz): avg: 3399 high: 4001 min/max: 800/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 4001 2: 2200 3: 4000
4: 4000 5: 2200 6: 4000 7: 3994 8: 2200 9: 4000 10: 4000 11: 2200 12: 4000
bogomips: 52799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3
bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Dell
driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1c20
class-ID: 0300
Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:4 chip-ID: 0c45:6a08
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 3200x1080 s-dpi: 96 s-size: 844x285mm (33.23x11.22")
s-diag: 891mm (35.07")
Monitor-1: HDMI-1-0 pos: right res: 1280x768 hz: 60 dpi: 46
size: 708x398mm (27.87x15.67") diag: 812mm (31.98") modes: N/A
Monitor-2: eDP-1 pos: primary,left res: 1920x1080 dpi: 142
size: 344x194mm (13.54x7.64") diag: 395mm (15.55") modes: N/A
API: OpenGL v: 4.6 Mesa 23.1.2 renderer: Mesa Intel UHD Graphics 630 (CFL
GT2) direct-render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
API: ALSA v: k6.3.7-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Dell
driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
bus-ID: 3b:00.0 chip-ID: 1969:e0a1 class-ID: 0200
IF: enp59s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:5
chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 5060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:
Local Storage: total: 1.03 TiB used: 969.5 GiB (92.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: SDM3 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Intel model: SSDSCKKF128G8 SATA 128GB
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: D04N scheme: GPT
Partition:
ID-1: / raw-size: 102.08 GiB size: 102.08 GiB (100.00%)
used: 76.98 GiB (75.4%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 588 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 102.08 GiB size: 102.08 GiB (100.00%)
used: 76.98 GiB (75.4%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 102.08 GiB size: 102.08 GiB (100.00%)
used: 76.98 GiB (75.4%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 102.08 GiB size: 102.08 GiB (100.00%)
used: 76.98 GiB (75.4%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.33 GiB used: 61 MiB (0.4%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.86 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb3 maj-min: 8:19
Sensors:
System Temperatures: cpu: 56.0 C pch: 51.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 302 Uptime: 21m wakeups: 2 Memory: available: 15.33 GiB
used: 5.23 GiB (34.1%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman
pkgs: 1657 libs: 479 tools: octopi,paru,yay Shell: fish v: 3.6.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2022-11-23
Last full system update: 2023-06-11
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

I don't often ask for help so if I did something wrong or didn't add some log please tell me.

I don't know if the following can help you, but I would recommend removing all the symlinks made between sonames (it can be dangerous, and is explicitly discouraged in the Arch wiki), maybe even restore a previous snapshot if you are not sure of the symlinks created.
After that, I would try re-installing the problematic packages.
I see that mbedtls 3.4.0-3 provides libmbedtls.so.19 and obs-studio 29.1.1-2, which depends on mbedtls, uses just that version, so the whole thing should stand.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.