NVIDIA freezes randomly

Please always provide the output of your garuda-inxi when opening a new topic, as text, formatted with a
~~~
before and after., as instructed by the template.
Regarding your problem, you might consider reading this guide:

3 Likes
System:
  Kernel: 5.17.5-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=8736464e-32e6-464b-aa69-5aa97de64cf4 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=4425a162-e3ad-42f1-bc0d-aa3b380435b8 loglevel=3
  Desktop: Cinnamon v: 5.2.7 tk: GTK v: 3.24.33 wm: Muffin dm: LightDM
    v: 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec2xxx v: N/A
    serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: HP model: 88DE v: 96.31 serial: <filter> UEFI: AMI v: F.15
    date: 08/18/2021
Battery:
  ID-1: BAT0 charge: 50.3 Wh (100.0%) condition: 50.3/50.3 Wh (100.0%)
    volts: 12.8 min: 11.6 model: HP Primary type: Li-ion serial: <filter>
    status: N/A
CPU:
  Info: model: AMD Ryzen 5 5600H with Radeon Graphics socket: FP6 bits: 64
    type: MT MCP arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1550 high: 3300 min/max: 1200/4280 boost: enabled
    base/boost: 3300/4250 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 3300 2: 1200 3: 1200 4: 1200
    5: 3300 6: 1200 7: 1200 8: 1200 9: 1200 10: 1200 11: 1200 12: 1200
    bogomips: 79050
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Hewlett-Packard
    driver: nvidia v: 510.68.02 alternate: nouveau,nvidia_drm pcie: gen: 1
    speed: 2.5 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: none empty: HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:25a2
    class-ID: 0300
  Device-2: AMD Cezanne vendor: Hewlett-Packard driver: amdgpu v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: none bus-ID: 05:00.0 chip-ID: 1002:1638
    class-ID: 0300
  Device-3: Luxvisions Innotech HP TrueVision HD Camera type: USB
    driver: uvcvideo bus-ID: 3-3:2 chip-ID: 30c9:0035 class-ID: fe01
    serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 driver: X:
    loaded: modesetting,nvidia gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
    s-diag: 583mm (22.95")
  Monitor-1: eDP-1 mapped: eDP-1-1 model: AU Optronics 0x2992 built: 2020
    res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: NVIDIA GeForce RTX 3050 Laptop GPU/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.68.02 direct render: Yes
Audio:
  Device-1: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:2291 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x,
    snd_pci_acp6x, snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 05:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.17.5-zen1-2-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw89_pci v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8852
    class-ID: 0280
  IF: wlo1 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 0bda:2852 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 45.01 GiB (9.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron
    model: MTFDHBA512TDV-1AZ1AABHA size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: HPS0032 temp: 49.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 60 GiB size: 60 GiB (100.00%) used: 21.13 GiB (35.2%)
    fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: /boot/efi raw-size: 615 MiB size: 613.8 MiB (99.80%)
    used: 576 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p8
    maj-min: 259:8
  ID-3: /home raw-size: 95.4 GiB size: 95.4 GiB (100.00%)
    used: 23.88 GiB (25.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
    maj-min: 259:7
  ID-4: /var/log raw-size: 60 GiB size: 60 GiB (100.00%)
    used: 21.13 GiB (35.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6
  ID-5: /var/tmp raw-size: 60 GiB size: 60 GiB (100.00%)
    used: 21.13 GiB (35.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p10 maj-min: 259:10
  ID-2: swap-2 type: zram size: 7.18 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 66.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0 fan-2: 0
  GPU: device: nvidia screen: :0.0 temp: 51 C device: amdgpu temp: 51.0 C
Info:
  Processes: 375 Uptime: 1m wakeups: 1 Memory: 7.18 GiB
  used: 2.09 GiB (29.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 Packages: pacman: 1368 lib: 320 Shell: garuda-inxi (sudo)
  default: fish v: 3.4.1 running-in: gnome-terminal inxi: 3.3.15
Garuda (2.6.2-1):
  System install date:     2022-05-08
  Last full system update: 2022-05-11
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Yes
  Snapshots:               Snapper
  Failed units:            

Can you suggest me common possible solution?

Try with filo's guide (created by tbg) above and see if it yields you somewhere. They are the first troubleshooting steps.

5 Likes

Your mistake here is switching to nvidia. Just keep it on hybrid and run the programs you need to use the GPU with prime-run. That's NVIDIA's official method. Don't mess around with tools like optimus-manager that try to do all kinds of wacky things to get stuff to work. This method also helps with battery life because it will turn off the GPU when not in use.

5 Likes

It doesn't give any better performance. If I run any browser with prime-run then it doesn't support hardware acceleration. But if NVIDIA is set to primary gpu, hardware acceleration is available and working with 10x performance for any apps.

That's why if I can set NVIDIA to primary GPU, it gives 10x performance.

Enabling this^^^ is known to cause freezing on some systems.

From the FAQ @filo already provided the link for you to read:

3 Likes

Tried after so many trials. Changing kernel, I/O schedulers, kernel parameters didn't work. Also no performance tweaks are enabled. But one things helped a little.

Adding kernel parameter nvidia drm modeset as 1 in GRUB file made it freeze display accept cursor. At first, whole display was freezed randomly after using sometime. Now, cursor is not freezed at least.

So can you please suggest some similar ways which can make whole display unfreeze?

Let me explain a little more...

You have a Laptop.
A PC/Laptop can function with one GPU.
Your Laptop vendor, like other vendors, added an additional GPU.
Why do you think they would want that? If nvidia is powerful, they could just ship only nvidia.

Laptop vendors add a 2nd GPU and they use one for low demand usage and the other one for high demand applications. This helps conserve battery power!!!!!!!

If you want to use the ONLY power hungry nvidia GPU, first look into the BIOS and see for such a setting.
Making nvidia Primary GPU, does not make sense. Ask your vendor to explain more, if my English is not good (BTW I am Greek :smile: ).
Optimus-manager advertises that can do the same thing (use nvidia only mode), but it uses advanced software technics, that, because there are countless HW/SW combinations, sometimes don't function as expected.

If you think optimus-manager maybe your solution, then I would suggest you ask their developers for support on your issue. We know a lot, but they are the creators and they will know ASAP what happens.

OTOH

this doesn't make sense. At least, if everything is configured well. Archwiki describes very well the way to setup and confirm hardware acceleration.

You have to try more..., or run Mint, Ubuntu, Fedora or WinOS. I hear they have a lot of success with Optimus Laptops.

5 Likes

Other distros doesn't provide what Garuda Linux provides. And before Garuda, I tried them all. Ubuntu also freezes like that in Garuda. Similar for Debian based distros. Fedora is not even booting up with NVIDIA drivers. Only option was Arch or Arch based distros. And I had 2 options : Garuda Linux and Manjaro. Manjaro has modified Arch to very much extent and it causes issues. And Garuda is just great and simple to use with all features anyone can imagine.

I tried by my side everything I could. Can you please suggest some way I can do so or it's just problem at NVIDIA side only?

@yash everyone else in this thread has a more detailed and informative response than you, and it's your thread. Why is that?

It's impossible to identify things that could use modification in your setup if you don't describe the changes you have been trying and what the results have been. This:

That's so unhelpful. There is basically no information here. No one knows what you tried. No one can tell what has helped or what has made things worse. Frankly you haven't even bothered to describe the problem very well.

So far the most detail you've put forward is you tried some random kernel parameter and something changed--but it's still broken. If I'm expressing that wrongly it's because I don't have a lot of information to base my synapses on.

Go through these links, take notes, describe what you've tried and what happens. Put some details into the thread, instead of just asking someone to come up with a magic snippet of code you can paste into your grub configuration without actually doing any work.

5 Likes

I tried kernel parameter nvidia-drm.modeset=1 but it didn't work. But I got to know that maybe Bumblebee would work in my case. But while starting bumblebee service it is not being started:

systemctl status bumblebeed.service

● bumblebeed.service - Bumblebee C Daemon
Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
Active: activating (auto-restart) (Result: exit-code) since Tue 2022-05-17 21:41:35 IST; 12s ago
Process: 6801 ExecStart=/usr/bin/bumblebeed (code=exited, status=1/FAILURE)
Main PID: 6801 (code=exited, status=1/FAILURE)
CPU: 1ms

i followed Archwiki Bumblebee guideline but I am unable to start the service

Which NVIDIA driver is needed for bumblebee? In garuda-settings-manager, there are three options : video-optimus-manager, video-nvidia-prime-render-offload and video-nvidia-dkms

Which one to install? At first MHWD automatically installed optimus driver but I need to use bumblebee so how can I make it work? Can you please help me? I followed Archwiki and also searched for it but didn't get any solution.

I don't know much about these aspects but I think I can give you some general, "approach" advices.
Are you sure you are taking the right path?
I see you're looking for a path on your own... but details are missing, without which I don't think anyone can help you.

Details missing

Are you really sure? Sources? Rarely I've seen Bumblebee suggested here (this could be a case, of course!).

That service status is not enough in my opinion, I hope there are logs, journal etc.

I see it's a long guide (with also a lot of troubleshootings). Are you 100% you followed everything and correctly? For sure, providing some details would help, but here I understand it is hard. Maybe if someone confirms this is the right way to go...

The Arch Wiki says

An appropriate version of the NVIDIA driver, see NVIDIA#Installation.

You should have the drivers installed according to the garuda-inxi. That's why I'm thinking there might be something else missing.
To make it simple, I would say video-nvidia-dkms, but as I said at the beginning these were only supposed to be general advices for the future.

2 Likes

Yes you are right. Actually it works well with drivers installed by mhwd after installation of Garuda but I don't know why it happens. The optimus manager works fine with hybrid and integrated mode but when it is set to nvidia, then also it works fine for a few minutes of use with any percentage or GPU utilization or load but after sometime the screen starts freezing, then again after a few seconds it is fine and the cycle of freezing continues. So I am a little confused what to do in this case. Above suggested troubleshooting steps are not helping in this case. It might be the issue from NVIDIA side because I saw some other users of different linux distros having same problem like me with NVIDIA RTX 3050. And one user has it working fine by bumblebee method.

And we are 100% sure here in this thread that this freeze is caused by GPU?

Problem is only there when switched to NVIDIA otherwise no problem is there.

You have been asked to provide some actual information, and as yet you have provided next to none.

Start providing full information on your issue or this thread may be shut down. The information we need was already linked several times here already.

This is from the FAQ Tutorial already linked several times (proceed to providing the information requested):



Feedback you should provide:



There are numerous threads on the forum dealing with freezing issues with many different suggestions posted on how to hopefully correct the issue. Please search the forum and report in detail on every fix you attempt and post relevant logs and command outputs. To troubleshoot any issue effectively forum assistants must know all the troubleshooting steps that have been tested to have any chance of finding a solution. Threads already covering this topic on the forum should provide plenty of information on the steps you need to take to troubleshoot this issue.

If a thorough search of the Garuda forum doesn't turn up a solution, then searching other Arch based forums is usually the next step. If you can't turn up what you need on the Arch derivative distro foras then throw a wider net with an internet wide search.



Freezing Questionnaire/Checklist:



Have you posted the output of the garuda-inxi command?


Have you provided a full history of fixes attempted?


Have you checked for errors/segfaults/crash dumps, and posted your logs?


Have you given at least 3 alternate kernels a test out? which ones?


Have you fully updated your system?


Is your BIOS up to date?


Have you checked your resource usage with htop, iotop, etc?


Are you getting close to maxing out your ram at any time?


Have you checked your system temperatures?


Did this issue start recently after an update?


If this started recently, have you tried performing a rollback via a snapshot?


Can you recall making any config changes about when this issue began?


Have you tried disabling the baloo file indexer temporarily?


Have you tried disabling all network adapters temporarily?


Have you tried disabling hardware acceleration in your browser?


Have you tried disabling BTRFS Quotas (qgroups)?


Have you run a BTRFS balancing operation?


If you press the CAPS or NUMLOCK key, does your KB state light change?


Is your CAPS or NUMLOCK LED blinking? (kernel panic indicator)


Can you move your mouse cursor?


Can you move your mouse cursor, but clicking has no effect?


Do you have full keyboard functionality?


Is this a complete freeze up with no keyboard or mouse responsiveness?


Does pressing CTRL+T open a terminal?


Does pressing CTRL+ALT+F2 get you to a TTY?


Have you tried restarting your system from the terminal or TTY?


Have you tried to remote in from another computer via ssh?


Have you tried to ping your machine from another computer?


Can you use the Magic SysRq key to restart/shutdown?


Have you tried restarting (KDE) plasmashell or kwin from the terminal?


Is there a specific program or action that often triggers a freeze?


How many applications are generally running when the freezing occurs?


Are the freezes completely random?


Is their any pattern to the freezes?


How often do the freezes usually occur?


How long have these freezes been happening on this install?


Do the freezes seem to be getting more frequent over time?


What is your longest time without a freeze?


Do freezes only happen while doing something CPU intensive?


Do the freezes happen even if the system is completely idle?


If a freeze does occur, does it resolve on its own if you wait a long time?


Have you tried both the proprietary and free Nvidia drivers, (if present)?


Have you tried changing your compositor settings?


Have you tried disabling your compositor entirely?


Have you followed all the steps in the hardware troubleshooting tutorial?


Have you followed all the steps in the software troubleshooting tutorial?


Have you tried removing all plasma widgets (plasmoids) you've installed?


Have you tried removing all Gnome extensions you've installed?


Have you used Garuda Assistant to reset your default config?


Have you tried Installing linux-firmware-git , and rebooting?


Have you made any overclocking/undervolting or similar modifications?


Do you use full disk encryption?


Do you use a swap partition?


Have you installed multiple Desktop Environments or WM's together?


Are you running Garuda in a Virtual Machine?


Do you have only 4GB of RAM (or less) with shared video?


Does your electrical grid experience power fluctuations?


Is your home wiring very old, do your lights flicker?


Have you installed any extra apps (which) from the AUR/Chaotic repos?


Have you fully updated all apps from the AUR/Chaotic repos?


Have you experienced similar issues with this hardware on other OS's?


Did, (or does) freezing also occur on Windows?


Did, (or does) freezing also occur on other Linux distros?


Have you booted live disks of other Garuda DE's or other distros?


Does freezing also occur in live environments, (which ones)?


Does freezing also occur if you create a new user account?


Does the system get progressively slower before freezing?


Has your computer ever shut off on its own, without you initiating ?


Does sound continue playing, or loop during a freeze?


Are you using tlp ? if so, disable or uninstall it temporarily.


If your computer has a disk activity LED, is it blinking during the freeze?


Please answer as many of the above questions as possible. We need to have a complete picture in order to help resolve your issue. You can copy the above list of questions in its entirety into any help request you open on this subject. Below each question provide an answer as best you can to each question on the checklist of queries.



6 Likes

Thanks for such a detailed help @tbg.

System:
  Kernel: 5.17.7-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=8736464e-32e6-464b-aa69-5aa97de64cf4 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=4425a162-e3ad-42f1-bc0d-aa3b380435b8 loglevel=3
    nvidia-drm.modeset=1
  Desktop: Cinnamon v: 5.2.7 tk: GTK v: 3.24.33 wm: muffin vt: 7
    dm: LightDM v: 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec2xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 88DE v: 96.31 serial: <superuser required> UEFI: AMI
    v: F.15 date: 08/18/2021
Battery:
  ID-1: BAT0 charge: 48.0 Wh (95.2%) condition: 50.4/50.4 Wh (100.0%)
    volts: 13.0 min: 11.6 model: HP Primary type: Li-ion serial: <filter>
    status: charging
CPU:
  Info: model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 2446 high: 3416 min/max: 1200/4280 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2395 2: 2621
    3: 3341 4: 3416 5: 2912 6: 2398 7: 1991 8: 2166 9: 2135 10: 1916 11: 2081
    12: 1983 bogomips: 79052
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Hewlett-Packard
    driver: nvidia v: 515.43.04 alternate: nouveau,nvidia_drm pcie: gen: 1
    speed: 2.5 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: none empty: HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:25a2
    class-ID: 0300
  Device-2: AMD Cezanne vendor: Hewlett-Packard driver: amdgpu v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: none bus-ID: 05:00.0 chip-ID: 1002:1638
    class-ID: 0300
  Device-3: Luxvisions Innotech HP TrueVision HD Camera type: USB
    driver: uvcvideo bus-ID: 3-3:2 chip-ID: 30c9:0035 class-ID: fe01
    serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 driver: X:
    loaded: modesetting,nvidia gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x2992 built: 2020 res: 1920x1080
    hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.44 5.17.7-zen1-2-zen)
    v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
  Device-1: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:2291 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x,
    snd_pci_acp6x, snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 05:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.17.7-zen1-2-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw89_pci v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8852
    class-ID: 0280
  IF: wlo1 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 0bda:2852 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 1 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 52.81 GiB (11.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron
    model: MTFDHBA512TDV-1AZ1AABHA size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: HPS0032 temp: 41.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 60 GiB size: 60 GiB (100.00%) used: 22.68 GiB (37.8%)
    fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: /boot/efi raw-size: 615 MiB size: 613.8 MiB (99.80%)
    used: 580 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-3: /home raw-size: 95.4 GiB size: 95.4 GiB (100.00%)
    used: 30.13 GiB (31.6%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
  ID-4: /var/log raw-size: 60 GiB size: 60 GiB (100.00%)
    used: 22.68 GiB (37.8%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-5: /var/tmp raw-size: 60 GiB size: 60 GiB (100.00%)
    used: 22.68 GiB (37.8%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p10 maj-min: 259:10
  ID-2: swap-2 type: zram size: 7.18 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 59.0 C mobo: N/A gpu: amdgpu temp: 46.0 C
  Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:
  Processes: 397 Uptime: 16m wakeups: 1 Memory: 7.18 GiB
  used: 2.77 GiB (38.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 Packages: pacman: 1379 lib: 323 Shell: fish v: 3.4.1
  running-in: gnome-terminal inxi: 3.3.15
Garuda (2.6.3-2):
  System install date:     2022-05-08
  Last full system update: 2022-05-18
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            

Kernels I tested : zen, arch stock, lts.

Yes

Yes

Yes. With htop, it is okay all the time. Using about 50 to 60% of 8GB RAM while 2 to 3 apps opened like browser, vscode, etc.

Never till now. Using Linux since 7 to 8 months and Garuda since 6 to 7 months. My RAM never reached that much close.

Normally, it's about 40 to 47 degree C. It never becomes too hot. Never went above 65 till now.

No, actually it's there since I started to use Linux. Like most people, I started with Ubuntu. Then freezing due to NVIDIA occured in it. I tried most of popular distros. Most freezes with NVIDIA drivers and NVIDIA set as primary gpu while others not even boot with proprietary drivers like Fedora. Then I switched to Garuda. First with GNOME so everything was fine with prime-run command but then I came to know in Cinnamon that NVIDIA can be set as primary gpu. Then it became a problem that whenever I set it to primary, it freezes after sometime randomly and unfreezes randomly with and without even any load or high temperature.

Yes, I did so and also reinstalled the whole OS.

Nothing

Yes. I have only one so I also tried with adapter off.

Yes. Screen freezes even when not using any browser or any graphics app.

Yes

Yes

Yes. It's normal

No

No

Yes

Yes

No

Yes. Freezing does to GUI only

Yes, so many times.

No

No

No

Any number of apps are running, it occurs. 0 or 1 or 2 or max 3. More than that I generally don't use simultaneously.

No

Yes. After switching to NVIDIA, freezes occurs after some seconds or minutes then continuously freeze unfreeze loop starts till I shutdown the machine forcefully or switch back to hybrid mode.

No

Since I installed Cinnamon edition. 8th May.

No when I switch to NVIDIA then only it occurs and totally random. No long or short duration or frequency increment or decrement.

About 5 minutes or so.

No. Anytime after switching is made.

Yes.

It unfreezes after sometime say 2 to 4 minutes and freezes another time after sometime and the loop continues

Free NVIDIA driver nouveau is not there for my RTX 3050.

Yes. I tried to disable it for full-screen windows and also enable it via Cinnamon settings.

No. I will check and reply ASAP.

Yes.

Yes

No

No

No

Yes, of 4GB space.

No.

Obviously not. I have it as primary OS with dual boot.

No

No

No

From AUR :

glmark2-git r974.6b70efb-1
logisim 2.7.1-7
notion-app-enhanced 2.0.18-1
nvidia-system-monitor-qt 1.5-1
packettracer 8.1.1-1
vuze 5.7.6.0-1

Non AUR :

accountsservice
alsa-firmware
amd-ucode
anydesk-bin
argyllcms
arj
asciiquarium
autoconf
automake
autorandr
b43-fwcutter
base
bash-completion
beautyline
bind
binutils
bison
bleachbit
blueberry
bluetooth-support
brave-bin
bridge-utils
btrfs-progs
bzip2
catfish
celluloid
chaotic-keyring
chaotic-mirrorlist
cinnamon
cmatrix
coreutils
cowsay
cpio
cryptsetup
curlftpfs
dconf-editor
deluge-gtk
dialog
dmidecode
dmraid
dosfstools
downgrade
e2fsprogs
ecryptfs-utils
efibootmgr
ethtool
exfatprogs
f2fs-tools
fakeroot
fatresize
festival
ffmpegthumbnailer
file
filesystem
findutils
firedragon
firefox
firefox-pwa
flex
freetype2
fscrypt
fwupd
garuda-assistant
garuda-boot-options
garuda-browser-settings
garuda-cinnamon-settings
garuda-common-settings
garuda-fish-config
garuda-gamer
garuda-hooks
garuda-hotfixes
garuda-icons
garuda-network-assistant
garuda-optimus-manager-config
garuda-settings-manager
garuda-setup-assistant
garuda-system-maintenance
garuda-video-linux-config
garuda-wallpapers
garuda-wallpapers-extra
garuda-welcome
garuda-zsh-config
gawk
gcc
gcc-libs
gettext
gimp
git
glibc
glmark2-git
gnome-calculator
gnome-color-manager
gnome-firmware
gnome-keyring
gnome-logs
gnome-online-accounts
gnome-screenshot
gnome-terminal-transparency
gnu-netcat
gparted
gpaste
grep
groff
grub
grub-btrfs
grub-garuda
grub-theme-garuda
gstreamer-meta
gtk-engine-murrine
gvfs
gvfs-afc
gvfs-goa
gvfs-google
gvfs-gphoto2
gvfs-mtp
gvfs-nfs
gvfs-smb
gzip
htop
inetutils
input-devices-support
inxi
iproute2
iptables-nft
iputils
ipw2100-fw
ipw2200-fw
jdk-openjdk
jfsutils
jre-openjdk
jre-openjdk-headless
kvantum
kvantum-theme-nordic-git
kvantum-theme-sweet-git
lhasa
libdvdcss
libgsf
libopenraw
librsvg
libtool
licenses
lightdm
lightdm-settings
lightdm-slick-greeter
linux
linux-firmware
linux-headers
linux-zen
linux-zen-headers
logisim
logrotate
lollypop
lrzip
lsb-release
lvm2
lzip
lzop
m4
make
man-db
man-pages
mdadm
meld
memtest86+
mercurial
micro
mintstick
mkinitcpio-nfs-utils
mkinitcpio-openswap
mkinitcpio-systemd-tool
mlocate
modem-manager-gui
mousetweaks
mtools
nano
nemo
nemo-fileroller
nemo-image-converter
nemo-preview
nemo-seahorse
nemo-share
neofetch-git
net-tools
network-manager-applet
networkmanager-support
nfs-utils
nilfs-utils
notion-app-enhanced
noto-fonts
noto-fonts-cjk
noto-fonts-emoji
nss-mdns
ntfs-3g
numlockx
nvidia-system-monitor-qt
onboard
onlyoffice-bin
orca
os-prober-btrfs
p7zip
packettracer
pacman
pacman-contrib
pamac-aur
papirus-icon-theme
paru
patch
pavucontrol
pciutils
perl-file-mimeinfo
pipewire-jack
pipewire-support
pkgconf
playerctl
plymouth-git
plymouth-theme-garuda
power-profiles-daemon
powertop
printer-support
procps-ng
psmisc
qgnomeplatform-qt5
qt5ct
rate-mirrors
reiserfsprogs
rsync
rtw89-dkms-git
samba-support
sassc
scanner-support
sed
shadow
simple-scan
sl
snapper-support
snapper-tools
sof-firmware
sshfs
stacer
subversion
sudo
system-monitoring-center
systemd
systemd-sysvcompat
tar
tela-icon-theme-git
telegram-desktop
terminus-font
texinfo
ttf-dejavu
ttf-fantasque-sans-mono
ttf-fira-sans
ttf-liberation
ttf-opensans
ufw
unace
unarchiver
unarj
unrar
unzip
update-grub
usbutils
util-linux
vi
vim
virtualbox-meta
visual-studio-code-bin
vivaldi
vivaldi-ffmpeg-codecs
vlc
vuze
warpinator
webapp-manager
webcamoid
wget
which
wireless-regdb
wireless_tools
wmctrl
xautolock
xbindkeys
xcape
xdg-desktop-portal
xdg-desktop-portal-gtk
xdg-user-dirs
xdg-utils
xdotool
xed
xfsprogs
xorg-server
xorg-server-xephyr
xorg-xbacklight
xorg-xeyes
xorg-xhost
xorg-xinit
xorg-xinput
xorg-xkill
xorg-xprop
xorg-xrandr
xorg-xsetroot
xorg-xwininfo
xreader
xsel
xviewer
xviewer-plugins
xz
zip

Yes, on Ubuntu, or any debain based distro. Fedora does't even boot with proprietary drivers option.

No.

Yes as above mentioned.

Yes. Garuda GNOME, Cinnamon, i3, xfce and Ubuntu, Manjaro, Fedora, EndeavourOS.

In live environment, swithcing to NVIDIA is not there or I haven't observed the option so it doesn't freeze.

Yes.

No, it works fine when not freezed.

No.

I haven't played any sound.

No it doesn't have.

That's all @tbg. I think issue is with my model of NVIDIA as it occurs in all distros. But don't know if it is anything else. If possible please help if this problem can be fixed.

4 Likes

Thank you so much for your detailed response. I must congratulate you on the thoroughness of your reply.

IMO, after reading all your answers I'd say there is a couple of routes to take.

  1. Reconfigure your driver.

  2. Test as many kernel parameters that you can find that may possibly help with freezing issues.

I do not use nvidia adapters, so I will leave it to others for advice on configuring your driver. The Archwiki has an entire section dedicated to troubleshooting nvidia issues that you should read carefully, (if you haven't already).

https://wiki.archlinux.org/title/NVIDIA/Troubleshooting

Again good work on your in depth answers. I am currently only on my cell, when I'm home and on my computer I will try to find some more suggestions for you.

3 Likes

I would also like to raise my hat to your deep responses @yash , when I edited your post to include the ~~~ for your packages lists I was amazed you went through ALL (I think all...) of the questions. Wow. :smiley: I hope you get your freezing fixed!

3 Likes