Nvidia driver not working after recent update

ok i have a problem simalar but when i plug in a external monitor in i can get it to but using snapshot revovery and not installing that update i have pmac and discover both installed on my system i tried to email the maintainer but i got a can not deliver cause it not an encypted email on cloudflare this is the email i wrote to them but could not deliver so i thought i would just add it to this post hello i have two older pcs and garuda upon updating this fille fails to show the desktop one of the said pc is a lenovo legion gaming pc it upon investigation i was able to plug in a monitor to external intel graphics and it will boot but on the larger 32 inch screen it would not display on hdmi nvidia output anything past the grub post this pc has intel vga graphics as well as a gtx nvida card the second pc is a laptop simple goes to a blank screen i used the snapshots i have a start up disk i created to boot from to do recovery and update all updates but this plymouth-git and it works can you think of why this is happening both pcs experiece same weird thing happening any ideas how to fix this so i can continue normal updates without not updating said plymouth-git

Hi @hottrod, I moved your post to a new topic because your issue is not related to the thread you originally commented in.

Please run the command garuda-inxi in your terminal and paste the output into the thread.

This topic is a good place to start for the issue you are experiencing:

Please update the thread as you work through that resource and let us know what you have tried, as well as the outcome of your efforts.


If that was just a nvidia thing why is it happening to 4 of my laptops after the same Plymouth-git update all the laptops have intel graphics also the pc with both a nvidia card and intel onboard will post on the intel side then after it gets past it i have a desktop appear on the nvidia and intel thats the desktop the laptops just wont boot had to reinstall then if you update to that 22.02 .122.r170.ge8e1937 1-1 you no longer can boot all theses intel laptops

I didn't say your issue was an "Nvidia thing", nor did I say it was anything else. I said it was not related to the thread you posted in, for which the solution is as simple as starting the relevant display manager. You can see how your issue is different, right?

If you want to test your theory that Plymouth is related to your issue, try downgrading plymouth-git, switching to plymouth, or removing the splash kernel parameter.

If you want help troubleshooting your issue, post the output of garuda-inxi into the thread, and also describe in detail what happens when you work through the steps in the resource linked above.


I see what you mean, when I moved your post I had to name the thread something and I blamed your Nvidia driver for your issue (seems like the most obvious cause). Feel free to rename it if you like by clicking the pencil icon to make an edit.

Edit 2:

Just to rule out a simple misunderstanding:

When you say " goes to a blank screen", do you mean "goes to a fully-functioning TTY where I can log in and execute commands"? If so, try starting the display manager as mentioned back on the hijack.

1 Like

Sorry for mis understanding then so the only way i can get past the blank black screen is to go into recovery and use a snapshot to restore from
And i have post on built in VGA intel adapter it displays the dragon logo with the spining logo then goes to another garuda splash then auto login drops into desktop however if i unplug the primary 32 monitor it does not boot at all off nvidia so it maybe a kernel nvidia driver not matching atleast on the pc but all my laptops have intel using default driver so not sure whats going on there i will eun the command today and post reaults and go from there

Here is the result of garuda- inxi

Kernel: 6.2.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=32d31004-ab07-4b44-8b2b-85706ea726d3 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off DEEPIN_GFXMODE=
Desktop: KDE Plasma v: 5.27.3 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm:
1: LightDM v: 1.32.0 note: stopped 2: SDDM note: stopped
Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Lenovo product: Ideacentre K330A v: Lenovo Product
serial: <superuser required>
Mobo: Lenovo model: N/A serial: <superuser required> BIOS: LENOVO
v: DPKT13A date: 02/10/2011
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Touch Keyboard K400
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Info: model: Intel Core i3-2100 bits: 64 type: MT MCP arch: Sandy Bridge
gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2496 high: 3100 min/max: 1600/3100 scaling:
driver: intel_cpufreq governor: performance cores: 1: 1596 2: 2190 3: 3100
4: 3100 bogomips: 24743
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Lenovo driver: i915 v: kernel arch: Gen-6 code: Sandybridge
process: Intel 32nm built: 2011 ports: active: VGA-1 empty: DP-1,HDMI-A-1
bus-ID: 00:02.0 chip-ID: 8086:0102 class-ID: 0380
Device-2: NVIDIA GP108 [GeForce GT 1030] vendor: Gigabyte driver: nvidia
v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-03) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 2 speed: 5 GT/s lanes: 4
bus-ID: 01:00.0 chip-ID: 10de:1d01 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: crocus gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 3280x1050 s-dpi: 55 s-size: 1515x485mm (59.65x19.09")
s-diag: 1591mm (62.63")
Monitor-1: HDMI-0 pos: primary,left res: 1680x1050 hz: 60 dpi: 48
size: 890x490mm (35.04x19.29") diag: 1016mm (40") modes: N/A
Monitor-2: VGA-1-1 pos: right res: 1600x900 hz: 60 dpi: 94
size: 432x240mm (17.01x9.45") diag: 494mm (19.46") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GT
1030/PCIe/SSE2 direct-render: Yes
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Device-2: NVIDIA GP108 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 4
bus-ID: 01:00.1 chip-ID: 10de:0fb8 class-ID: 0403
API: ALSA v: k6.2.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsamixer,amixer
Server-1: PipeWire v: 0.3.67 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel 82579V Gigabit Network vendor: Lenovo driver: e1000e
v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:1503 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
driver: r8188eu bus-ID: 2-1.1.2:7 chip-ID: 0bda:8179 class-ID: 0000
IF: wlp0s26u1u1u2 state: down mac: <filter>
Device-1: Dynex Bluetooth 4.0 Adapter [Broadcom 1.12 BCM20702A0] type: USB
driver: btusb v: 0.8 bus-ID: 2-1.2:4 chip-ID: 19ff:0239 class-ID: fe01
serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Local Storage: total: 2.17 TiB used: 198.07 GiB (8.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST9750420AS
size: 698.64 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: DEM1 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: SBM3 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD6400AAKS-75A7B2 size: 596.17 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 3B01
scheme: GPT
ID-1: / raw-size: 698.63 GiB size: 698.63 GiB (100.00%)
used: 198.07 GiB (28.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 698.63 GiB size: 698.63 GiB (100.00%)
used: 198.07 GiB (28.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 698.63 GiB size: 698.63 GiB (100.00%)
used: 198.07 GiB (28.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 698.63 GiB size: 698.63 GiB (100.00%)
used: 198.07 GiB (28.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 11.6 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 31.0 C mobo: N/A gpu: nvidia temp: 31 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 34%
Processes: 229 Uptime: 4m wakeups: 4 Memory: 11.6 GiB used: 2.62 GiB (22.6%)
Init: systemd v: 253 default: graphical tool: systemctl Compilers:
gcc: 12.2.1 Packages: 2114 pm: pacman pkgs: 2081 libs: 546
tools: octopi,pamac,paru pm: flatpak pkgs: 33 Shell: fish v: 3.6.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-02-10
Last full system update: 2023-03-31
Is partially upgraded:   Yes
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       <superuser required>
Failed units

My advice, just remove Plymouth. I remember having major issues with it in the past. It is a complicated order to do so if memory serves me. It has its hooks in initramfs, grub cfg, systemd. Consult Arch-wiki and the web.

It was one of the reason I did a Frankenstein fresh install and added Garuda repos into an ACLI install separately (method not supported by Garuda btw.)

1 Like

Can you explain why you are including this kernel parameter? My understanding is it will need a string as an argument to have an effect (for example DEEPIN_GFXMODE=1024x768x16, to set the resolution to 1024x768 with 16-bit color depth), but I may not know the whole story. It is definitely not part of a default setup. It doesn't look like you are using Deepin?

A partial upgrade can make troubleshooting very difficult because there is no telling what can be broken. Binaries might be linked against libraries that don't exist, etc. It is best to resolve a partial upgrade first before trying to address other problems.



from the terminal, and paste the output into the thread.

1 Like
Synchronizing package databases...
garuda downloading...
core downloading...
extra downloading...
community downloading...
multilib downloading...
chaotic-aur downloading...
:: Starting full system upgrade...
warning: reshade-shaders-git: local (r909.2459c73-1) is newer than chaotic-aur (r18.1947b78-1)
resolving dependencies...
looking for conflicting packages...

Packages (76) dxvk-mingw-git-2.1.r54.g6d14fffd-1  garuda-migrations-2.3.0-1
plymouth-git-22.02.122.r170.ge8e19371-2  python-humanfriendly-10.0-4  qemu-audio-alsa-7.2.1-1
qemu-audio-dbus-7.2.1-1  qemu-audio-jack-7.2.1-1  qemu-audio-oss-7.2.1-1  qemu-audio-pa-7.2.1-1
qemu-audio-sdl-7.2.1-1  qemu-audio-spice-7.2.1-1  qemu-block-curl-7.2.1-1
qemu-block-dmg-7.2.1-1  qemu-block-nfs-7.2.1-1  qemu-block-ssh-7.2.1-1
qemu-chardev-spice-7.2.1-1  qemu-common-7.2.1-1  qemu-desktop-7.2.1-1
qemu-emulators-full-7.2.1-1  qemu-hw-display-qxl-7.2.1-1  qemu-hw-display-virtio-gpu-7.2.1-1
qemu-hw-display-virtio-gpu-gl-7.2.1-1  qemu-hw-display-virtio-gpu-pci-7.2.1-1
qemu-hw-display-virtio-gpu-pci-gl-7.2.1-1  qemu-hw-display-virtio-vga-7.2.1-1
qemu-hw-display-virtio-vga-gl-7.2.1-1  qemu-hw-s390x-virtio-gpu-ccw-7.2.1-1
qemu-hw-usb-host-7.2.1-1  qemu-hw-usb-redirect-7.2.1-1  qemu-hw-usb-smartcard-7.2.1-1
qemu-img-7.2.1-1  qemu-pr-helper-7.2.1-1  qemu-system-aarch64-7.2.1-1
qemu-system-alpha-7.2.1-1  qemu-system-alpha-firmware-7.2.1-1  qemu-system-arm-7.2.1-1
qemu-system-arm-firmware-7.2.1-1  qemu-system-avr-7.2.1-1  qemu-system-cris-7.2.1-1
qemu-system-hppa-7.2.1-1  qemu-system-hppa-firmware-7.2.1-1  qemu-system-loongarch64-7.2.1-1
qemu-system-m68k-7.2.1-1  qemu-system-microblaze-7.2.1-1
qemu-system-microblaze-firmware-7.2.1-1  qemu-system-mips-7.2.1-1  qemu-system-nios2-7.2.1-1
qemu-system-or1k-7.2.1-1  qemu-system-ppc-7.2.1-1  qemu-system-ppc-firmware-7.2.1-1
qemu-system-riscv-7.2.1-1  qemu-system-riscv-firmware-7.2.1-1  qemu-system-rx-7.2.1-1
qemu-system-s390x-7.2.1-1  qemu-system-s390x-firmware-7.2.1-1  qemu-system-sh4-7.2.1-1
qemu-system-sparc-7.2.1-1  qemu-system-sparc-firmware-7.2.1-1  qemu-system-tricore-7.2.1-1
qemu-system-x86-7.2.1-1  qemu-system-x86-firmware-7.2.1-1  qemu-system-xtensa-7.2.1-1
qemu-tools-7.2.1-1  qemu-ui-curses-7.2.1-1  qemu-ui-dbus-7.2.1-1  qemu-ui-egl-headless-7.2.1-1
qemu-ui-gtk-7.2.1-1  qemu-ui-opengl-7.2.1-1  qemu-ui-sdl-7.2.1-1  qemu-ui-spice-app-7.2.1-1
qemu-ui-spice-core-7.2.1-1  qemu-user-7.2.1-1  qemu-vhost-user-gpu-7.2.1-1
qemu-virtiofsd-7.2.1-1  rubberband-3.2.1-1  xf86-input-wacom-1.2.0-1

Total Download Size:   110.55 MiB
Total Installed Size:  558.84 MiB
Net Upgrade Size:       -4.62 MiB

:: Proceed with installation? [Y/n]

Proceed! :+1:

if i click yes i can not get back in the system unless i use a previous snap to restore to i have tried many times to get tty and restart x it will not let me i was able to get tty 1 time and it just froze and rebooted it post the grub then the screen with boot options thats as far as i get and i tried all options in the boot only thing that works is the boot to snapshot then i chose snap with the zen and initrmfs option and reset back to the current state which does boot but after upgrade does not
is plymouth a splash screen it was when i was using ubuntu for a very long time just converted to garuda and love it lots to learn here

Okay but please take the update and paste the output into the thread so we can see if there are relevant clues regarding what is happening.

this computer is my wifes she plays games on it in steam and as far as deepin she likes the file manager so she installed that instead of using defualt dolphin

so you want me to update then it will ask to reboot but it will not unless i restore i have done it 4 times

Yes, and paste the output into the thread so we can see what is happening.

is there a conflict with my kernel matching the nvidia driver someone said i need to use the dkms driver so it updates both the kernel and the driver to match

cause i dont think i used the dkms driver cause it did not have the over clock controls for this gpu it has 3 speeds

if you dont think its a nvidia issue i will upgrade again and post output i just will close the box that says reboot and i will just have to use sanapper again to get it to boot back up

What box is this?

Please, just take the update and paste the output in the thread. Don't worry about rebooting right now.

a box pops up and says restart it updates

i will just do it now i know how to reverse it and paste the ouput but it will take me half hour to get back online before we can chat again

Please, stop posting like in a chat room.

As long as no one has responded to your post you can edit your post.

what do you mean im trying to fix this issue with plymouth-git that breaks my system after update on all my pcs