NVidia-dkms driver problem

Hi,
I state that this is not the first time this happens but generally by reinstalling the system everything would be fine.
I've been having problems with Nvidia drivers for about a week now.
It all started a week ago when trying to update the system, and Pacman crashed the system while installing the NVidia dkms module. Since I didn't have time to investigate, I restored a snapshot.
Yesterday I decided to wipe, and I could not complete the installation using NVidia's closed source drivers.
I then completed the installation without the NVidia drivers and then installed them later, but the same thing happened as soon as I tried again. The system freezes, and so I am forced to force it to shut down.
I have already checked that the bios is up to date, and it is.

sudo garuda-inxi
System:
Kernel: 5.17.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=366fbff6-1a66-45bd-b0bd-baf5a6a52039 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: N/A
Mobo: ASUSTeK model: ROG MAXIMUS XII FORMULA v: Rev 1.xx serial: <filter>
UEFI: American Megatrends v: 2403 date: 10/27/2021
Battery:
ID-1: hidpp_battery_0 charge: 84% condition: N/A volts: 4.0 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: discharging
CPU:
Info: model: Intel Core i9-10900K socket: LGA1200 bits: 64 type: MT MCP
arch: Comet Lake family: 6 model-id: 0xA5 (165) stepping: 5 microcode: 0xF0
Topology: cpus: 1x cores: 10 tpc: 2 threads: 20 smt: enabled cache:
L1: 640 KiB desc: d-10x32 KiB; i-10x32 KiB L2: 2.5 MiB desc: 10x256 KiB
L3: 20 MiB desc: 1x20 MiB
Speed (MHz): avg: 1963 high: 4864 min/max: 800/5300 base/boost: 3700/8300
scaling: driver: intel_pstate governor: powersave volts: 0.9 V
ext-clock: 100 MHz cores: 1: 800 2: 800 3: 3619 4: 2894 5: 2130 6: 1356
7: 871 8: 800 9: 800 10: 800 11: 800 12: 800 13: 800 14: 800 15: 800
16: 2222 17: 4482 18: 4447 19: 4864 20: 4389 bogomips: 147994
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: Gigabyte driver: nouveau
v: kernel non-free: 515.xx+ status: current (as of 2022-05) arch: Pascal
pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
ports: active: DP-1,DP-2,DP-3 empty: DVI-D-1,HDMI-A-1 bus-ID: 01:00.0
chip-ID: 10de:1b81 class-ID: 0300
Device-2: Logitech HD Pro Webcam C920 type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-2.2:7 chip-ID: 046d:082d
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: nouveau unloaded: modesetting
alternate: fbdev,nv,vesa gpu: nouveau display-ID: :0 screens: 1
Screen-1: 0 s-res: 7280x1440 s-dpi: 96 s-size: 1926x381mm (75.83x15.00")
s-diag: 1963mm (77.3")
Monitor-1: DP-1 pos: primary,top-center model: Mi Monitor built: 2019
res: 3440x1440 hz: 50 dpi: 110 gamma: 1.2 size: 797x334mm (31.38x13.15")
diag: 864mm (34") modes: max: 3440x1440 min: 720x400
Monitor-2: DP-2 pos: primary,top-left model: AOC 2460G5 serial: <filter>
built: 2017 res: 1920x1080 dpi: 92 gamma: 1.2
size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-3: DP-3 pos: bottom-r model: LG (GoldStar) 24GL600F
serial: <filter> built: 2020 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
size: 531x298mm (20.91x11.73") diag: 609mm (24") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: NV134 v: 4.3 Mesa 22.0.4 direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:10f0
class-ID: 0403
Device-3: Logitech HD Pro Webcam C920 type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-2.2:7 chip-ID: 046d:082d
class-ID: 0102 serial: <filter>
Device-4: RODE Microphones NT-USB type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1:2 chip-ID: 19f7:0003
class-ID: 0300
Sound Server-1: ALSA v: k5.17.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Aquantia AQC107 NBase-T/IEEE 802.3bz Ethernet [AQtion]
vendor: ASUSTeK driver: atlantic v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 2 link-max: lanes: 4 port: N/A bus-ID: 04:00.0 chip-ID: 1d6a:07b1
class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-3: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 05:00.0
chip-ID: 8086:15f3 class-ID: 0200
IF: enp5s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:9 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.61 TiB used: 11.17 GiB (0.7%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: N/A
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: RKT343.4
temp: 29.9 C scheme: GPT
SMART: yes health: PASSED on: 30d 1h cycles: 408
read-units: 2,351,965 [1.20 TB] written-units: 6,909,996 [3.53 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB
family: based SSDs size: 232.89 GiB block-size: physical: 512 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 2B6Q temp: 30 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 1y 310d 6h cycles: 3153
written: 32.85 TiB
ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 EVO 250GB
family: based SSDs size: 232.89 GiB block-size: physical: 512 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 2B6Q temp: 30 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 1y 357d 16h cycles: 3428
written: 40.9 TiB
ID-4: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 850 EVO 250GB
family: based SSDs size: 232.89 GiB block-size: physical: 512 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 1B6Q temp: 30 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 3y 147d 1h cycles: 3017
written: 40.93 TiB
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 11.17 GiB (1.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 580 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 11.17 GiB (1.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 11.17 GiB (1.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 11.17 GiB (1.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.16 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 27.8 C mobo: N/A gpu: nouveau temp: 37.0 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 0
Info:
Processes: 461 Uptime: 5m wakeups: 2 Memory: 31.16 GiB
used: 3.34 GiB (10.7%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 Packages: pacman: 1439 lib: 323 Shell: garuda-inxi (sudo)
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.16
Garuda (2.6.3-2):
System install date:     2022-05-20
Last full system update: 2022-05-21
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Yes
Snapshots:               Snapper
Failed units:

Just check fast boot and secure boot is disabled before the reinstall in your bios as windows has a habit on turning them back on

1 Like

Just checked, fast boot and secure boot are disabled.

Also, I installed Windows before reinstalling but after the first time I had the problem so I don't think it's related.

Try switching to a different kernel--LTS is a good place to start.

Pull the system up to date:

garuda-update

Install LTS kernel:

sudo pacman -S linux-lts linus-lts-headers

Select "advanced options" on the grub menu to boot to your new kernel.

3 Likes

Have you disconnected your extraneous monitors?

Running 3 monitors isn't exactly a standard setup. I would highly suggest installing with only 1 main monitor to start with.

Edit:

Just read your post history. You've had more than 1 help request relating to your multi monitor setup. Have you tested disabling the kwin compositor?

Multi-monitor setups are fraught with issues as there are many bugs with this type of setup.

3 Likes

I forgot to write that I have already tried with the following kernels: linux, linux-lts, linux-zen, linux-mainline, linux-xanmod-edge

Perhaps you didn't notice my last minute edit just before your last post.

Have you tested disabling the kwin compositor?

Have you tried setting up your computer with only a single monitor?

Just tried, no difference

The same happens also if I try to install nvidia-dkms from the tty so the compositor isn't the problem.

Perhaps try searching for some kernel parameters relevant to your motherboard and nvidia.

Test using nomodeset to start with.

1 Like

Other kernel parameters you might want to test are:

pcie_aspm=off

pci=noacpi

Another thing you could try is installing the older version of the nvidia driver. That is assuming there was an nvidia driver update during the timeframe when your system broke.

https://wiki.archlinux.org/title/downgrading_packages

2 Likes

Okay, those two parameters helped. Now the whole system doesn't crash anymore.
But it still keeps getting stuck there.

> Using config 'video-nvidia-dkms' for device: 0000:01:00.0 (0300:10de:1b81) Display controller nVidia Corpora
tion GP104 [GeForce GTX 1070]
> Installing video-nvidia-dkms...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-dkms/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
core downloading...
extra downloading...
community downloading...
multilib downloading...
chaotic-aur downloading...
blackarch downloading...
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: nvidia-utils will be installed before its egl-wayland dependency

Packages (37) blas-3.10.1-1  cblas-3.10.1-1  egl-wayland-2:1.1.9+r3+g582b2d3-1  eglexternalplatform-1.1-2  gob
ject-introspection-1.72.0-1  gwe-0.15.5-1  lapack-3.10.1-1  lib32-nvidia-utils-515.43.04-1  lib32-opencl-nvidi
a-515.43.04-1  libdazzle-3.44.0-1  libxnvctrl-515.43.04-1  nvidia-dkms-515.43.04-1  nvidia-settings-515.43.04-
1  nvidia-utils-515.43.04-1  opencl-nvidia-515.43.04-1  python-beaker-1.11.0-8  python-cycler-0.11.0-1  python
-dateutil-2.8.2-4  python-fonttools-4.33.3-1  python-importlib-metadata-4.8.1-3  python-injector-0.19.0-1  pyt
hon-kiwisolver-1.3.2-3  python-mako-1.1.6-3  python-markdown-3.3.7-1  python-markupsafe-2.1.1-1  python-matplo
tlib-3.5.2-1  python-numpy-1.22.3-1  python-peewee-3.14.10-1  python-py3nvml-0.2.7-1  python-pyxdg-0.27-4  pyt
hon-rx-3.2.0-3  python-six-1.16.0-5  python-typing_extensions-4.2.0-1  python-xlib-0.31-3  python-zipp-3.8.0-1
qhull-2020.2-4  garuda-nvidia-config-1:r62.889aefa-6                                                         

Total Download Size:   313,58 MiB                                                                              
Total Installed Size:  875,17 MiB                                                                              

:: Proceed with installation? [Y/n]                                                                            
:: Retrieving packages...                                                                                      
nvidia-utils-515.43.04-1-x86_64 downloading...                                                                
nvidia-dkms-515.43.04-1-x86_64 downloading...                                                                 
lib32-nvidia-utils-515.43.04-1-x86_64 downloading...                                                          
lib32-opencl-nvidia-515.43.04-1-x86_64 downloading...                                                         
opencl-nvidia-515.43.04-1-x86_64 downloading...                                                               
python-numpy-1.22.3-1-x86_64 downloading...                                                                   
python-matplotlib-3.5.2-1-x86_64 downloading...                                                               
lapack-3.10.1-1-x86_64 downloading...                                                                         
python-fonttools-4.33.3-1-x86_64 downloading...                                                               
gobject-introspection-1.72.0-1-x86_64 downloading...                                                          
qhull-2020.2-4-x86_64 downloading...                                                                          
nvidia-settings-515.43.04-1-x86_64 downloading...                                                             
libdazzle-3.44.0-1-x86_64 downloading...                                                                      
python-peewee-3.14.10-1-x86_64 downloading...                                                                 
python-dateutil-2.8.2-4-any downloading...                                                                    
python-xlib-0.31-3-any downloading...                                                                         
python-rx-3.2.0-3-any downloading...                                                                          
gwe-0.15.5-1-any downloading...                                                                               
python-markdown-3.3.7-1-any downloading...                                                                    
python-mako-1.1.6-3-any downloading...                                                                        
blas-3.10.1-1-x86_64 downloading...                                                                           
python-beaker-1.11.0-8-any downloading...                                                                     
python-py3nvml-0.2.7-1-any downloading...                                                                     
python-pyxdg-0.27-4-any downloading...                                                                        
libxnvctrl-515.43.04-1-x86_64 downloading...                                                                  
python-kiwisolver-1.3.2-3-x86_64 downloading...                                                               
python-injector-0.19.0-1-any downloading...                                                                   
python-typing_extensions-4.2.0-1-any downloading...                                                           
cblas-3.10.1-1-x86_64 downloading...                                                                          
python-importlib-metadata-4.8.1-3-any downloading...                                                          
egl-wayland-2:1.1.9+r3+g582b2d3-1-x86_64 downloading...                                                       
python-six-1.16.0-5-any downloading...                                                                        
python-markupsafe-2.1.1-1-x86_64 downloading...                                                               
python-cycler-0.11.0-1-any downloading...                                                                     
python-zipp-3.8.0-1-any downloading...                                                                        
eglexternalplatform-1.1-2-any downloading...                                                                  
garuda-nvidia-config-1:r62.889aefa-6-any downloading...                                                       
checking keyring...                                                                                            
checking package integrity...                                                                                  
loading package files...                                                                                       
checking for file conflicts...                                                                                 
checking available disk space...                                                                               
:: Running pre-transaction hooks...                                                                            
(1/1) Performing snapper pre snapshots for the following configurations...                                     
==> root: 40                                                                                                   
:: Processing package changes...                                                                               
installing nvidia-utils...                                                                                     
If you run into trouble with CUDA not being available, run nvidia-modprobe first.                              
Optional dependencies for nvidia-utils                                                                         
nvidia-settings: configuration tool [pending]                                                              
xorg-server-devel: nvidia-xconfig                                                                          
opencl-nvidia: OpenCL support [pending]                                                                    
installing eglexternalplatform...                                                                              
installing egl-wayland...                                                                                      
installing python-markupsafe...                                                                                
installing python-beaker...                                                                                    
installing python-mako...                                                                                      
installing python-zipp...                                                                                      
installing python-importlib-metadata...                                                                        
installing python-markdown...                                                                                  
installing gobject-introspection...                                                                            
installing libdazzle...                                                                                        
installing python-typing_extensions...                                                                         
installing python-injector...                                                                                  
installing python-six...                                                                                       
installing python-cycler...                                                                                    
installing python-dateutil...                                                                                  
installing python-fonttools...                                                                                 
Optional dependencies for python-fonttools                                                                     
python-brotli: to compress/decompress WOFF 2.0 web fonts                                                   
python-fs: to read/write UFO source files                                                                  
python-lxml: faster backend for XML files reading/writing                                                  
python-lz4: for graphite type tables in ttLib/tables                                                       
python-matplotlib: for visualizing DesignSpaceDocument and resulting VariationModel [pending]              
python-pyqt5: for drawing glyphs with Qt’s QPainterPath [installed]                                        
python-reportlab: to drawing glyphs as PNG images [installed]                                              
python-scipy: for finding wrong contour/component order between different masters                          
python-sympy: for symbolic font statistics analysis                                                        
python-uharfbuzz: to use the Harfbuzz Repacker for packing GSUB/GPOS tables                                
python-unicodedata2: for displaying the Unicode character names when dumping the cmap table with ttx       
python-zopfli: faster backend fom WOFF 1.0 web fonts compression                                           
installing python-kiwisolver...                                                                                
installing blas...                                                                                             
installing cblas...                                                                                            
installing lapack...                                                                                           
installing python-numpy...                                                                                     
Optional dependencies for python-numpy                                                                         
openblas: faster linear algebra                                                                            
installing qhull...                                                                                            
installing python-matplotlib...                                                                                
Optional dependencies for python-matplotlib                                                                    
tk: Tk{Agg,Cairo} backends                                                                                 
pyside2: alternative for Qt5{Agg,Cairo} backends                                                           
pyside6: alternative for Qt6{Agg,Cairo} backends                                                           
python-pyqt5: Qt5{Agg,Cairo} backends [installed]                                                          
python-pyqt6: Qt6{Agg,Cairo} backends                                                                      
python-gobject: for GTK{3,4}{Agg,Cairo} backend [installed]                                                
python-wxpython: WX{Agg,Cairo} backend                                                                     
python-cairo: {GTK{3,4},Qt{5,6},Tk,WX}Cairo backends [installed]                                           
python-cairocffi: alternative for Cairo backends                                                           
python-tornado: WebAgg backend                                                                             
ffmpeg: for saving movies [installed]                                                                      
imagemagick: for saving animated gifs [installed]                                                          
ghostscript: usetex dependencies [installed]                                                               
texlive-bin: usetex dependencies [installed]                                                               
texlive-latexextra: usetex usage with pdflatex                                                             
python-certifi: https support                                                                              
installing python-peewee...                                                                                    
Optional dependencies for python-peewee                                                                        
python-psycopg2: for PostgreSQL database support                                                           
python-pymysql: for MySQL database support                                                                 
installing python-py3nvml...                                                                                   
installing python-rx...
installing python-pyxdg...
installing python-xlib...
installing gwe...
installing libxnvctrl...
installing nvidia-settings...
installing opencl-nvidia...
Optional dependencies for opencl-nvidia
opencl-headers: headers necessary for OpenCL development
installing lib32-nvidia-utils...
Optional dependencies for lib32-nvidia-utils
lib32-opencl-nvidia [pending]
installing lib32-opencl-nvidia...
Optional dependencies for lib32-opencl-nvidia
opencl-headers: headers necessary for OpenCL development
installing nvidia-dkms...
installing garuda-nvidia-config...
:: Running post-transaction hooks...
( 1/16) Creating system user accounts...
Creating group 'nvidia-persistenced' with GID 143.
Creating user 'nvidia-persistenced' (NVIDIA Persistence Daemon) with UID 143 and GID 143.
( 2/16) Reloading system manager configuration...
( 3/16) Reloading device manager configuration...
( 4/16) Arming ConditionNeedsUpdate...
( 5/16) Install DKMS modules
==> dkms install --no-depmod nvidia/515.43.04 -k 5.17.9-zen1-1-zen

With nomodeset even nouveau stops working

I believe the full parameter should be nomodeset=1.

However, I am not an nvidia user, so I'm not overly familiar with what is required to get their basterdized drivers working. :wink:

1 Like

How long does it get stuck on the dkms install?
Depending on how quick your machine is, this could take up to 2 or even 3mins.

I waited 10 minutes. Also if I am in tty I get multiple hardware errors.

What are the errors? Output to a text file and paste them into the thread, perhaps the errors will be meaningful to someone in the forum.

I try, however for the most part there are dumps of the CPU registers and RAM sectors as I have seen.


Since they are direct logs to the tty a screenshot is the only way I was able to show those logs.

man pastebinit

Not even a downgrade seems to help...