Nvidia color separation/delamination

Hello guys,
I have some issue with games on Garuda. Weird color separation.
On yt videos and in OS, there is no problem.
This looks like this:
https://i.imgur.com/r6w03Rz.jpg
Should I try reinstall graphic card drivers?
I didn’t have problem on other linux distro.

Hi there, welcome to the forum.
Please provide your garuda-inxi information, as required by the template.

4 Likes
System:
Kernel: 6.6.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0af2a4f8-1bac-4ac1-8d80-afba7db4b238 rw rootflags=subvol=@
quiet resume=UUID=86052d48-12aa-493e-91bf-1a4363e34726 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: B550 AORUS ELITE V2
serial: <superuser required> UEFI: American Megatrends LLC. v: F16b
date: 02/08/2023
CPU:
Info: model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 0 microcode: 0xA201025
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3435 high: 4150 min/max: 2200/5083 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3400 2: 3400
3: 3400 4: 3400 5: 3400 6: 3400 7: 3400 8: 3400 9: 3400 10: 3400 11: 3400
12: 3400 13: 3581 14: 3400 15: 3400 16: 3400 17: 3400 18: 3400 19: 3592
20: 3400 21: 4150 22: 3400 23: 3400 24: 3400 25: 3400 26: 3400 27: 3400
28: 3400 29: 3400 30: 3400 31: 3400 32: 3400 bogomips: 217190
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: Micro-Star MSI
driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 2 speed: 5 GT/s
lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none
off: DP-1,DP-2,HDMI-A-1 empty: DP-3 bus-ID: 07:00.0 chip-ID: 10de:2204
class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 107 s-size: 1064x342mm (41.89x13.46")
s-diag: 1118mm (44")
Monitor-1: DP-1 mapped: DP-0 note: disabled pos: right model: MSI G241
serial: <filter> built: 2020 res: 1920x1080 hz: 60 dpi: 93 gamma: 1.2
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
Monitor-2: DP-2 note: disabled pos: primary,left
model: LG (GoldStar) 27GL850 serial: <filter> built: 2020 res: 2560x1440
hz: 144 dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23")
diag: 685mm (27") ratio: 16:9 modes: max: 2560x1440 min: 640x480
Monitor-3: HDMI-A-1 mapped: HDMI-0 note: disabled
model: LG (GoldStar) TV SSCR2 serial: <filter> built: 2022 res: 2560x1440
dpi: 61 gamma: 1.2 size: 1600x900mm (62.99x35.43") diag: 1836mm (72.3")
ratio: 16:9 modes: max: 3840x2160 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3090/PCIe/SSE2
memory: 23.44 GiB
API: Vulkan v: 1.3.269 layers: 11 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3090 driver: nvidia v: 545.29.06
device-ID: 10de:2204 surfaces: xcb,xlib
Audio:
Device-1: NVIDIA GA102 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 07:00.1 chip-ID: 10de:1aef class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Samson Meteor condenser microphone
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-3:3 chip-ID: 17a0:0310 class-ID: 0300
API: ALSA v: k6.6.6-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2725
class-ID: 0280
IF: wlp4s0 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 06:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-6.2:5 chip-ID: 8087:0032
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 7c0104
Drives:
Local Storage: total: 2.77 TiB used: 197.26 GiB (6.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Seagate
model: XPG GAMMIX S70 BLADE size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 3.2.F.74 temp: 47.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Western Digital
model: WD Blue SN570 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 234100WD temp: 40.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Silicon Power
model: SPCC Solid State Disk size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 8B0
scheme: GPT
Partition:
ID-1: / raw-size: 896.85 GiB size: 896.85 GiB (100.00%)
used: 197.26 GiB (22.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:6
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:5
ID-3: /home raw-size: 896.85 GiB size: 896.85 GiB (100.00%)
used: 197.26 GiB (22.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:6
ID-4: /var/log raw-size: 896.85 GiB size: 896.85 GiB (100.00%)
used: 197.26 GiB (22.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:6
ID-5: /var/tmp raw-size: 896.85 GiB size: 896.85 GiB (100.00%)
used: 197.26 GiB (22.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 34.37 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme1n1p3 maj-min: 259:7
ID-2: swap-2 type: zram size: 31.24 GiB used: 2.2 MiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 32 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 45.6 C mobo: 30.0 C gpu: nvidia temp: 57 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Info:
Processes: 513 Uptime: 26m wakeups: 0 Memory: total: 32 GiB
available: 31.24 GiB used: 4.05 GiB (13.0%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1860 libs: 538 tools: octopi,pamac,paru
Shell: fish v: 3.6.4 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-12-11
Last full system update: 2023-12-14
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Hi @SzzzAK999 , you are using x.org , can you please switch to Wayland

On wayland is even worst and I use nvidia card so there is no full drivers for wayland. X11 is better with nvidia I guess, and there is less bugs on desktop.

that’s partially true , but i do use Wayland like many others do , its getting so much better and i got no issues so far , and garuda KDE is moving towards wayland (and almost all DE in the future ), so please try it if the problem still appears consider changing into Gnome (well its now using wayland).

Well I will use X11, because I have less issues. Gnome looks like Windows 8, no thanks.

On wayland still this colors is weird:
https://i.imgur.com/iOlpegw.jpg

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.