Nvidia card not scaling correctly pushiing task bar off screen

Hello Garuda users.

I just installed Garuda, was able to get it working with the corect scaling on the intel graphics card. However when I switched to the Nvidia 2060 Super I have in the system it caused the scaling to make it so I cant see all the task bar under any of the KDE desktops. I looked under the forums last night and tried the fixed to change the dpi that did not work. I tried to reinstall the OS with the nvidia card plugged in with the same result.

When looking at the sddm.conf there is only 2 lines, and it shows that I do not have the other files listed in other posts. Any help would be thankful.

  Kernel: 6.5.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    available: acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=22c7b133-fa3d-4411-8f14-81db7bd92dfe rw rootflags=subvol=@ quiet quiet
    rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=ca3cc88f-4b7b-4c11-8d45-b3c442229154 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: Dell product: XPS 8940 v: N/A serial: <superuser required> Chassis: type: 3
    serial: <superuser required>
  Mobo: Dell model: 0KV3RP v: A00 serial: <superuser required> UEFI: Dell v: 2.11.1
    date: 02/24/2023
  Info: model: Intel Core i9-10900 bits: 64 type: MT MCP arch: Comet Lake gen: core 10 level: v3
    note: check built: 2020 process: Intel 14nm family: 6 model-id: 0xA5 (165) stepping: 5
    microcode: 0xF8
  Topology: cpus: 1x cores: 10 tpc: 2 threads: 20 smt: enabled cache: L1: 640 KiB desc: d-10x32
    KiB; i-10x32 KiB L2: 2.5 MiB desc: 10x256 KiB L3: 20 MiB desc: 1x20 MiB
  Speed (MHz): avg: 2944 high: 4706 min/max: 800/5200 scaling: driver: intel_pstate
    governor: powersave cores: 1: 4700 2: 4700 3: 4706 4: 800 5: 800 6: 4697 7: 4700 8: 4700 9: 4697
    10: 800 11: 800 12: 4694 13: 800 14: 4695 15: 4699 16: 800 17: 800 18: 800 19: 800 20: 4700
    bogomips: 111997
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: Dell driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: none empty: DP-1, DP-2,
    HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:9bc5 class-ID: 0380
  Device-2: NVIDIA TU106 [GeForce RTX 2060 SUPER] vendor: Dell driver: nvidia v: 535.113.01
    alternate: nouveau,nvidia_drm non-free: 535.xx+ status: current (as of 2023-09) arch: Turing
    code: TUxxx process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1f06 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1 compositor: kwin_x11 driver: X:
    loaded: modesetting,nouveau,nvidia alternate: fbdev,intel,nv,vesa dri: iris gpu: i915,nvidia
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 7680x2160 s-dpi: 60 s-size: 3249x914mm (127.91x35.98")
    s-diag: 3375mm (132.88")
  Monitor-1: HDMI-0 pos: primary res: 3840x2160 hz: 60 dpi: 61 size: 1600x900mm (62.99x35.43")
    diag: 1836mm (72.27") modes: N/A
  Monitor-2: None-2-1 size-res: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0 drv: nvidia device: 1
    drv: iris device: 3 drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 535.113.01 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce RTX 2060 SUPER/PCIe/SSE2 memory: 7.81 GiB
  API: Vulkan v: 1.3.264 layers: 4 device: 0 type: discrete-gpu name: NVIDIA GeForce RTX 2060
    SUPER driver: nvidia v: 535.113.01 device-ID: 10de:1f06 surfaces: xcb,xlib device: 1
    type: integrated-gpu name: Intel UHD Graphics 630 (CML GT2) driver: mesa intel
    v: 23.2.1-arch1.2 device-ID: 8086:9bc5 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  API: ALSA v: k6.5.8-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type:
 plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek vendor: Rivet Networks driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:2600 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 1-14:5 chip-ID: 8087:0026 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2 lmp-v: 11 status:
    discoverable: no pairing: no class-ID: 7c0104
  Local Storage: total: 2.29 TiB used: 17.12 GiB (0.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: KBG40ZNS512G NVMe KIOXIA 512GB
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD
    serial: <filter> fw-rev: 10410106 temp: 49.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 1003 scheme: GPT
  ID-1: / raw-size: 442.46 GiB size: 442.46 GiB (100.00%) used: 17.12 GiB (3.9%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 442.46 GiB size: 442.46 GiB (100.00%) used: 17.12 GiB (3.9%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 442.46 GiB size: 442.46 GiB (100.00%) used: 17.12 GiB (3.9%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 442.46 GiB size: 442.46 GiB (100.00%) used: 17.12 GiB (3.9%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 34.19 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 31.08 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
  System Temperatures: cpu: 53.0 C pch: 38.0 C mobo: 38.0 C gpu: nvidia temp: 34 C
  Fan Speeds (rpm): cpu: 798 fan-2: 1000 gpu: nvidia fan: 31%
  Processes: 378 Uptime: 41m wakeups: 0 Memory: total: 32 GiB note: est. available: 31.08 GiB
  used: 2.6 GiB (8.4%) Init: systemd v: 254 default: graphical tool: systemctl Compilers:
  gcc: 13.2.1 Packages: pm: pacman pkgs: 1469 libs: 421 tools: octopi,paru Client: shell wrapper
  v: 5.1.16-release inxi: 3.3.30
Garuda (2.6.17-1):
  System install date:     2023-10-23
  Last full system update: 2023-10-23
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:

Did you try

sudo nvidia-settings

save your settings, if this work.
Did you use system settings - monitor?
Scale and resolution?


I use only one GPU in my desktops, so I am out of ideas.

There was a fix that said to add sddm.conf file


ServerArguments=-nolisten tcp -dpi 96

The intel card is on the mother board,. I am out of idead.

Please, answer all questions.
Use also in terminal arandr and xrandr if system and nvidia settings fail.

You can try also in ~/.Xresources, create if not exist.

Xft.dpi: 120

Edit 120 to you liking.

I am trying to see is I can get xrandr to set it. Nvidia setting didn’t give me much. I will the making the file.

Just made it and it didn’t work. I am guessing I am going to to have to use the intel card

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.