Numlock on login screen

Hi,
how to enable the numlock on login screen for Garuda lxqt edition.?

### NumLock on by default

Install the [numlockx](https://archlinux.org/packages/?name=numlockx) package and then edit `/etc/lightdm/lightdm.conf`:

/etc/lightdm/lightdm.conf

[Seat:*] greeter-setup-script=/usr/bin/numlockx on

Source : LightDM - ArchWiki

2 Likes

Numlockx was installed on the OS already. i saw it in Add/remove software.

i opened the folder /etc/lightdm/lightdm.conf on file system
i opened lightdm.conf text file and inserted "greeter-setup-script=/usr/bin/numlockx on " under the heading of [Seat:*]..i saved the text file .. restarted the computer..

numlock was not there.

did i do it wrong way?

I can't help you at the moment because Gitlab is down and I can't see lightdm.conf

1 Like

So, comming back on the topic,

This means all lines starting with [Seat:

I mean you don't have to add it, it should be there, for example [Seat:Default]

You have to go to it and add

Also keep in mind that you should also search on search engines like Duckduckgo or Whoogle to save time. It is a common request on many LXQT Forums, so you can easily get it.

1 Like

[Seat:*]
#type=local
#pam-service=lightdm
#pam-autologin-service=lightdm-autologin
#pam-greeter-service=lightdm-greeter
#xserver-command=X
#xmir-command=Xmir
#xserver-config=
#xserver-layout=
#xserver-allow-tcp=false
#xserver-share=true
#xserver-hostname=
#xserver-display-number=
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
greeter-setup-script=/usr/bin/numlockx
greeter-session=lightdm-slick-greeter
#greeter-hide-users=false
#greeter-allow-guest=true
#greeter-show-manual-login=false
#greeter-show-remote-login=true
#user-session=default
#allow-user-switching=true
#allow-guest=true
#guest-session=
session-wrapper=/etc/lightdm/Xsession
#greeter-wrapper=
#guest-wrapper=
#display-setup-script=
#display-stopped-script=
#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=

Is it correct?

1 Like

I think so.
So, is it working?

No it do not work. thanks for help. i will keep trying.

Yep, I use lxqt. Lxqt uses sddm as display manager so lightdm don't matter here. :innocent:

To enable NumLock set Numlock to false in /etc/sddm.conf like this:

[General]
Numlock=false

4 Likes

Tried with Numlock=false and Numlock=on seperately..the keyboard layout also changed to English(us) default. But it did not work. :grin:

It works for me :thinking:

make sure NumLock=on is not commented and under the [General] section.

here is my sddm.conf..Please rely with corrected one..I will copy, paste it . Thanks

[Autologin]
Relogin=false
Session=
User=

[General]
Numlock=false
Session=
HaltCommand=/usr/bin/systemctl poweroff
RebootCommand=/usr/bin/systemctl reboot

[Theme]
Current=breeze

[Users]
MaximumUid=60000
MinimumUid=1000

Try Numlock=on

1 Like

Tried it "numlock=on" also.

n should be capital N

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.