Now, output device resets on suspend =p

possibly related to this other problem, which seems to have been solved… every time I turn on or come back from suspension, the output device resets from HDMI/DP audio output to the internal device output… Any ideas?

System:
  Kernel: 6.9.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1 clocksource: tsc
    avail: acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=5309dd87-249f-4b46-97cc-d3e9694e11ac rw rootflags=subvol=@ quiet
    resume=UUID=2bc0ab3f-115d-4d02-8834-b9c9e5ffcd56 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.3.0 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Laptop System: Dell product: G5 5590 v: N/A serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Dell model: 0CNDTP v: A04 serial: <superuser required> part-nu: 08EA
    uuid: <superuser required> UEFI: Dell v: 1.13.2 date: 05/22/2020
Battery:
  ID-1: BAT0 charge: 43.6 Wh (100.0%) condition: 43.6/60.0 Wh (72.6%) volts: 16.3 min: 15.2
    model: SMP DELL JJPFK87 type: Li-poly serial: <filter> status: full
CPU:
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake gen: core 9 level: v3
    note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 0xA (10)
    microcode: 0xF6
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 3999 high: 4003 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 4000 2: 4000 3: 4000 4: 4003 5: 4000 6: 4001 7: 4002 8: 4000
    9: 4000 10: 4000 11: 4000 12: 3990 bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: none off: eDP-1 empty: DP-2,
    DP-3, HDMI-A-2, HDMI-A-3 bus-ID: 0000:00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Dell driver: nvidia v: 550.90.07
    alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of 2024-04; EOL~2026-12-xx)
    arch: Turing code: TUxxx process: TSMC 12nm FF built: 2018-2022 ports: active: none
    off: DP-1,HDMI-A-1 empty: none bus-ID: 0000:01:00.0 chip-ID: 10de:1f11 class-ID: 0300
  Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0c45:671f class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
    gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x2160 s-dpi: 96 s-size: 675x570mm (26.57x22.44") s-diag: 883mm (34.78")
  Monitor-1: DP-1 mapped: DP-1-0 note: disabled pos: primary,top model: LG (GoldStar) HDR WFHD
    serial: <filter> built: 2018 res: 2560x1080 hz: 60 dpi: 81 gamma: 1.2
    size: 798x334mm (31.42x13.15") diag: 869mm (34.2") modes: max: 2560x1080 min: 640x480
  Monitor-2: HDMI-A-1 mapped: HDMI-1-0 note: disabled pos: bottom model: LG (GoldStar) ULTRAWIDE
    serial: <filter> built: 2013 res: 2560x1080 hz: 60 dpi: 96 gamma: 1.2
    size: 677x290mm (26.65x11.42") diag: 628mm (24.7") modes: max: 2560x1080 min: 640x480
  Monitor-3: eDP-1 note: disabled model: BOE Display 0x084a built: 2018 res: 2560x1080 dpi: 142
    gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: iris device: 3 drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: iris
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.1-arch1.1 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL GT2) device-ID: 8086:3e9b
    memory: 7.53 GiB unified: yes
  API: Vulkan v: 1.3.279 layers: 9 device: 0 type: integrated-gpu name: Intel UHD Graphics 630
    (CFL GT2) driver: mesa intel v: 24.1.1-arch1.1 device-ID: 8086:3
e9b surfaces: xcb,xlib
    device: 1 type: discrete-gpu name: NVIDIA GeForce RTX 2060 driver: nvidia v: 550.90.07
    device-ID: 10de:1f11 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe (LLVM 17.0.6 256
    bits) driver: mesa llvmpipe v: 24.1.1-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl, snd_soc_avs, snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  Device-3: Realtek USB Audio driver: snd-usb-audio type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
    mode: 2.0 bus-ID: 1-4.5:4 chip-ID: 0bda:4014 class-ID: 0102 serial: <filter>
  API: ALSA v: k6.9.5-zen1-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek vendor: Dell driver: r8169 v: kernel port: 3000 bus-ID: 0000:3b:00.0
    chip-ID: 10ec:2502 class-ID: 0200
  IF: enp59s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell
    driver: ath10k_pci v: kernel bus-ID: 0000:3c:00.0 chip-ID: 168c:003e class-ID: 0280
  IF: wlp60s0 state: down mac: <filter>
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB rev: 3.0
    speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 6-1.2:3 chip-ID: 0bda:8153 class-ID: 0000
    serial: <filter>
  IF: enp58s0u1u2 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: br-6bfe65abf195 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  IF-ID-3: veth5c4ba1d state: up speed: 10000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 1-14:7 chip-ID: 0cf3:e007 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2 lmp-v: 8 status:
    discoverable: no pairing: no class-ID: 6c010c
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: intel_nvme_remap v: N/A
    port: 5060 bus-ID: 0000:00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:
  Local Storage: total: 1.14 TiB used: 925.64 GiB (79.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520 NVMe WDC 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B tech: SSD serial: <filter>
    fw-rev: 20240012 temp: 44.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-75Z10T3 size: 931.51 GiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 4514 scheme: GPT
Partition:
  ID-1: / raw-size: 39.74 GiB size: 39.74 GiB (100.00%) used: 31.73 GiB (79.9%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 620 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 181.46 GiB size: 181.46 GiB (100.00%) used: 120.25 GiB (66.3%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 39.74 GiB size: 39.74 GiB (100.00%) used: 31.73 GiB (79.9%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 39.74 GiB size: 39.74 GiB (100.00%) used: 31.73 GiB (79.9%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.43 GiB used: 512 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
  ID
-2: swap-2 type: partition size: 16.98 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 74.0 C pch: 72.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB available: 15.43 GiB used: 7.57 GiB (49.1%)
  Processes: 363 Power: uptime: 40m states: freeze,mem,disk suspend: s2idle avail: deep
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 6.13 GiB
    services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd v: 256
    default: graphical tool: systemctl
  Packages: 1915 pm: pacman pkgs: 1907 libs: 528 tools: octopi,paru pm: flatpak pkgs: 8
    Compilers: clang: 17.0.6 gcc: 14.1.1 Client: shell wrapper v: 5.2.26-release inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-03-11
  Last full system update: 2024-06-18
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.