Notifications opening on different desktop

After doing todays updates When I close a browser tab and Cookie AutoDelete deletes the cookies for that tab it’s notification to inform it it has done so opens on my Applications desktop switching me to that desktop and away from the Internet desktop. I have not tested with other programs to see if the behavior is with all notifications or nor. I’m assuming that it is. Anyone else run into this and perhaps have suggestions on fixing it?

Settings are main panel at the top and notifications to appear in the bottom right-hand corner. Thanks

~  garuda-inxi                                                                                 ✔  12:07:15
System:
Kernel: 6.9.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=67fa465d-cdbb-4ff0-b9b7-9ddf6577d903 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.1.0 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_x11 with: krunner vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: TUF GAMING B550-PLUS WIFI II v: Rev X.0x
serial: <superuser required> part-nu: SKU uuid: <superuser required>
UEFI: American Megatrends v: 3405 date: 12/13/2023
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K360
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 7 5700X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 2 microcode: 0xA20120E
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3956 high: 4641 min/max: 2200/4662 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4237 2: 3692
3: 3783 4: 4641 5: 3400 6: 4610 7: 3400 8: 3908 9: 4453 10: 3932 11: 3400
12: 4594 13: 3664 14: 3709 15: 3400 16: 4476 bogomips: 108590
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: ASUSTeK
driver: nvidia v: 550.90.07 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-06; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: none off: HDMI-A-1 empty: DP-1,DP-2,DP-3
bus-ID: 0a:00.0 chip-ID: 10de:2504 class-ID: 0300
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1080 s-dpi: 97 s-size: 670x283mm (26.38x11.14")
s-diag: 727mm (28.63")
Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: AOC Q2963
serial: <filter> built: 2016 res: 2560x1080 hz: 60 dpi: 97 gamma: 1.2
size: 673x284mm (26.5x11.18") diag: 730mm (28.8") modes: max: 2560x1080
min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.90.07
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
memory: 11.72 GiB
API: Vulkan v: 1.3.279 layers: 1 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3060 driver: nvidia v: 550.90.07
device-ID: 10de:2504 surfaces: xcb,xlib
Audio:
Device-1: NVIDIA GA106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0a:00.1 chip-ID: 10de:228e class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.9.5-zen1-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 07:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp7s0 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 09:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, smbd, sshd, systemd-timesyncd,
wpa_supplicant
Bluetooth:
Device-1: IMC Networks Wireless_Device driver: btusb v: 0.8 type: USB
rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 13d3:3563
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c0104
Device-2: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7.4:12 chip-ID: 8087:0029
class-ID: e001
Report: ID: hci1 rfk-id: 2 state: up address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 26.83 TiB used: 18.48 TiB (68.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000T500SSD8
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P8CR002 temp: 30.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Crucial model: CT500P3SSD8
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P9CR30A temp: 27.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: Expansion HDD
size: 7.28 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 1801 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Seagate model: Expansion HDD
size: 10.91 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 0003 scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST8000AS0002-1NA17Z
size: 7.28 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: HDD rpm: 5980
serial: <filter> scheme: GPT
Partition:
ID-1: / raw-size: 232.8 GiB size: 232.8 GiB (100.00%)
used: 56.52 GiB (24.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 1.4 MiB (0.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 232.8 GiB size: 232.8 GiB (100.00%)
used: 56.52 GiB (24.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 232.8 GiB size: 232.8 GiB (100.00%)
used: 56.52 GiB (24.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 232.8 GiB size: 232.8 GiB (100.00%)
used: 56.52 GiB (24.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 46.96 GiB used: 1.85 GiB (3.9%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 44.9 C mobo: N/A gpu: nvidia temp: 40 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Info:
Memory: total: 48 GiB available: 46.96 GiB used: 9.91 GiB (21.1%)
Processes: 555 Power: uptime: 2d 2h 43m states: freeze,mem,disk
suspend: deep avail: s2idle wakeups: 0 hibernate: platform avail: shutdown,
reboot, suspend, test_resume image: 18.74 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 256 default: graphical
tool: systemctl
Packages: 1838 pm: pacman pkgs: 1832 libs: 468 tools: pacseek,pikaur,yay
pm: flatpak pkgs: 6 pm: snap pkgs: 0 Compilers: clang: 17.0.6 gcc: 14.1.1
Shell: garuda-inxi default: Zsh v: 5.8 running-in: konsole inxi: 3.3.35
Garuda (2.6.26-1):
System install date:     2024-06-23
Last full system update: 2024-06-24 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Seems to bee a much bigger issue than I thought. Just did the reboot for those updates and I booted back to the desktop looking like the below image. Attempted to rollback to the last Snapshot from yestrerday andgot informed it was sucessful, rebooted and nothing reverted back. Still the same as the below image. Taskbar only on the Applications desktop when I press the Meta key. Browser will open on the Internet desktop but can’t get the main panel to show there. Try to launch qBittorrent launches to it’s desktop but cannot see it even though it’s tray icon suggest it is open. Something tells me this migfht have in part to do will KDE’s fake desktop session for Wayland even thought I’m on x11.

EDIT:

I have my full desktop but my panels still only show on the Applications desktop. Can rightclick the Applications desktop and get the context menu but not the other 3 desktops.

Rebooted yet?

1 Like

I stated in the first line in my post above yor that I had. I have also tried to roll back twice with rebooting afterwards to no avail.

Please use slightly more punctuation. Took me three reads to comprehend your issue :upside_down_face:

Why don’t you just disable the hideous CAD notification? It’s pretty useless

To test your issue you could just try sleep 5; notify-send "test" and then immediately switch to another desktop.

What are CAD notifications?

CAD = Cookie Auto Delete

image

That’s not the issue. The issue is with Plasma. I just ran your test from the Dolphin desktop and was taken back to the Applications desktop to show me the notification. The notification issue is now a secondary issue. The other one is more urgent to get addressed if possible.

EDIT looks like I was mistaken and the system did restore but left the issue uncorrected.

This might sound insane, but have you tried switching to Wayland since this happened? If for nothing else than to see if the issue persists.

It would also be a good test to create a new user and log in as them. If you can’t get to the GUI settings at the moment, you can use useradd from a TTY. https://wiki.archlinux.org/title/Users_and_groups#User_management

sudo useradd -m -G wheel my_cool_new_user
3 Likes

You don’t have any of the other desktops selected like in this pic below. They should be uncheck normally. It shouldn’t affect notifications I know but just to be sure.

And you have checked here as well?

can also clear the ~/.cache/plasmashell/ an log out an see if that fixes it. just a guess

Yea actually I did decide to switch to Wayland to see if it still had the same issues. At first all looked well except for my 2nd and 3rd docks not wanting to show up. Found if I add a panel it forces those two to show up and then I can remove that added panel. Seems a bit more responsive than x11 and actually did remember my open apps, but there is blinking out in the browser every few second. I’ll create a new user later and then go into x11 to see what I get.

Personally I’m willing to bet since whatever is causing the issue(s) wasn’t removed when I rolled back the sysyem it’s going to be the same under any new user I create.

@elite I can tell you for a fact that’s not the case. I am very carefull with assigning applications to their particular desktop. Plus the one suggested test when ran did the samething. As for custom location as I stated I have it set to the bottom right corner.

Creating a secondary profile actually seems to have done the trick. I have tested in x11, but not Wayland and other than adding my browser profiles back and doing my personal tweaks icluding assigning items back to their appropriate desktops all looks good so far.

No glitches in the browser, no being taken to the Applications desktop when I close out anything on another desktop that shows notifications. Notifications back to being normal size. As I said so far all looks good. Thanks

1 Like

I for one would still like to know what possibly caused this. I had installed CachyOS and over the course of a week built it up. A day later I did updates and got all the same behaviors I saw in Garuda.

CachyOS is the German version of Garuda Linux,
only not as colorful and with fewer people in the forum :wink:

3 Likes

UM NO, there is quite abit of difference. My point was that it looks like I’m right about it being something with Plasma itself, specifically Plasma 6.1.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.