No wallpaper and WiFi after recent update

after upgrading my system on Sunday, the system now no longer shows any wallpapers and I can't use WiFi, the icon no longer shows.

```
System:
Kernel: 5.18.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=fd064626-5c5f-4be1-9f81-5f6ac8b2f47d rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=d8ae0431-a1a2-48e5-b320-073dd2566394 loglevel=3
Desktop: KDE Plasma v: 5.25.0 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: HP product: HP ProDesk 600 G2 DM v: N/A
serial: <superuser required> Chassis: type: 15 serial: <superuser required>
Mobo: HP model: 8169 v: KBC Version 05.26 serial: <superuser required>
UEFI: HP v: N22 Ver. 02.09 date: 03/10/2016
CPU:
Info: model: Intel Core i5-6500T bits: 64 type: MCP arch: Skylake-S
gen: core 6 built: 2015 process: Intel 14nm family: 6 model-id: 0x5E (94)
stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3030 high: 3086 min/max: 800/3100 scaling:
driver: intel_pstate governor: performance cores: 1: 3086 2: 3000 3: 3001
4: 3034 bogomips: 19999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel HD Graphics 530 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen9 process: Intel 14n built: 2015-16 ports:
active: HDMI-A-1 empty: DP-1, DP-2, DP-3, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:1912 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI1 model: Mi Monitor serial: <filter>
built: 2020 res: 1920x1080 dpi: 92 gamma: 1.2
size: 530x290mm (20.87x11.42") diag: 603mm (23.7") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 22.1.1
direct render: Yes
Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
chip-ID: 8086:a170 class-ID: 0403
Sound Server-1: ALSA v: k5.18.5-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 16.0 running: no
Sound Server-4: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b7 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
driver: N/A bus-ID: 1-4.3:5 chip-ID: 0bda:8179 class-ID: 0000
serial: <filter>
IF-ID-1: enp0s20f0u3 state: unknown speed: -1 duplex: half mac: <filter>
Drives:
Local Storage: total: 588.73 GiB used: 129.94 GiB (22.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLB512HAJQ-000L7 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 4L2QEXA7 temp: 34.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: TCSunBow model: X3 120GB
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 8A scheme: MBR
Partition:
ID-1: / raw-size: 468.5 GiB size: 468.5 GiB (100.00%)
used: 129.94 GiB (27.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 562 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 468.5 GiB size: 468.5 GiB (100.00%)
used: 129.94 GiB (27.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 468.5 GiB size: 468.5 GiB (100.00%)
used: 129.94 GiB (27.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 468.5 GiB size: 468.5 GiB (100.00%)
used: 129.94 GiB (27.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.65 GiB used: 1.5 MiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.18 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
System Temperatures: cpu: 37.0 C pch: 43.5 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 222 Uptime: 13m wakeups: 0 Memory: 7.65 GiB
used: 3.39 GiB (44.3%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1389
lib: 347 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.18
Garuda (2.6.3-2):
System install date:     2021-09-24
Last full system update: 2022-06-19
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Timeshift (maybe)
Failed units:            bluetooth-autoconnect.service nmb.service systemd-guest-user.service
```

For the WiFi, this could be applicabile

8 Likes

thanks, the wallpaper issue now done. now left with the WiFi issue

I see in a previous inxi of yours that was actually the affected driver.
You should try the linux-lts till the 5.18.6 is released.

Please, only one problem per thread, helps the search function in the forum as well as others to solve a problem.

3 Likes

Existing recent thread with a similar problem for the same chipset:

3 Likes