No video playing suddenly

System:
  Kernel: 6.1.21-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=35a59b1d-d50f-4b12-b731-7e082a2e9e5e rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Mini-pc System: ASUSTeK product: MINIPC PN52 v: N/A
    serial: <superuser required>
  Mobo: ASUSTeK model: PN52 v: Rev 1.xx serial: <superuser required>
    UEFI: American Megatrends v: 11300 date: 06/15/2022
CPU:
  Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1231 high: 1396 min/max: 1200/4462 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1202 2: 1200
    3: 1200 4: 1300 5: 1201 6: 1200 7: 1197 8: 1202 9: 1197 10: 1200 11: 1227
    12: 1268 13: 1396 14: 1314 15: 1196 16: 1200 bogomips: 102241
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel arch: GCN-5 code: Vega process: GF 14nm
    built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s ports: active: DP-2 empty: DP-1,HDMI-A-1,HDMI-A-2
    bus-ID: 05:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 46.0 C
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.00x12.48")
    s-diag: 599mm (23.57")
  Monitor-1: DP-2 mapped: DisplayPort-1 model: Dell U2412M serial: <filter>
    built: 2012 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 518x324mm (20.39x12.76") diag: 611mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 720x400
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
    missing.
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
    snd_sof_amd_rembrandt pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max:
    gen: 4 speed: 16 GT/s bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 05:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound API: ALSA v: k6.1.21-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.67 running: yes
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 02:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    vendor: Foxconn driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 03:00.0 chip-ID: 14c3:0616 class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
Bluetooth:
  Device-1: Foxconn / Hon Hai Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 5-3:3 chip-ID: 0489:e0e2 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 2.27 TiB used: 523.58 GiB (22.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S500G
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: SBJ00101 temp: 36.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: SSD size: 931.51 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 1010 scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate
    model: ST1000LM 048-2E7172 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B type: N/A serial: <filter> rev: 0204 scheme: GPT
Partition:
  ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 20.98 GiB (4.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 857.51 GiB size: 842.98 GiB (98.31%)
    used: 502.61 GiB (59.6%) fs: ext4 block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3
  ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 20.98 GiB (4.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 20.98 GiB (4.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 62.21 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 24 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2
Sensors:
  System Temperatures: cpu: 51.5 C mobo: N/A gpu: amdgpu temp: 47.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 428 Uptime: 2h 2m wakeups: 0 Memory: 62.21 GiB
  used: 7.84 GiB (12.6%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1490
  libs: 402 tools: gnome-software,octopi,pamac,paru Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.25
Garuda (2.6.16-1):
  System install date:     2023-01-26
  Last full system update: 2023-03-24
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected

Yesterday I could watch any videos on Internet, Youtube etc and the sound was working too. I was trying to use Skype and Zoom for a meeting had scheduled and found out that my mic and my video camera did not work, so I tried to install Pulse audio (that i remembered from a week ago when I have Linux Mint on another computer) and found it and installed it, but when I tried to open Pulse audio I only found the regular audio program and not Pulse audio. After having to sleep last night, the video did not work today, not on Firefox and not Brave (my standard browser) I'm not very tech savy so have not much clue of what more to do. Tried to update Garuda but got another error message that i don't know what it means.

1 Like

I tried to install Pulse audio

no no no no not this again....!!!

Kick that off your system... sudo pacman -Rns pulseaudio and reboot

You are already running pipewire... Installing pulseaudio will just break everything.

This will probably not be enough. I recently had a friend do the same, which took about 30 minutes to fix because there are so many things breaking if you install pulseaudio. Please report back if it works.

The video playback was likely related to jamesdsp. Disable that in the settings

3 Likes

Well, Garuda and this system is all new to me... :wink: I tried to remove it but it didn't work, I got this error instead. (oh sorry, I can't upload to screenpic bc I'm new here...) well, I got this error: FEL: Kunde inte förbereda transaktionen (kunde inte tillfredsställa beroenden)
:: Att ta bort pulseaudio förstör beroendet 'pulseaudio=16.1-6' som krävs avpulseaudio-equalizer
:: Att ta bort pulseaudio förstör beroendet 'pulseaudio=16.1-6' som krävs avpulseaudio-jack
It says to remove Pulseaudio destroys the dependency that is needed for ...

what is that? What did you install???

As I said, I tried to solve the problem with no sound on my mic and no video from my side, so I thought I installed Pulseaudio that I had in Mint where everything worked fine. So I thought this was Pulseaudio.

try a sudo pacman -Rnsuc pulseaudio

Full disclaimer: This can very well be one of the most destructive commands if you run it on the wrong package.

Only run it if it removes pulseaudio stuff. Cancel it if it removes important packages

3 Likes

So bf I run it, how do I know it's the right package, as a noob? :wink:

it should remove pulseaudio, this avpulseaudio stuff and maybe a few libraries. Nothing more

It will remove these, looks ok to me...
:: firefox beror valfritt av pulseaudio: Audio support
:: pavucontrol beror valfritt av pulseaudio: Audio backend
:: speech-dispatcher beror valfritt av pulseaudio: PulseAudio support

Paket (3) pulseaudio-equalizer-16.1-6 pulseaudio-jack-16.1-6
pulseaudio-16.1-6

yeah fine get rid of that and reboot. If you are in luck, everything will work.

ok, good, cross my fingers and will update here.

Your suggestion worked very well, thank you so much! I'll be more careful when I try to solve things in the future. :slightly_smiling_face:
I suppose I will need to create a new post for next problem (that I tried to correct in this bad way)?

if you still face audio issues caused by that pulseaudio installation, just post them here

Well I figured out my video issue and that is working now. I'm wondering if the sound issue has to do with the jack and cable to the pc? (ah, again, can't upload pic here)...difficult to explain... I have a headset with two cables to connect to a pc. One is mic and one is speakers. In my old pc (Linux Mint debian) I only used the speakers connection to the pc since there was only one outlet and that worked for both speaking and listen. Now I have the same connection in my new...

Please mark always the solution and not your implementation.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.