No video display after installing Vulkan driver

System:
  Kernel: 5.19.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=1db70d98-337a-4a96-9288-2c25246933a8
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Console: tty 2 DM: greetd Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Hewlett-Packard product: HP Pavilion 14 Notebook PC
    v: 0887100000005E00000600000 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 216A v: 30.26 serial: <superuser required> UEFI: Insyde v: F.19
    date: 07/14/2016
Battery:
  ID-1: BAT0 charge: 26.5 Wh (100.0%) condition: 26.5/26.5 Wh (100.0%) volts: 16.6 min: 14.8
    model: Hewlett-Packard Primary type: Li-ion serial: N/A status: full
CPU:
  Info: model: AMD A10-5745M APU with Radeon HD Graphics bits: 64 type: MT MCP arch: Piledriver
    built: 2012-13 process: GF 32nm family: 0x15 (21) model-id: 0x13 (19) stepping: 1
    microcode: 0x6001119
  Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 192 KiB desc: d-4x16 KiB; i-2x64 KiB
    L2: 4 MiB desc: 2x2 MiB
  Speed (MHz): avg: 1196 high: 1500 min/max: 1100/2100 boost: enabled scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 1500 2: 1100 3: 1100 4: 1085 bogomips: 16769
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling, PBRSB-eIBRS: Not
    affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Richland [Radeon HD 8610G] vendor: Hewlett-Packard driver: radeon v: kernel
    alternate: amdgpu arch: TeraScale-3 code: Northern Islands process: TSMC 32nm built: 2010-13
    ports: active: eDP-1 empty: HDMI-A-1,VGA-1 bus-ID: 00:01.0 chip-ID: 1002:990f class-ID: 0300
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon 520 Mobile]
    vendor: Hewlett-Packard driver: radeon v: kernel alternate: amdgpu arch: GCN-1
    code: Southern Islands process: TSMC 28nm built: 2011-20 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 8 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 1002:6660 class-ID: 0380
  Device-3: Cheng Uei Precision Industry (Foxlink) SunplusIT HP Truevision HD Webcam type: USB
    driver: uvcvideo bus-ID: 2-4:2 chip-ID: 05c8:0361 class-ID: 0e02
  Display: server: Xwayland v: 22.1.3 driver: gpu: radeon note:  X driver n/a tty: 136x38
  Monitor-1: eDP-1 model: LG Display 0x03b3 built: 2012 res: 1366x768 dpi: 112 gamma: 1.2
    size: 309x174mm (12.17x6.85") diag: 355mm (14") ratio: 16:9 modes: max: 1366x768 min: 640x480
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Trinity HDMI Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    bus-ID: 00:01.1 chip-ID: 1002:9902 class-ID: 0403
  Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
  Sound Server-1: ALSA v: k5.19.2-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.56 running: no
Network:
  Device-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard driver: rt2800pci
    v: 2.3.0 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 1814:3290
    class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8136
    class-ID: 0200
  IF: eno1 state: down mac: <filter>
Bluetooth:
  Device-1: Ralink RT3290 Bluetooth vendor: Hewlett-Packard driver: N/A pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.1 chip-ID: 1814:3298 class-ID: 0d11
  Report: bt-service: enabled,stopped note: tool can't run
Drives:
  Local Storage: total: 223.57 GiB used: 12.04 GiB (5.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G size: 223.57 GiB block-size:
    physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 0000 scheme: GPT
Partition:
  ID-1: / raw-size: 174.07 GiB size: 174.07 GiB (100.00%) used: 12.02 GiB (6.9%) fs: btrfs
    dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 25.5 MiB (26.6%) fs: vfat
    dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 174.07 GiB size: 174.07 GiB (100.00%) used: 12.02 GiB (6.9%) fs: btrfs
    dev: /dev/sda5 maj-min: 8:5
  ID-4: /var/log raw-size: 174.07 GiB size: 174.07 GiB (100.00%) used: 12.02 GiB (6.9%)
    fs: btrfs dev: /dev/sda5 maj-min: 8:5
  ID-5: /var/tmp raw-size: 174.07 GiB size: 174.07 GiB (100.00%) used: 12.02 GiB (6.9%)
    fs: btrfs dev: /dev/sda5 maj-min: 8:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 6.97 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 43.8 C mobo: N/A
  Fan Speeds (RPM): N/A
  GPU: device: radeon temp: 47.0 C device: radeon temp: 43.0 C
Info:
  Processes: 140 Uptime: 3m wakeups: 1 Memory: 6.97 GiB used: 517.7 MiB (7.3%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6 Packages:
  pacman: 1264 lib: 312 Shell: Bash v: 5.1.16 running-in: tty 2 inxi: 3.3.20
e[1;34mGaruda (2.6.6-1):e[0m
e[1;34m  System install date:e[0m     2022-08-15
e[1;34m  Last full system update:e[0m 2022-08-18
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m Probably (Run as root to verify)
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m greetd.service

I was trying to run Godot 4 on my notebook. Godot said it needed Vulkan support, so I tried installing the Vulkan drivers from Vulkan - ArchWiki. I installed vulkan-radeon and vulkan-icd-loader. I restarted the computer and tried running Godot, it didn't work, so I installed lib32-vulkan-icd-loader and restarted the computer, after that I I'm always presented with a black screen instead of the login screen.
I tried running set AMD_VULKAN_ICD=RADV on console and rebooting but it didn't make difference.

When I run vulkaninfo I have this errors:

'DISPLAY' environment variable not set... skipping surface info
ERROR: [../mesa-22.1.6/src/amd/vulkan/radv_device.c:627] Code 0 : Device '/dev/dri/renderD129' is not using the AMDGPU kernel driver: Invalid argument (VK_ERROR_INCOMPATIBLE_DRIVER)
ERROR: [../mesa-22.1.6/src/amd/vulkan/radv_device.c:627] Code 0 : Device '/dev/dri/renderD128' is not using the AMDGPU kernel driver: Invalid argument (VK_ERROR_INCOMPATIBLE_DRIVER)
ERROR: [Loader Message] Code 0 : setup_loader_term_phys_devs:  Failed to detect any valid GPUs in the current config
ERROR at /build/vulkan-tools/src/Vulkan-Tools-1.3.217/vulkaninfo/vulkaninfo.h:231:vkEnumeratePhysicalDevices failed with ERROR_INITIALIZATION_FAILED

Any idea on how to fix this?

I don't think you want lib32-vulkan-icd-loader.

1 Like

Or you may need to install lib32-vulkan-radeon as well.

1 Like

I tried uninstalling lib32-vulkan-icd-loader and I think I don't have to:

checking dependencies...
:: removing lib32-vulkan-icd-loader breaks dependency 'lib32-vulkan-icd-loader' required by lib32-mesa
:: removing lib32-vulkan-icd-loader breaks dependency 'lib32-vulkan-icd-loader' required by mhwd-garuda-git

I suspect this isn't going to help - maybe try enabling amdgpu for this GPU? https://wiki.archlinux.org/title/AMDGPU#Enable_Southern_Islands_(SI)and_Sea_Islands(CIK)_support

1 Like

I followed those steps and then after generating the new InitramFS I could boot into GUI.

Also Vulkan seems to be set up OK because running vulkaninfo displays Vulcan information instead of errors.

I tried opening Godot and my PC froze though and I got a pure black screen.

1 Like

Your laptop is a decade old at this point, so it might just be time for an upgrade?

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.