No sound after reinstalling Pulseaudio

Greetings Garuda users;

After reinstalling Pulseaudio after unsolvable issues with Pipewire (mainly cackling and distortion when the volume peaked in every application), the sound system ALSA failed to open a slave PCM signal, returning the following error upon using aplay for testing:

aplay "/path/to/music/file.mp3"
ALSA lib pcm_dmix.c:999:(snd_pcm_dmix_open) unable to open slave
aplay: main:834: audio open error: No such file or directory

My laptop has an IDT soundcard, which has been proven fussy to setup even on Windows systems, maybe it's something related?

The garuda-inxi out:

System:
  Kernel: 6.1.50-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=fe4bf09f-7ee8-4b8c-b7d5-e0364790b11c rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
    ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Hewlett-Packard product: HP ProBook 655 G1
    v: A3008DD11303 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 1992 v: KBC Version 05.34
    serial: <superuser required> UEFI: Hewlett-Packard v: L72 Ver. 01.47
    date: 07/30/2018
CPU:
  Info: model: AMD A8-5550M APU with Radeon HD Graphics bits: 64 type: MT MCP
    arch: Piledriver level: v2 built: 2012-13 process: GF 32nm family: 0x15 (21)
    model-id: 0x13 (19) stepping: 1 microcode: 0x600111F
  Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 192 KiB
    desc: d-4x16 KiB; i-2x64 KiB L2: 4 MiB desc: 2x2 MiB
  Speed (MHz): avg: 1908 high: 2053 min/max: 1400/2100 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 1872 2: 2030
    3: 2053 4: 1678 bogomips: 16776
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Richland [Radeon HD 8550G] vendor: Hewlett-Packard
    driver: radeon v: kernel alternate: amdgpu arch: TeraScale-3
    code: Northern Islands process: TSMC 32nm built: 2010-13 ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:01.0
    chip-ID: 1002:990d class-ID: 0300
  Device-2: Cheng Uei Precision Industry (Foxlink) HP HD Webcam
    driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
    bus-ID: 1-5:3 chip-ID: 05c8:0369 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: radeon unloaded: modesetting alternate: fbdev,vesa dri: r600
    gpu: radeon display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 mapped: eDP model: Samsung 0x4851 built: 2012
    res: 1366x768 hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: max: 1366x768 min: 640x480
  API: OpenGL v: 4.5 Mesa 23.1.6-arch1.4 renderer: AMD ARUBA (DRM 2.50.0 /
    6.1.50-1-lts LLVM 16.0.6) direct-render: Yes
Audio:
  Device-1: AMD Trinity HDMI Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:9902
    class-ID: 0403
  Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel
    v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
  API: ALSA v: k6.1.50-1-lts status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module
    tools: pacat,pactl,pamixer,pavucontrol
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 4000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Broadcom BCM43228 802.11a/b/g/n driver: wl v: kernel
    modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 14e4:4359 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-3: KYE Systems (Mouse Systems) GF3000F Ethernet Adapter
    driver: hid-generic,usbhid type: USB rev: 1.1 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 8-2.2:3 chip-ID: 0458:6001 class-ID: 0301
Bluetooth:
  Device-1: Broadcom HP Portable Bumble Bee driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-3:2 chip-ID: 0a5c:21f1
    class-ID: fe01 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 4.0
    lmp-v: 6 status: discoverable: no pairing: no class-ID: 10010c
Drives:
  Local Storage: total: 465.76 GiB used: 126.01 GiB (27.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 032 scheme: GPT
Partition:
  ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 126.01 GiB (27.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 126.01 GiB (27.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 126.01 GiB (27.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 126.01 GiB (27.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 6.97 GiB used: 512 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: radeon temp: 40.0 C
  Fan Speeds (rpm): N/A
Info:
  Processes: 236 Uptime: 18m wakeups: 1 Memory: total: 8 GiB note: est.
  available: 6.97 GiB used: 2.35 GiB (33.7%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1961 libs: 524 tools: octopi,pamac,paru,yay pm: rpm pkgs: 0
  Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.29
Garuda (2.6.16-1):
  System install date:     2023-05-01
  Last full system update: 2023-09-01 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

It also makes web browsers such as Firefox crash upon loading a video or playing files, any guidance of how to fix this issue?
Thank you in advance!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.